View Full Version : Start of next album track plays in error

2008-02-26, 06:17
Having spent a good 45 minutes unsuccessfully searching the forum and bugzilla for some other posting on this, I'm writing it up myself. Apologies if it's already covered (tell me what search terms you used to find it). I am currently running 6.5.5 Mac OS X 10.4.x, but I have been getting this issue forever, including when I used to run a Linux box.

Often, but not always, when playing a list containing individual tracks from several albums, the system plays the current song for too long, such that the start of the next track on the album is heard before the start of the next track in the playlist.

The current track plays out, you hear the pause after the track and then a snatch of the start of the next track on the album. You then hear that instantly replaced by the start of the next playlist item, which plays normally.

For example, if the playlist contains album A track n, followed immediately by Album B track p, you hear the end of Album A track n, pause, the start of Album A track n+1, then Album B track p immediately starts and plays out normally.

This is the case EVEN IF THE TWO TRACKS ARE FROM THE SAME ALBUM PLAYING IN SEQUENCE, ie if the playlist contains album A track n followed immediately by Album A track n+1, you hear the end of track n, pause, the start of track n+1, then track n+1 immediately starts again and plays out normally.

Most of my library is in FLAC format, and I wonder if this is part of the problem? Unfortunately the problem does not occur EVERY time and I have relatively few mp3 files, so it's hard to tell.

Yes, I have tried rebuilding the library etc etc etc.

Thoughts, anyone?
--Richard E

2008-02-26, 06:38
Have you confirmed the problem isn't your files? For example, have you listened to the ends of them in some other player? Are you using single file + cue sheets or individual files per track?

I can't think of a good reason why SS would start playing a new file which wasn't the next one on the playlist, seems very arbitrary.

2008-02-26, 08:25
Unfortunately, I think yours is an isolated problem. i too run osx 10.4.x with SS 6.5.4 and most of my library is flac but I've never encountered your problem.

Has there ever been a version of ss that worked correctly for you?

2008-03-01, 05:11
Thanks for the comments.

I have checked the end of some sample files and they do not include snippets of the next track. They play fine in other apps. Though that's what it sounds like!

I do not recall a version of SS which ever worked correctly for me in this respect, whether Linux or Mac OS X.

--Richard E