PDA

View Full Version : Squeezebox > Problem: Can't open file for...



Wparent
2008-02-23, 09:57
Hi all,

Have a Squeezebox and SlimServer running on a server with Linux ClarkConnect on it. I've copied my music to a music map on the server, SlimServer is able to see the map and it's announcing all the music files on the Squeezebox.
When U push play, it's gives the error above.

I set up all users and other users to have RW access to the music map, but also that didn't help.

Does anyone know what to do?

Siduhe
2008-02-23, 11:28
Sounds like a permissions issue - you don't say which version of Slimserver, but I'm going to assume 6.5 branch? Does user "slimserver" have read access to the actual music files?

The files need to be 644 (rw-r--r--) and directories 755 (rhxr-xr-x) I believe.

Wparent
2008-02-24, 07:53
Sounds like a permissions issue - you don't say which version of Slimserver, but I'm going to assume 6.5 branch? Does user "slimserver" have read access to the actual music files?

The files need to be 644 (rw-r--r--) and directories 755 (rhxr-xr-x) I believe.

Hi there,

Found the problem. I've set up the rights for the entire musicmap. But the submaps does not aim that rights from the capital music map.

Is there a way to give rights to de capital map AND all of the submaps?

dantal
2008-02-29, 14:33
I'm not 100% sure what you are asking, but open a terminal window, or console window change directories to you music folder and enter a command like:

chmod -R 755 .


This will add an extra execute flag to the files but the directories need it for searching. And it is simpler than the alternatives.

bhaagensen
2008-02-29, 15:09
chmod -R 755 .


This will add an extra execute flag to the files but the directories need it for searching. And it is simpler than the alternatives.

One way of avoiding that:

'find . -type f -exec chmod 755 {} \;'