PDA

View Full Version : No automatic standby



michel
2008-02-22, 04:23
I am running a dedicated fileserver and slimserver PC on XP. Under SS 6.5 I had more or less no problems with the PC going into standby when running idle for 20'.
After upgrading to 7.0 the computer does standby as it used to when wakened up by another PC (Magic Packet) and no slimserver action executed.
When wakened by a SB3 it does not go to standby when idle.
Did someone else observe this strange behavior?

P.S.: I am running SqeezeCenter as service.

sunset-squeeze
2008-03-21, 18:01
I have noticed the same thing with a similar setup (Squeeze Center 7.0 running as service under XP). I never looked at this under 6.5. My computer will go to standby if my SB3 is off for 30 minutes after I last do something on the keyboard. But if its in Standby, and I wake it up from the SB3 and then turn the SB3 off, it does not go back to Standby. I going to see if I get better results with Squeeze Center running as an application.

Zaragon
2008-03-22, 03:50
There have been some other threads on this. I seem to remember particularly on the correct configuration of Wake On LAN on ethernet cards. Whilst I don't know of what changes may have been made in respect of V7 it could be worth you doing a forum search to see what the outcomes were.

sunset-squeeze
2008-03-22, 10:55
Thanks. I looked at the other threads but found no help.
Also running Squeeze Center 7 as an application did not help.
To summarize the situation,

Here's what works:
1. PC will automatically Standby if SB3 is Off (with Clock screensaver), after you use PC keyboard.
2. PC does not go to Standby while SB3 is playing music.
3. PC can be manually put to Standby if SB3 is Off.
4. PC in Standby can be sucessfully woken by pressing SB3 Power button. (PC is configured to only awaken w. Magic Packet)

Here's the one thing that doesn't work:
If PC in Standby is awoken from SB3, it will not time out and automatically go to Standby after SB3 is turned off (assuming no use of the PC keyboard).

Can anyone verify that this works for them with SqueezeCenter 7 and SB3?

tamanaco
2008-03-22, 15:35
Here's the one thing that doesn't work:
If PC in Standby is awoken from SB3, it will not time out and automatically go to Standby after SB3 is turned off (assuming no use of the PC keyboard).

Can anyone verify that this works for them with SqueezeCenter 7 and SB3?

If I understand you correctly, after you wake up the PC with the WOL's Magic Packet... the PC goes into standby mode after you turn off the SB3 and before the pre-defined time out setting in Advanced Power Management. If this is the case, you "might" be suffering from "WOL's 2 Minute Standby Syndrome". Whenver you wake up a Windows PC using WOL and there is no application to prevent standby or no mouse/keyboard activity the PC goes back to sleep in two minutes. Note that this is no the case if the Windows PC is brought out of standby using other methods.

See: http://support.microsoft.com/kb/810719

I use a free application called WakeUP 1.6 (google it) to prevent my server from going into standby mode after using WOL. I set it so that my server remains awake if there is a connection in some TCP ports, namely 3389 Remote Desktop, 3483 SB3, 9000 SC7 Web UI and 9090 CLI.

I hope this helps.

MadScientist
2008-03-23, 04:21
I use a free application called WakeUP 1.6 (google it) to prevent my server from going into standby mode after using WOL. I set it so that my server remains awake if there is a connection in some TCP ports, namely 3389 Remote Desktop, 3483 SB3, 9000 SC7 Web UI and 9090 CLI.

I hope this helps.

I have the 'sleep after 2 min inactivity' problem and am interested in how you got around it. I had a look at Wakeup 1.6 but this seems to be just a program for remotely waking other computers. Have I missed something? Is there an English manual anywhere?

Thanks

Cliff

sunset-squeeze
2008-03-23, 07:26
My problem is not that it goes to sleep when it shouldn't.

Its that it won't automatically timeout and go to sleep when it should.

I think I found an answer. I found that I got better results by turning off the Intel "Quick Resume" function under Windows Power Management. This is part of the Intel's "Viiv" technology. A google search revealed a known issue(#5409) for Viiv at http://downloadmirror.intel.com/12128/ENG/Release_1523.htm,

"The system will not timeout to Hibernation or Standby via the system inactivity timer if the system has awakened to Quick Resume mode from Hibernation or Standby from a programmed video recording or a wake on LAN event .
Workaround: Wake the system to S0 via the mouse or keyboard and then allow the inactivity timer to expire or manually put the system in to Hibernation or Standby."

This seems to fit the problem I originally reported. As far as I can tell, Intel has not fixed this issue.

tamanaco
2008-03-23, 08:52
I have the 'sleep after 2 min inactivity' problem and am interested in how you got around it. I had a look at Wakeup 1.6 but this seems to be just a program for remotely waking other computers. Have I missed something? Is there an English manual anywhere?

Thanks

Cliff

Cliff, I got WakeUP 1.6 from here http://noeld.com/programs.asp?cat=dstools#wakeup

I think that the version depicted in the web page is an earlier version and does not show the prevent-stanby on port activity option. Below you can see how I configured Wakeup to prevent my server from going to sleep when there is activity on certain TCP ports.

MadScientist
2008-03-23, 11:35
Tamanaco, Many thanks for this. I was looking at the wrong program. I'll give it a go - this problem has been bugging me for a long time.

MadScientist
2008-03-24, 01:03
Michel

I assume under the nic power management that you have tbe 'only allow management stations to wake' box ticked? Not enforcing this option is the only time I'm had problems with my XP machine staying awake.

tamanaco
2008-03-24, 06:12
Michel

I assume under the nic power management that you have tbe 'only allow management stations to wake' box ticked? Not enforcing this option is the only time I'm had problems with my XP machine staying awake.


Yes, I have that option selected. The issue is that the brilliant developers at Microsoft did not provide for a configurable/variable time-out option for standby after WOL. There is only a "fixed default" time-out of 2 minutes.