PDA

View Full Version : Slimproto error, length 2003



Olaf Lenzmann
2004-02-09, 13:14
At the moment, my setup is screwed so much that the server process dies
immediately when it makes the first connection to the squeezebox.
Attached the tcpdump (actually windump) logs for 3 attempts. If the
attachments do not go through the mailing list, let me know how to send
those to you.

The last lines of the server log on d_select and d_slimproto read:

2004-02-09 21:09:03.8750 select returns (0): reads: of 4 writes: of 0
err:
2004-02-09 21:09:03.8906 select returns (0): reads: of 4 writes: of 0
err:
2004-02-09 21:09:03.8906 select returns (0): reads: of 4 writes: of 0
err:
2004-02-09 21:09:03.8906 select returns (0): reads: of 4 writes: of 0
err:
2004-02-09 21:09:03.9062 select returns (0): reads: of 4 writes: of 0
err:
2004-02-09 21:09:03.9531 select returns (0): reads: of 4 writes: of 0
err:
2004-02-09 21:09:04.0000 select returns (0): reads: 1 of 4 writes: 0 of
0 err: 0
2004-02-09 21:09:04.0625 adding select read
IO::Socket::INET=GLOB(0x2f3347c) CODE(0x2b60cb0)
2004-02-09 21:09:04.0625 Slimproto accepted connection from:
192.168.0.102
2004-02-09 21:09:04.1093 select returns (0): reads: 1 of 5 writes: 0 of
0 err: 0


-----Original Message-----
From: Sean Adams [mailto:sadams (AT) slimdevices (DOT) com]
Sent: Montag, 9. Februar 2004 17:12
To: Slim Devices Discussion
Subject: [slim] Slimproto error, length 2003



The control channel uses a very simple framing protocol which is just
<4 bytes frame type><4 bytes length><n bytes data...>

The message that you're seeing is the squeezebox failing a sanity check
on the incoming control stream. Probably this is not a networking
issue, but rather something is awry on the server, perhaps in
slimproto.pm

If you can send me a packet dump (tcpdump -s 0 -w dumpfile) I'd
appreciate it.



On Feb 9, 2004, at 5:10 AM, Olaf Lenzmann wrote:

> I use the CVS sources from (I think) Monday last week; running
> ActiveState
> Perl 5.8.0 on a Windows XP SP1 machine, which is connected via
> Ethernet to
> my WLAN router. Squeezebox connects wireless. No firewalling or
> filtering
> is used in the network (except on the internet, of course).
>
> The error occurred twice, but happens rarely. It might be a follow-on
> error
> to the server process dying in the slimproto.pm module (?)
>
> Olaf
>
>
> On 09.02.2004 0:56 Uhr, "dean blackketter" <dean (AT) slimdevices (DOT) com>
> wrote:
>
>> That's a new one. Do you have any proxy or firewall enabled that
>> could
>> be interfering with the SlimServer and the Squeezebox communicating?
>>
>> Also, post some details about your computer setup.
>>
>> -dean
>>
>> On Feb 8, 2004, at 3:08 AM, Olaf Lenzmann wrote:
>>
>>> My squeezebox display shows "Slimproto error, length 2003" and loses

>>> contact with the server. Also, the server frequently (once an hour
>>> or so, even when idle) dies after assertion failures in slimproto.pm

>>> lines 183 and 203 (bytes_to_receive >= 0). Running Win XP SP 1.
>>> Anybody had similar problems or even a solution?
>>>
>>> TIA,
>>>
>>> Olaf
>>>
>>>