PDA

View Full Version : Scanning For Music On Slimserver



hdy742
2008-02-14, 05:46
I have connected a TS-109, transfered my music but cannot scan without filling in the folder box on slimserver. Any ideas?

Thanks, Steve

Zaragon
2008-02-14, 06:32
I'm assuming that you don't want to fill in the box on Slimserver that tells it where your music is stored. If this is the case then it will never scan. I suspect browse by directory would also fail.

At the moment you have a Slimserver with no music and a NAS with music stored on it. I recommend that you connect the two by telling the Slimserver where your music is stored.

Or am I missing something here?

Zaragon
2008-02-14, 06:46
Now that I've seen your other message in another thread I see that the problem you are having is determining what the directory information should be.

I don't know the TS-109 but usually a format of \\servername\directory\ will work. This UNC format should be the same for every box on the network.

Servername would be the name by which your TS-109 is known on the network and directory is the way you navigate down from the first directory you get to on the TS-109 until you hit the head of the music directory tree. eg \\TS-109\music or \\MyNAS\Music\MyMusic\ etc

hdy742
2008-02-14, 08:42
Thanks Zaragon, Whenever we try and fill in the box asking for the path/folder that the music is stored in it ie. \\192.168.x.x\Qmultimedia\My Music we click on Change and it just keeps giving us an error message Oops - it is not a valid directory.

Steve

Khuli
2008-02-14, 09:15
ie. \\192.168.x.x\Qmultimedia\My Music

192.168.x.x is the IP address, not the server name, which might be the problem.

hdy742
2008-02-14, 09:28
Thanks Khuli, We've tried putting the server name \\SlimServer-109\Qmultimedia\My Music from copying and pasting in the properties tab but it still doesn't work.

Steve

Khuli
2008-02-14, 09:53
Using windows? If so, does Windows Explorer give you the same path if you browse to the music folder?

hdy742
2008-02-14, 10:25
Tried using Windows Explorer but slimserver still doesn't allow it

maggior
2008-02-14, 10:50
Do you have any permissions set on the NAS? Perhaps they are restricting access and preventing slimserver from accessing it. Do you have slimserver set up to run as a service? You can see what this is set to by right clicking on the tray icon. Try changing it to the other setting and see what happens.

hdy742
2008-02-14, 14:59
When I try to open Web File Manager on my TS-109 Trubo Station, it says:

Website Security Certificate is not issued by a trusted certificate Authority.

The security certificate presented by this website was issued for a different website's address.

Security certificate problems may indicate an attempt to fool you or intercept any data you send to the server.

We recommend that you close this webpage and do not continue to this website.

Please help.

Zaragon
2008-02-14, 15:10
If you don't have a local DNS resolver the using the IP address is the right way to go. Make sure that the TS IP address is consistant, either statically assigned or reserved in the DHCP server.

Whilst the UNC path ought to be the same to access the music from the network as from the TS itself I could envisage problems if the TS turns the call around within itself rather than using the network stack.

A couple of things to try. Save a shortcut to the TS music folder on your windows desktop then look at it's properties to see the UNC.

If that doesn't work then start a cmd box (start->run type cmd and OK). Use a command: net view \\192.168.x.x
This should give you a run down of all the network visible directories on the TS just in case they are different to what you see in windows.

If that doesn't help then you will probably need to gain a terminal access to the TS to check permissions of the unix path to the music files. Unfortunately I can't help you in that respect as I've never had a TS.

Another thought occurs. If you have created accounts for users on the TS into which they can store their own personal files then you will probably need to give the music directory structure access for the guest user ie one that logs in with no credentials. An alternative is to grant access to the account under which the Slimserver is running on the TS platform.

hdy742
2008-02-14, 18:06
Do you have any permissions set on the NAS? Perhaps they are restricting access and preventing slimserver from accessing it. Do you have slimserver set up to run as a service? You can see what this is set to by right clicking on the tray icon. Try changing it to the other setting and see what happens.

How do I get the permissions? Slimserver start automatically at login. thanks

Mark Lanctot
2008-02-15, 07:43
When I try to open Web File Manager on my TS-109 Trubo Station, it says:

Website Security Certificate is not issued by a trusted certificate Authority.

The security certificate presented by this website was issued for a different website's address.

Security certificate problems may indicate an attempt to fool you or intercept any data you send to the server.

We recommend that you close this webpage and do not continue to this website.

You'll get a message like this if the website's secure certificate isn't held on your local PC or registered or something like that...I see this when I try to access my router by a secure path (https:// )

Totally irrelevant because this device is on your own network. You control it or at least the device manufacturer has written the code, and hacking into your customer's computers sure won't make repeat sales! It isn't trying to fool you, it's secure but not registered.

You should still have the option to proceed to the configuration site.

Now, if you see this out on the Internet, you should be a little more concerned.

emsto
2008-02-15, 16:20
Thanks Zaragon, Whenever we try and fill in the box asking for the path/folder that the music is stored in it ie. \\192.168.x.x\Qmultimedia\My Music we click on Change and it just keeps giving us an error message Oops - it is not a valid directory.

Steve

I assume you're trying to run the Progressive version of Slimserver installed on the TS-109. If so you only need to enter the local path to your music directory. The default location is /ext/Qmultimedia

There's a full set up guide at https://www.ripcaster.co.uk/node/209

Hope this helps

emsto

lthrower
2008-02-27, 19:47
Success! Thanks, your answer pointed me sufficiently. For those of you trying to figure this out in the future, here is what I did.

1. I openned Windows Explorer. Under "My Computer" my NAS drive showed up in 2 places - one was as my K: drive, the other under "My Network Places" as "Volume_1 on DNS-323 (Dlink-eec391)". The second of these held the key.

2. Looking at the properties on the entry under "My Network Places", I saw Target: \\DLINK-EEC391\Volume_1

3. I then tried "\\DLINK-EEC391\Volume_1\My Ripped CDs" in the music location section in the SlimServer setup software (My Ripped CDs being the directory right off the root directory of my NAS where everything is). This did NOT work!!

4. Thinking I had to be close, I tried again taking out "Volume_1", so my entry was simply ""\\DLINK-EEC391\My Ripped CDs".

Worked like a charm. I hope this helps others with the same problem.

Lloyd