PDA

View Full Version : Bug in Mac Slimserver 6.5.4



sjalloq
2008-02-10, 16:43
Hi there,

I've just noticed a bug in Slimserver where it is adding files to the library which are not in the search path.

I keep all my FLAC files in a folder at the following path:

/Volumes/FreeNAS/MEDIA/FLAC

and all my MP3's in a folder currently called:

/Volumes/FreeNAS/MEDIA/MP3_new.

This folder has only recently been created so I've not noticed the problem before.

What happens is that I set my Music Folder to the FLAC directory under Server Settings/Basic Settings, but when I "Clear library and rescan everything" I get the contents of both the FLAC and the MP3_new directory and get duplicated albums. One in FLAC and one in MP3 format.

Is this a known bug and if so can which version do I need to upgrade to in order to fix it? Thanks. Here is my version info.

SlimServer Version: 6.5.4 - 12568 - Mac OS X 10.4.11 (8S2167) - EN - utf8
Server IP address: 192.168.1.4
Perl Version: 5.8.6 darwin-thread-multi-2level
MySQL Version: 5.0.22-standard

radish
2008-02-10, 22:27
The most likely explanation is that you have a shortcut/symlink from the FLAC directory to the mp3 one. It's possible it's a bug, but I would have thought someone would have noticed something as obvious before.

sjalloq
2008-02-11, 06:21
Nope, no soft links. Just checked. But I agree this seems very strange and would have been picked up before. I just can't put my finger on what could be wrong.

radish
2008-02-11, 08:35
Any playlists referencing the mp3 files?

sjalloq
2008-02-11, 12:48
OK, I have no idea what was going on but I've fixed it. I just moved the MP3_new directory to a new name and rescan the library.

I use Unix day in day out for work so I'm not a completely numpty on the command line. Still, I couldn't find any soft links or playlists referencing the other directory so I have no clue what went wrong. As long as it works I don't care though.

Thanks for your help anyway.

radish
2008-02-11, 13:44
No problem :)