PDA

View Full Version : Leopard, SLIMP3 and Server



DavidFerrington
2008-01-31, 23:02
I'm sorry to just post without researching this.
I've been using four SLIMP3s with v4.1b1 of the server on Mac Panther and Tiger for about 8 years now. Without any firmware updates or any other changes to the server etc.
It just works :) Ok, I have to stick with MP3 since my SLIMP3s wont decode anything else, but hey, it just works!

I've just purchased a brand new iMac and will need to install the server. I'd like to install the latest server of course. Will this support the SLIMP3s? Are there any gotchas that I need to be aware off?


BTW, did I mention, it just works!

TIA
--
David

mherger
2008-02-01, 00:38
> I'm sorry to just post without researching this.

No need to be sorry - just do the search before ;-)

> I've been using four SLIMP3s with v4.1b1 of the server on Mac Panther
> and Tiger for about 8 years now. Without any firmware updates or any
> other changes to the server etc.

Wow, pretty impressive setup :-)

> I've just purchased a brand new iMac and will need to install the
> server. I'd like to install the latest server of course. Will this
> support the SLIMP3s?

Yes! And synchronization of SliMP3s even has been improved a lot. You'll
be able to use Pandora and Slacker on your SliMP3. Development hasn't
ceased.

> Are there any gotchas that I need to be aware off?

Go with SC7. It's still not officially released and everything, but the
last official build 6.5.4 has some issues with Leopard. And SC7 is the
best base for your next 8-10 years :-)

Michael

DavidFerrington
2008-02-01, 01:18
That's great news, thank you for the reply.
I've been away from here a long time, I used to get dev. mail because I was thinking of working on the server (Unix Perl since 1990). But I never got around to it.
Now I'll have to find out what Pandora and Slacker are now - yes I'll search :-)

Thanks again.

DavidFerrington
2008-02-18, 18:56
Well, I've just tried to use 7.0 (SqueezeCenter) with my original SliMP3 players (v2 firmware) and when I try to access the iTunes music library, it tell me i need a later version of the SqueezeBox - hmm, not cleaver at figuring its not a SqueezeBox but a SliMP3!

So where do I go from here - I tried overwriting 7.0 with 6.5.4, but the server won't stay up - that could be because I didn't remove 7.0 or because of issues mentioned with Leopard (10.5.2)

How do I remove 7.0 - can't see an uninstall option - maybe I just find all the files and remove them?

Suggestions please on what to do - can I upgrade the firmware?

I certainly can't afford to replace the 4 players.

mherger
2008-02-19, 00:45
> Well, I've just tried to use 7.0 (SqueezeCenter) with my original SliMP3
> players (v2 firmware) and when I try to access the iTunes music library,
> it tell me i need a later version of the SqueezeBox

Who's telling you so? And what exactly? Fact is you can't play songs
bought from iTunes. And you might need to transcode files if they're in
..m4a. But that's only a guess without knowing the real message you see.

SliMP3 should work fine with SC7 - I'm using one myself.

Michael

DavidFerrington
2008-02-19, 01:34
Michaei, thank you
I did think this was strange after your obviously imformative post before.

I don't have any songs from iTunes Store - all ripped from my CD collection as mp3 since v2 firmware doesn't play anything else!

It was a message on the SliMP3 that said something like 'You need a later version of SqueezeBox to play this'. Sorry, it was late and I didn't note how I got this message, I'll again.

However, if you are using one and I had hoped there would be someone, then there is hope. Perhaps my v2 firmware needs updating to v2.3 ?
I have never touched the firmware on the 4 players, just used as they came out the box (with SliMP3 remote not Sony one).

So hope upgrade is simple and will try that.

Back to the server, how do I remove all files so I can do a clean install of SC7 again?

Thank you for all the help, I'm sure we'll get this sorted out.

mherger
2008-02-19, 04:11
> Back to the server, how do I remove all files so I can do a clean
> install of SC7 again?

Remove SC from
/Library/PreferencePanes
~/Library/Applicaon Support
~/Library/Cache
~/Library/Logs

--

Michael

DavidFerrington
2008-02-19, 04:21
Thanks - I'll do that, then a clean install and try again.
What version of firmware are you running on your SLIMP3?

mherger
2008-02-19, 06:30
> What version of firmware are you running on your SLIMP3?

2.2 or 2.3 - it's at home

--

Michael

DavidFerrington
2008-02-19, 06:43
thank you, I'm running 2.0 so that may be the problem.

I obviously need to put a bit more work into this, but glad you have it working, because that means I should be able too as well

DavidFerrington
2008-04-20, 02:33
I finally got the courage to update the firmware on my players today - I just did one and it all went so easily.
I then install the latest server on my iMac 24" 2.8GHz running 10.5.2 and it all appears to be fine.
So I'll go update the other players and now I have a learning curve on the way the new f/w and web access to server work.
We have never tried adding to playlists, it just always seams to show the playlists from iTunes. Which is ok, but when there are so many ....
I see there is a Favourites option on the SLIMP3 that I don't remember before - it might have been there and we haven't used it. I'll try to figure that one out.

Thank you for all your help, support and encouragement. Looks like I'm set for another 10 years of music enjoyment :-)