PDA

View Full Version : noob ? Best way to save/preset streaming radio stations



trans_lux
2008-01-29, 20:19
Hello
Having trouble figuring out how to create a preset for my beloved somafm stations. Currently I paste the url into the Radio URL box.
I have tried Mypicks and Wikiradio but just can't get this to work.
Wikiradio only shows helpmechill.com and Mypicks crashes and needs the server to restarted to access again.
Running SlimServer Version: 6.5.5 - 14805 - On Clark Connect
Any help is greatly appreciated.

bpa
2008-01-30, 01:28
MyPicks is the solution you need especially as all the somafm stations are already in the wikiradio.

You have a problem with your MyPicks installation.

First make sure you have used the version of 0.6 for SS6.5 and not the version for SS6.3.
http://wiki.slimdevices.com/plugin/attachments/WikiRadio/MyPicks-0.6-6.5.zip

Installing the wrong version will cause a crash. If you are not sure. Stop Slimserver. Delete the MyPicks plugin directory. Delete the file WIkiradio.pm from the Plugins directory. Re-install MyPicks 0.6 for 6.5 from a fresh download. Restart Slimserver.

Then make sure you have a Playlist directory defined in Server Settings. Also make sure that Slimserver has permissions to create files inthis this directory.

If it is still not working then enable debug loggin g d_server and d_plugins. Open a log window and then try saving an URL. look at log entries and if necessary copy log to a file and attach to a post.

When MyPicks is working, Stop Slimserver install the Wikiradio plugin.

trans_lux
2008-01-30, 14:34
Thanks for the prompt reply!
I know this is very basic but I can't seem to be able to start/stop slimserver. When I use /etc/init.d/slimserver restart I get :

Shutting down SlimServer: pidof: invalid options on command line!

pidof: invalid options on command line!

[FAILED]
Starting SlimServer: [ OK ]
I recall reading somewhere you can add it to the Clarkconnet web util but can't find the daemon.list

bpa
2008-01-30, 14:48
I think you should look up other threads about installing on CC.

The error message relates to "pidof" which seems to be used by the shell script "slimserver". On some shells implementation "pidof" is not implemented - that looks like to be case in the version of CC you are using.

You should check if other CC users had the same problem.