PDA

View Full Version : Weird WOL problem



DeeBee
2008-01-29, 09:39
I've been searching the forums for ages without being able to find a solution - perhaps I'm missing something, but I have a Wake on Lan problem with Slimserver + SB3 which I can't seem to resolve.

WOL works fine on my XP SP2 box. I boot up the PC, SS starts up, the machine goes into Standby after 3 mins.

Then I press the power on on the SB3, and it wakes up the PC and allows me to play music/radio etc. No problem.

However when I power down the SB3, the PC never goes back into standby. There are no other applications running apart from a few TSRs that were running when the machine first booted up.

It just seems that after it's woken, it won't sleep again.

Any ideas anyone? Anyone had this issue themselves?

TIA

Anoop M.
2008-01-29, 16:08
I believe this is happening because your SB3 is still connected to SlimServer when your player is off. Try connecting your player to SqueezeNetwork and then see if your computer goes into hibernate mode.

DeeBee
2008-01-30, 04:47
Aha, yes that does it - I can see now that it's the clock/screensaver that's keeping the PC awake.

Is there an option in the player settings to make the player go totally off when the power button is pressed, or do I have to hold down power or the left button to make it unconscious?

If not that's a pain, as I use a Logitech Harmony 850 all-in-one remote, and I don't think that'll function the same way as the dedicated SB3 remote.

nacmacfeegle
2008-01-30, 06:06
Aha, yes that does it - I can see now that it's the clock/screensaver that's keeping the PC awake.

Is there an option in the player settings to make the player go totally off when the power button is pressed, or do I have to hold down power or the left button to make it unconscious?



I use the 'server power plugin' to switch off the PC via the Squeezebox.
http://adrianonline.wordpress.com/projects/squeezebox/

On my version of Slimserver I can customise the menus so I keep it at the top level, this way its easy to find. Works like a charm. As long as you can use your Harmony to move about the menu system, it should do it for you.

fcm4711
2008-01-30, 07:24
Hi DeeBee

My guess is that your PCs network card is set to wake the PC for _any_ traffic, not just when it receives the magic WOL packet.

My network card offers a setting 'Wake-Up-Functions' which needs to be set to 'Magic Packet'. If I set it to 'Wake on Link' the PC would not go to sleep.

Cheers
Felix

DeeBee
2008-01-30, 08:56
Thanks for the suggestions, but we're not really there yet.

Here's the situation as I see it...

1. Wake on Lan is working perfectly. Powering on the SB3 wakes the PC from Standby and connects and plays. Great so far.

2. Powering off the SB3 with the screensaver set to Clock leaves the SB3 talking to SS so the PC won't go back to sleep. Understandable.

3. So I can hold down the power off or the left button on the SB3 remote to power down "fully" and the PC then goes into standby. That's fine... except I use a Logitech all-in-one super-duper remote which won't behave the same way as the SB3 remote. Without going back to multiple remotes I can't "fully" switch off the SB3.

4. So... I think "Aha - perhaps there's a player setting that'll sort this out" and lo and behold there appears to be.

So now I've changed the Player settings in SlimServer so that the Screensaver to use when powered off is set to "None". Switching off the SB3 now goes to a completely black display, except... the PC isn't going into standby. Why not? Why is the SB3 still "talking" to Slimserver? Confused.

5. nacmacfeegle's suggestion of the plugin is good, but slightly inconvenient to have to add extra steps before you can hit the Off button, and it seems to shut down the PC. I really don't want to shut it down, just go into standby, so I can wake it up again using Wake on Lan.

The issue isn't that Wake On Lan isn't working correctly at all, it transpires, it's that SB3 needs to be REALLY told to go to sleep, and just sending a power off command by itself is incapable of doing this.

Is there any way to either send the PC into standby on SB3 power down, or a way to get the SB3 to stop talking to SS on a simple power off command?

Any more suggestions?

Honva
2008-01-31, 11:48
Don't know if this is of help to you. Just to share my observation. It may not be the SB3 keeping your computer up. Is your SB3 connected with wireless or cable?

I have very similar setup as you. SB3(wireless) and XP SP2 server. However, my server have no problem going back to sleep mode after SB3 powered down. In fact, if I am not playing music, the server will also go sleep after preset timeout. (even when I use RSS feed screensaver.)

Even when I unchecked the option of "wake by admin command only", the server has no problem going sleep. It works just as what I liked.

There may be another process in your computer that is keeping it up. Also check the BIOS setting. There is a setting in BIOS to choose S1 or S3 sleep mode. On my machine, Windows will only go sleep reliably if I set it to "S3 only". If I set it to "S1&S3", it is very unpredictable.

Sometimes, windows update will also keep your machine from going to sleep.

Biu

DeeBee
2008-02-01, 09:59
SB3 is connected wirelessly. Wireless router connected to PC via switch box.

It's definitely SB3 keeping the PC awake, even though it's powered down. If I disconnect the SB3 from Slim Server and connect to Squeeze Network the PC goes straight to sleep.

I can see the little lights blinking away on the network switch box while SB3 is powered down and showing the clock screensaver and also when the screensaver is set to "None". As soon as I switch to Squeeze Network the light relating to the PC network card falls silent.

I've tried every permutation of Sleep modes and power options, and network card settings relating to Wake on Lan.

What I don't understand is why the SB3 needs to keep talking to SS even though the screensaver is set to None? I wouldn't want to upset anyone else's set-up by changing SB3's default behaviour, but shouldn't it be possible to have a screensaver setting that says "None (Disconnect)" that really tells SB3 and SS to quit their yakkin'?

It seems that the current "None" screensaver setting is just droppping the display brightness to zero instead of actually stopping all communication - am I wrong about this?

Wirrunna
2008-02-02, 00:04
DeeBee, look through this thread http://forums.slimdevices.com/showthread.php?t=32674, I use the Shutdown.pm plugin (post #17) to make the server hibernate.