PDA

View Full Version : oggs won't play



Austin Frank
2004-02-02, 20:42
Hey all--

I've got my squeezebox up and running, but I can't play any of my oggs.
I've tried v5.01 of the software, as well as the 2004-02-02 cvs build. I
installed from source, unpacking the .tar.gz to /usr/local/slimserver. I
start my server with the line (it gets line wrapped in my mailer)

/usr/local/slimserver/slimserver.pl --daemon --pidfile
/var/run/slimserver.pid --audiodir /music

My squeezebox detects the server just fine, and I can play the 4 mp3s I
have, but oggs won't play. When I load a playlist full of oggs and push
play on the server, it seems to run through the list very quickly without
playing anything. Every 12th song or so shows up on the display of the
squeezebox for about a second, and then it moves 12 or 13 songs forward in
the list. I imagine it's accessing each song sequentially, but can only
refresh quickly enough to show every 12th song or so. What I really want to
know is why they aren't playing.

I've got oggdec v1.0 and lame v3.95.1. The firmware on the squeezebox is
version 7.

Is there something special I need to do to get my oggs to play?

/au

--
"Your reality, sir, is lies and balderdash; and I am
delighted to say I have no grasp of it whatsoever."
*Baron Munchausen*

Roy M. Silvernail
2004-02-02, 20:59
On Mon, 2004-02-02 at 22:42, Austin Frank wrote:
> Hey all--
>
> I've got my squeezebox up and running, but I can't play any of my oggs.
> I've tried v5.01 of the software, as well as the 2004-02-02 cvs build. I
> installed from source, unpacking the .tar.gz to /usr/local/slimserver. I
> start my server with the line (it gets line wrapped in my mailer)
>
> /usr/local/slimserver/slimserver.pl --daemon --pidfile
> /var/run/slimserver.pid --audiodir /music
>
> My squeezebox detects the server just fine, and I can play the 4 mp3s I
> have, but oggs won't play. When I load a playlist full of oggs and push
> play on the server, it seems to run through the list very quickly without
> playing anything.

Shut down the daemon and run the server from a shell command line with
the --d_source switch. Try to play your oggs and watch the output. It
will show what the server is trying to do to play oggs, and errors
should show up pretty clearly. Also, check your convert.conf file for
an "-R 1" argument to oggdec. Chances are that your oggdec doesn't want
that "1" in there.
--
Roy M. Silvernail is roy (AT) rant-central (DOT) com, and you're not
Never Forget: It's Only 1's and 0's!
SpamAssassin->procmail->/dev/null->bliss
http://www.rant-central.com

Austin Frank
2004-02-02, 22:50
Using the 2002-02-02 software, I started the server with this command:

perl slimserver.pl --pidfile /var/run/slimserver.pid --audiodir
/music/ --d_source

here's a sample of the error I was getting:

2004-02-03 00:44:28.0461 opening next song...
2004-02-03 00:44:28.0475 the next song is number 3, was 2
2004-02-03 00:44:28.0496 checking formats for:
ogg-aif-squeezebox-00:04:20:05:12:04
2004-02-03 00:44:28.0509 checking formats for:
ogg-wav-squeezebox-00:04:20:05:12:04
2004-02-03 00:44:28.0520 Matched ogg-wav-squeezebox-*
2004-02-03 00:44:28.0555 openSong on:
/music/ben_folds_five/naked_baby_photos/04_alice_childress_live.ogg
2004-02-03 00:44:28.0573 openSong: getting duration 261, size 3626859, and
offset 316 for
/music/ben_folds_five/naked_baby_photos/04_alice_childress_live.ogg
2004-02-03 00:44:28.0593 checking formats for:
ogg-aif-squeezebox-00:04:20:05:12:04
2004-02-03 00:44:28.0603 checking formats for:
ogg-wav-squeezebox-00:04:20:05:12:04
2004-02-03 00:44:28.0613 Matched ogg-wav-squeezebox-*
2004-02-03 00:44:28.0623 openSong: this is an ogg file:
/music/ben_folds_five/naked_baby_photos/04_alice_childress_live.ogg
2004-02-03 00:44:28.0633 file type: ogg format: wav
2004-02-03 00:44:28.0642 command: $oggdec$ -Q -o - -R 1 $FILE$
2004-02-03 00:44:28.0664 Using command for conversion: "/usr/bin/oggdec" -Q
-o - -R 1
"/music/ben_folds_five/naked_baby_photos/04_alice_childress_live.ogg" & |
2004-02-03 00:44:28.0837 Streaming with format: wav
ERROR: Can only specify one input file if output filename is specified

here is the line for oggs from my convert.conf

ogg mp3 * *
$oggdec$ -Q -o - -R $FILE$ | $lame$ --silent -b $BITRATE$ -r $-x$ - -

I took out the 1 after the -R option as you suggested, but the debug message
still show that it is using -R 1 to convert the ogg.

Why doesn't the command string in the debug message match my convert.conf?

/au




On Mon, Feb 02, 2004 at 10:59:45PM -0500, Roy M. Silvernail wrote:
> On Mon, 2004-02-02 at 22:42, Austin Frank wrote:
> > Hey all--
> >
> > I've got my squeezebox up and running, but I can't play any of my oggs.
> > I've tried v5.01 of the software, as well as the 2004-02-02 cvs build. I
> > installed from source, unpacking the .tar.gz to /usr/local/slimserver. I
> > start my server with the line (it gets line wrapped in my mailer)
> >
> > /usr/local/slimserver/slimserver.pl --daemon --pidfile
> > /var/run/slimserver.pid --audiodir /music
> >
> > My squeezebox detects the server just fine, and I can play the 4 mp3s I
> > have, but oggs won't play. When I load a playlist full of oggs and push
> > play on the server, it seems to run through the list very quickly without
> > playing anything.
>
> Shut down the daemon and run the server from a shell command line with
> the --d_source switch. Try to play your oggs and watch the output. It
> will show what the server is trying to do to play oggs, and errors
> should show up pretty clearly. Also, check your convert.conf file for
> an "-R 1" argument to oggdec. Chances are that your oggdec doesn't want
> that "1" in there.

--
"Your reality, sir, is lies and balderdash; and I am
delighted to say I have no grasp of it whatsoever."
*Baron Munchausen*

kdf
2004-02-02, 22:57
Quoting Austin Frank <aufrank (AT) columbia (DOT) edu>:


> Why doesn't the command string in the debug message match my convert.conf?
>
> /au

Did you restart the server after making this change?

-kdf