PDA

View Full Version : Soft Squeeze Won't Connect Remotely to SlimServer



Ed C
2008-01-11, 14:30
I'd like to thank everyone whose posted in the past regarding how to set-up remote access to SlimServer. Thanks to that wealth of information, I was able to successfully access SlimServer remotely and listen to the stream through Windows Media Player with the URL http://<host address>:9000/stream.mp3 (In fact, I'm listening to it as I write.)

What I haven't been able to do is get SoftSqueeze to work. When I launch SoftSqueeze from the SlimServer window, it does launch, but never gets past the "Please wait. Connecting to Slim Server." message. I've spent a lot of effort scouring the forums, the FAQ, and the Wiki looking for an answer, but so far, no luck. Any suggestions would be appreciated. I think SoftSqueeze would be the better interface since it could control the SlimServer directly instead of controlling the stream with SlimServer in one window and listening to it through a separate mp3 application.

T.I.A.,
Ed

SubFuze
2008-01-11, 20:15
Most likely you need to open port 3483. More details about exactly what you need to do is here:
http://wiki.slimdevices.com/index.cgi?ConnectingRemotely

Ed C
2008-01-11, 21:08
Thanks. A "Shields-Up" probe tells me that 3483 is open. I only have it set-up as a TCP port; perhaps I need to open it for UDP also?

aldente295
2008-01-12, 01:12
Could it be that in your 'settings' of the softsqueeze, it's set to 'localhost' rather than the name of your slimserver machine? My softsqueeze constantly resets to that, and I need to manually change it each time. Just a thought... (and if anyone knows how to STOP it from doing that,...)

Ed C
2008-01-14, 09:33
Thanks aldente295, but my softsqueeze instance "Slimserver host" setting is pointing to my home PC's IP address.

I have this nagging feeling that I'm missing something so blatantly obvious that I'll feel idiotic when it finally becomes clear!

Ed

Mark Lanctot
2008-01-16, 08:44
Thanks. A "Shields-Up" probe tells me that 3483 is open. I only have it set-up as a TCP port; perhaps I need to open it for UDP also?

Yes, you'll need that.

Also you need to port-forward both 9000 and 3483 to your SlimServer PC. Finally, check Server Settings - Security - Block Incoming Connections and Allowed IP Addresses to make sure you're not blocking the remote PC.

Ed C
2008-01-16, 10:21
Thanks Mark!

Both port 9000 and 3483 are forwarded. I learned some more last night. This may have something to do with my work PC which is on a really large company's network behind their firewall. I had an old Win95 notebook at home that I connected by dial-up to the internet. I confirmed that it was at a different IP than my router's WAN IP. Then I used a port query program to check the ports on my router. Since I had access control turned-on, the port query showed them all as "closed". Then I added the Win95 machine's IP address to the router's "allowed" list and port query showed 3483 and 9000 as "listening". I brought-up Slimserver on the "remote" machine with no problem. I couldn't test SoftSqueeze because it requires Java 1.4 but Win95 won't run Java 1.4. That said, the IP address of my work machine is also in my router's "allowed" list. This morning, a port query of my home router from work shows port 9000 as "listening" but shows port 3483 as "not listening". I need to get a modern machine, outside my company's firewall, and see if SoftSqueeze works.

dminches
2008-01-16, 19:26
Ed C, how do you test to see if the ports are listening? I am having the same issues that you are so your answers could help me solve my problem.

Ed C
2008-01-16, 19:48
dminches,

I used a port query tool from "our friends" at Microsoft. It's called PortQryUI. The download is at:

http://www.microsoft.com/downloads/details.aspx?familyid=8355e537-1ea6-4569-aabb-f248f4bd91d0&displaylang=en

dminches
2008-01-17, 06:03
I ran Port Query from my office. 9000 returned filtered and 3483 returned filtered or listening. Is it possible that it is my company's firewall that is blocking communication and not my machine at home? I can load slimserver via the web and see my library from my office. I just can't get Squeezesoft going.

What should I try next? Should I try a different port that I think I can communicate through, getting past my office firewall?

Ed C
2008-01-17, 07:24
dminches,

That's a similar problem to what I'm having: I can open SlimServer from my office, I can play an mp3 stream through Windows Media Player, but I can't get SoftSqueeze to connect. I haven't solved mine SoftSqueeze problem yet, so I don't have any advice for you.

If I solve mine, I'll be sure to post it. Perhaps that will help.

Ed

dminches
2008-01-18, 19:50
I finally got it to work on my office laptop, but I wasn't logged into my office network. Instead, I was out of the office communicating via my verizon broadband card. I was able to run the Softsqueeze applet and listen to music in my slimserver library. My conclusion is that my office is blocking ports 3483 and/or 9000. I will try changing the ports to something that I think I can communicate through at the office and see if that works.

Hopefully this provides you with an action step for you to try.

Mark Lanctot
2008-01-18, 20:40
You might want to try SSH, it's more secure and uses a single port which is often not blocked:

http://wiki.slimdevices.com/index.cgi?ConnectingRemotely

See "RESTRICTIVE INTERNET SERVICE PROVIDER".

Ed C
2008-01-22, 13:01
Thanks Mark. I just read your post today, and, coincidentally, I was "playing" with PuTTy earlier. Unfortunately, I don't have port 22 forwarded on my router at home and, a related issue, I haven't been able to get remote admin to my router. My office firewall is probably preventing communication with that port also. I'll forward port 22 tonight, and see if PuTTy can enable SoftSqueeze.

I may have another way around. Last night, I forwarded every port between 2000 and 65534 (I did limit access to my office PC's IP address!). This morning, a port scan of my home PC from my office shows port 3389 and port 9000 as "open". I think I can use my router's "virtual server" functionality to route a WAN connection to 3389 to LAN port 3483. There's a setting in SoftSqueeze to tell it what port is the slimproto port. If I set that to 3389, maybe that will give SoftSqueeze the access that it needs to 3483.

I do like the idea of using SSH, then I can eliminate the access controls. I need to learn a lot more about PuTTY and SSH, though. I don't even understand how I can forward port 22 and not give the world SSH access to my PC. (To someone who understands SSH, that question is probably nonsensical.)

Ed

Ed C
2008-01-23, 08:48
Success! Thanks everyone. Biting the SSH bullet did the trick (Thanks Mark!). Setting-up OpenSSH was an act of "blind faith" (There's an album that I should buy!) Typing Unix commands without bothering to learn what they do was unsettling. It was also important to port forward 9000 on my router so that I could then get into SlimServer to limit the audio stream rate while SoftSqueeze was connected. (I wonder whether I can get to port 9000 through the SSH tunnel? I'm sure I can, now to go learn how.

dminches
2008-01-23, 08:54
Ed C, glad you got this working. Can you point me to what you read to get the SSH going so i can try it myself? I assume you set up the secure tunnel on our home machine and then access is remotely?

Ed C
2008-01-23, 09:22
I can try:

This thread was somewhat helpful:

http://forums.slimdevices.com/archive/index.php/t-13831.html

and this one was even more so:

http://forums.slimdevices.com/archive/index.php/t-19157.html

This web page was helpful in setting-up OpenSSH:

http://www.vbmysql.com/articles/security/protecting-mysql-sessions-with-ssh-port-forwarding-part-2/

In the step entitled, "Configuring The passwd And group Files", I had to change the command "cd c:program fileopensshbin" to "cd c:\program files\openssh\bin"

When you execute the "mkpasswd -1 -u tunnel >> ..etcpasswd" command that you replace the word "tunnel" with the name of a password protected local machine user.

By the way, my previous comment about forwarding port 9000 can be ignored. There's a button in the upper left of SoftSqueeze that opens SlimServer through the SSH.

Ed

Mark Lanctot
2008-01-25, 13:48
I don't even understand how I can forward port 22 and not give the world SSH access to my PC. (To someone who understands SSH, that question is probably nonsensical.)

SSH is very, very secure, much more secure than SS's rudimentary access controls and IP blocking.

http://en.wikipedia.org/wiki/Ssh

It's been around since 1995 so it's been field-tested and battered every which way and aside from the security concerns outlined in http://en.wikipedia.org/wiki/Ssh#Security_cautions it's quite secure.

I believe that yes, your SSH is open to the world - but that's the point. Without your password, they can't get in. Your communications are secured by public-key cryptography, a very powerful encryption method, so powerful some repressive governments have banned its use because even they couldn't intercept such communications. The U.S. government proposed such a system but where they would hold the keys, http://en.wikipedia.org/wiki/Clipper_chip Needless to say, it didn't fly!

Glad I could help!