PDA

View Full Version : Linux RealAudio streaming



=?iso-8859-1?q?Nigel=20Champion?=
2004-01-30, 03:27
I am having trouble with trplayer... it keeps seg
faulting! I tried building it from scratch..some prob
:( I can run vsound with RealPlayer no prob
I am running Redhat 9 any ideas?

Thanks

Nigel

--- Colin Burn-Murdoch <colin (AT) aranion (DOT) com> wrote: > >
The Linux RealAudio is working a treat with sox
> now and I'm very happy.
> > Has anyone done anything similar for mms://
> streams? I had a quick play
> > and just about got it working using mplayer, a
> named pipe and lame. I
> > started a lame thread reading the named pipe then
> set mplayer getting
> > the mms stream. Somewhere I think I got lame
> reading before the named
> > pipe was created which meant it didn't get any
> input. Then I ran out of
> > time. But it's certainly a workable solution. Is
> this the best way to go
> > about doing it or is there another solution?
> >
>
> I've updated the rm2mp3proxy script a bit.... it's a
> little better written now and it won't accept links
> with ";"s for security.
>
> Changed the usage, is now:
>
> http://localhost/GAIN/BITRATE/rtsp://mp3stream.....
>
> Where GAIN is 1 for no processing and about 5 for
> the BBC streams... BITRATE is the resultant MP3
> stream bitrate, eg 128.
>
> I had a look at mms:// briefly... but despite it
> saying it was using an 8K cache, the cache filled
> mega slowly, and extrapolating, it looked like it
> was trying to get more like 8MB... i didn't leav eit
> to fill though.

> ATTACHMENT part 2 application/octet-stream
name=rm2mp3proxy.pl
>