View Full Version : Internet Radio - setup - ports on router

2008-01-07, 12:52
OK. So now have problems with internet radio.

when browsing and wanting to play some radio stations: I get the message: failed to parse.......
and later I get the message of an audio stream, but SB does not play the stream.

I have no software firewall in the computer...
I believe, that my wireless router has some ports close (i opened the necessary, I believe) but still have no results.

Could someone direct me to a thread where the setup is described?
Also, I have a dlink DIR-635 wireless.

2008-01-07, 13:18
Most radio stations do not need any changes ot routers.

It sounds like the url being used is not correct.

What stations are you trying to play ?

2008-01-07, 13:22
I'm just trying to access any radio station.
They're in the slimpicks - or the rdio sattions listed in the box

It seems, that the SB just does not see the internet.

Absolutely no idae what that might be.

2008-01-07, 13:26
sorry, sorry.
The radio works, just not the links in the SB
Some work, some don't.

I just need to set my favorites, and learn to browse, memorize, etc.

Another problem solved!

2008-01-07, 13:29
But, playing now with slimserver, it does not open properly most of the radio stations: for example I got such a message:

There was an error loading the remote feed for SHOUTcast Radio: (Failed to connect to http://content.us.squeezenetwork.com:8080/shoutcast/index.opml (Couldn't resolve IP address for: content.us.squeezenetwork.com) )

Any idea what is cousing that?

2008-01-07, 13:35
OK. Sop just checked most of the radio stations - they just don't play.
The live 365 does not play, beacuse you need to log in.
Alo no idea how.
Bou others are not playing as well.

2008-01-07, 13:35
It sounds like DNS problems. "Resolving IP address" is the terminology used when changing a IP name into a number using DNS.

Is the music server IP address configured using DHCP or a fixed IP address ?

If you are not using DHCP - make sure
(i) device ip address is on the same subnet as the gateway address
(ii) the server has the correct gateway address
(iii) The DNS addresses of the server are set correctly

2008-01-07, 13:44
Well, I made IP addresses reserved for each component of my network. The DHCP is running.
I will look at the subnet masks.

The broadband connection is done via a cable modem. You think this might be of significance?

2008-01-07, 13:52
OK. So I think I found the problem.

I ran the ipconfig /all command

My ethernet gets everything fine from the router.
DHCP is running
default gateway is ok,
subnet mask is ok,
dns, ETC IS OK.

the cable modem
there is no routing ip
no dns suffix, etc.

But - strange - web browsing is ok, everything runs ok on that computer

Should I contact the cable vendor to switch on the ip routing?

For security reasons I had the fixed ip made private (whatever that means - i guess it's not broadcasted)

But all the computers in my network run fine, brpwse the web, run outlook, etc.

2008-01-07, 17:20
If you can use a web browser on the music server - then the problem is DNS as used by Slimserver/Squeezecenter. Although it is odd as the Slimpicks list you used had to be retrieved by Slimserver from Slimdevices host - so there are some comms.

Sometime this is a system start problem - stop and restart Slimserver/Squeezecenter without rebooting the PC and see if problem persists.

There are debug /logging message which may help with this problem

If you are using SS 6.5 - then enable d_http_async, open log window and try to access a station.

If you are using SC 7.0 - then set loggin network.asyncdns to INFO and open server.log window.

In both case lkook at the log for error message - post a copy if you do not see anything obvious