PDA

View Full Version : audiostream to slimserver



Marcel
2008-01-05, 15:31
Hi there,

I've just purchased a SB3 and I'm very happy with it. I would be more happy even if I could also send all my pc-audio to the SB. I've searched the fora and came to try the following two approaches:

1) I installed a shoutcast-plugin in winamp and started to stream to 127.0.0.1:8000 on the same PC that runs slimserver. I check if this stream was working by connecting to it with vlc media player (also from the same PC). This indeed gave me the stream that was broadcasted with winamp. So far so good. Then I tried to listen to the same stream using slimserver (setting the URL in the internet radio section), but I got timeout errors. The messages from my shoutcast server were:

<01/05/08@22:09:24> [dest: 127.0.0.1] starting stream (UID: 1)[L: 1]{A: iTunes/4.7.1 (Windows; N; Windows Vista; 586; NL; cp1252) SlimServer/6.5.4/12568}(P: 0)
<01/05/08@22:09:24> [dest: 127.0.0.1] connection closed (0 seconds) (UID: 1)[L: 0]{Bytes: 8192}(P: 0)
<01/05/08@22:09:55> [source] no data (30s timeout). disconnecting.

I'm really lost why this doesn't work. Any ideas?

2) Since the above didn't work, I tried to catch the audiostream from my soundcard directly (which would be a superior solution anyway) using the waveinput-plugin for slimserver. This didn't work also, but this may have to do that I'm using Vista and that I have an onboard audiocard (realtek alc883HD audio 6 channel with S/PDIF). I've tried all my audio in and ouput settings to no avail. I figure this has to do with the fact that my soundcard probably doesn't support local loopback because the SB is nicely waiting for audio input (so it says). Anybody?

Thanks for you attention guys, I appreciate it highly!

pasil
2008-01-07, 11:36
Don't know if I have any clues but I'm having the exact same issues as you with both shoutcast and wave plugin not working on my XP machine. I've had the shoutcast solution working in the past if I went thru the softsqueeze interface and both the emulator and SB3 would work but that hard drive died and with the newer software versions I can't get shoutcast to work now. Exact same server messages as you. I tried the wave plugin and it wont capture more than 1.5 seconds of audio when I followed the cmd line instructions on the main wave input plugin thread. I was blaming this on my integrated soundcard but I don't know for sure. Just seems like streaming the wave out mix from a soundcard is a reasonable thing to do and it becomes a huge issue. Let me know if you figure anyhting out. Try going thru the softsqueeze interface and see if the emulator will play your stream. Paul

pasil
2008-01-07, 21:23
ok -I got it working again. Once again I use the softsqueeze interface- don't know what kind of voodoo is going on there. Set the shoutcast source encoder to something very simple -I started with 48kps and in the player setting on slimserver use proxied streaming for "mp3 streaming method" then tune to 127.0.0.1:8000 and see if you can pick it up. I worked from there and can stream 96kps 44.1 ok. If I try and play both the SB3 and the softsqueeze emulator it will sputter and loop and generally sound bad. The other weird thing I noticed is sometines the shoutcast server monitor will report connection closed but things are still going fine- it does still show one connection in the lower right corner. good luck!-Paul