PDA

View Full Version : WAP Connection(s)



Neil Cameron
2008-01-02, 07:46
I have one WLAN with one SSID, but two WAPs. I've been having some annoying
dropouts and performance issues with one of the Squeezeboxes, and when I
went to Information : Player found it was at only 35-40% wireless signal,
even though it was in the same room as one of the WAPs. So I turned that
WAP off - no difference, and it kept on working! So I then turned the
faraway WAP off and the Squeezebox finally stopped. Then I turned on the
nearby WAP and it connected at 100%.
It had been communicating with the wrong WAP! Why on Earth would it do
that?! I'm sure I connected to the right WAP originally, but I may have
turned it off at some point. Do they stick with the most recent WAP despite
signal strength?

--
Neil Cameron

danco
2008-01-02, 08:57
I had a similar situation.

I suspect that the SB remembers the WAP it was first connected to (unlike the little portable internet radio I have just bought, which I am told connects to the best WAP available at the time it is turned on).

My solution was to enable MAC filtering on the WAP I did not want the SB to connect to, and not include the SB's WAP, so it could only connect to the other one.

There may well be better solutions, but this works.

Neil Cameron
2008-01-04, 03:17
Neat idea Danco; but I have people popping in and out with laptops to
connect and get fed up with adding MAC addresses to WAPs. I just think it
should be designed to switch dynamically to the strongest signal...

Neil

"danco"
<danco.32kg5z1199289601 (AT) no-mx (DOT) forums.slimdevices.com>
wrote in message news:danco.32kg5z1199289601 (AT) no-mx (DOT) forums.slimdevices.com...
>
> I had a similar situation.
>
> I suspect that the SB remembers the WAP it was first connected to
> (unlike the little portable internet radio I have just bought, which I
> am told connects to the best WAP available at the time it is turned
> on).
>
> My solution was to enable MAC filtering on the WAP I did not want the
> SB to connect to, and not include the SB's WAP, so it could only
> connect to the other one.
>
> There may well be better solutions, but this works.
>
>
> --
> danco
> ------------------------------------------------------------------------
> danco's Profile: http://forums.slimdevices.com/member.php?userid=210
> View this thread: http://forums.slimdevices.com/showthread.php?t=41674

danco
2008-01-04, 09:19
I just think it
should be designed to switch dynamically to the strongest signal...



I wonder how difficult this would be. It would be worth formally suggesting as a wanted feature.

Eric Seaberg
2008-01-04, 11:47
Neat idea Danco; but I have people popping in and out with laptops to
connect and get fed up with adding MAC addresses to WAPs. I just think it
should be designed to switch dynamically to the strongest signal...

Neil


I have two WAPs as well, but have them named differently, i.e. one is 802.11N and the other is 802.11G and their names have the N or G tag. I have the G setup for guests and my wife's computer that is only B/G savvy, keeping the N for me and my SB3s.

I know you're thinking "SB3 doesn't work with 802.11N" but I have it setup to do N and remain B/G compatible. It works GREAT, allowing the SB3s to connect at G and my MacBook Pro via N.

I can also setup different security types for each as required.

FYI...

oreillymj
2008-01-07, 05:05
I have a router and a wap setup using the same SSID in bridging mode.

I wonder if danco's solution would fix my issue where the SB2 switches from the nearby AP to the original router. In doing so the signal strength drops from ~90% to 50%.

In MAC filtering, I can specifically deny MAC single addresses, so I can disable the SB2 from connecting to the router, but it can talk to the nearby AP.

So I wouldn't have to set up a heap of 'allow' rules for existing devices & guests, just the single 'deny'

danco
2008-01-07, 10:08
Best thing seems to be to try it and see if it works.

Being able to deny an individual address, rather than having to allow the addresses you want omitting the one you don't want, makes it a lot easier.