PDA

View Full Version : SB3 with Ubuntu



Crispy
2008-01-01, 12:43
OK - I'd best start off by owning up to being a newbie with Unix if not SlimServer.

For some time I've been running Slimserver, most recently on Vista using a wireless connection to an SB3 - no problems.

I've just installed Ubuntu 7.10 as a dual-boot option on the same machine and installed SlimServer (6.5.4 - 12568 - Debian - EN - utf8). It is set to read the same music library of (mostly) flac files. Slimserver has scanned the library, read the artwork etc and the web interface looks fine. The SB3 can see the server and vice versa - I can change menu order, font size etc through the http interface OK. There has been NO hardware/network changes between Vista/Ubuntu.

However, when it comes to actually playing a track to the SB3 - I get a "Connection timed out" on the SB and this in the Server log.

2008-01-01 19:37:46.1186 Backtrace:

frame 0: Slim::Player::Source::errorOpening (/usr/share/perl5/Slim/Player/Squeezebox2.pm line 579)
frame 1: Slim::Player::Squeezebox2::failedDirectStream (/usr/share/perl5/Slim/Networking/Slimproto.pm line 527)
frame 2: Slim::Networking::Slimproto::_disco_handler (/usr/share/perl5/Slim/Networking/Slimproto.pm line 387)
frame 3: Slim::Networking::Slimproto::client_readable (/usr/share/perl5/Slim/Networking/Select.pm line 238)
frame 4: (eval) (/usr/share/perl5/Slim/Networking/Select.pm line 238)
frame 5: Slim::Networking::Select::select (/usr/sbin/slimserver line 499)
frame 6: main::idle (/usr/sbin/slimserver line 452)
frame 7: main::main (/usr/sbin/slimserver line 1076)

I've never had enough trouble with SS to get into debugging so I'd be grateful if someone can give me a nudge in the right direction.

The NFS mount with the music library shows 777 permissions and root:root ownership all the way through.

SuperQ
2008-01-01, 16:21
How did you install slimserver on the machine? With the Ubuntu/Debian package or from tar file?

Mark Miksis
2008-01-01, 16:38
2008-01-01 19:37:46.1186 Backtrace:
...

Including the last few lines from the log before this might help.

Crispy
2008-01-02, 02:53
SuperQ:
this was the Debian package installed with apt. It picked up a load of dependencies - mostly Perl - and appeared to install without errors.

Fletch:
I'm not in front of the machine ATM - but the earlier bits of the log file all looked clean as I recall. Just a start-up, one error where I typed in the path to the library wrong & then nothing until I tried streaming.

One thing I was wondering - does the stream use a different port to the control routines ? I did have to open one port that was flagged by Firestarter as blocked before the SB would talk to the server.

Crispy
2008-01-02, 13:21
Hangs head in shame....getting back to it tonight & it turns out that all it needed was a reboot.

Now streaming flacs perfectly....just need to sort out the handful of mp3s I've got. Seems that a Linux install was easier than Vista..definitely converted :-)