PDA

View Full Version : SLIMP3 and Internet Radio Resampling



Adam_F
2007-12-24, 03:25
Hi,

A Live365 station I listen to sometimes recently starting streaming with a sampling rate of 16 KHz. My SB3 has no problem playing this stream, but my SLIMP3 cannot handle it.

Is there any way to configure SS so that all MP3 streams are re-encoded to 44 Khz ? I have tried to construct a suitable entry in convert.conf using mplayer and lame, but no luck so far.

Thanks,

Adam.

bpa
2007-12-24, 03:34
It should be possible with mplayer & lame.

What commands did you try ?

Adam_F
2007-12-24, 03:39
Hi,

I tried to base it on the approach used for handling AAC+, so I replaced:

mp3 mp3 * *
-

... with:

mp3 mp3 * *
[mplayer] -ac faad -demuxer mp3 -really-quiet -vc null -vo null -cache 64 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# $FILE$ | [lame] --silent -r -x -q $QUALITY$ -b $BITRATE$ - -

This does not seem to work though.

Thanks,

Adam.

bpa
2007-12-24, 03:54
-ac fadd - says to use mpeg4 - AAC decoding.

Trying playing the stream on a command line with mplayer. Use "-v -v" options and find what ac is being used and then put that in the conf file.

Adam_F
2007-12-24, 12:12
Thanks - this is not going to be as easy a problem to solve as I thought. In the end I tried the command without the -ac and -demuxer parameters. Some Shoutcast streams play fine with this, but when I try to play others (or any Live365 streams at all) nothing happens, except for a message from Vista telling me that socketwrapper has stopped working, and SS eventually crashing.

This is unfortunate, as it appears that all Live365 stations streaming at 32Kbps also use a sampling rate of 16KHz, which means that there is a whole class of stations no longer supported on the SLIMP3. Looks like I will need to spend some quality time on this over the holidays.

Adam.

bpa
2007-12-24, 12:44
The AACplus template is an unusual way of using mplayer as the stream is being handled by SC and that is why the dmeuxer is used unlike AlienBBC or WMA streams. Using the demuxer means that any station info in ICY format will appear. If you don't use the demuxer then you will have to change the conf files and provide a handler.

I suspect the problem lies in whether station have ICY track info or not.

Adam_F
2007-12-28, 01:02
Just got this working - in the end, mplayer was not needed as lame can handle the whole process. All that is needed are these lines added to convert.conf:

mp3 mp3 slimp3 *
[lame] --mp3input --resample 44100 --silent -q $QUALITY$ --abr $BITRATE$ - -

Adam.