PDA

View Full Version : no sound in linux players



graymon
2007-12-21, 08:15
The linux players I have connect to the slimserver but there's no sound! It seems to have found the stream.mp3 and starts playing it, but it seems like there's no audio in the file.

But mplayer on windows plays fine - so there's audio in the stream. XMMS on linux has the same problem - it makes the connection to the server, but the audio stream appears to be empty. Something is up here.

If anyone has seen this, please let me know - linux codec problem? both mplayer and xmms play files fine, http streams of files, etc - just not stream from slimserver?


Audio file file format detected.
================================================== ========================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16le, 320.0 kbit/22.68% (ratio: 40000->176400)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
================================================== ========================
AO: [pulse] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A: 3.9 (03.8) of 0.0 (unknown) 0.6% 45%
ICY Info: StreamTitle='Welcome to SlimServer';
A: 4.7 (04.7) of 0.0 (unknown) 0.6% 45%
ICY Info: StreamTitle='Welcome to SlimServer';
A: 5.5 (05.5) of 0.0 (unknown) 0.6% 45%
ICY Info: StreamTitle='Welcome to SlimServer';
--- etc......


I'm trying to get slimserver up an running, so far so good.

bpa
2007-12-21, 09:09
Have you installed lame ?

graymon
2007-12-21, 09:43
Lame is in there.

$ rpm -q lame
lame-3.97-6.lvn8

mplayer and xmms all work fine with mp3 files. mplayer even recognizes it as an mp3 stream and seems to "play" it, but it just plays silence. I've been searching around google and various newgroups, the slimserver bug list, but I can't find anything. It doesn't seem like slimserver is transcoding the file into anything else?

The FILE FORMAT CONVERSION SETUP portion of the web server had some checkboxes for MP3. I shut them off, then nothing worked - even in windows, so I rechecked them. It was a little confusing - was it converting MP3 => MP3?

Anyway, mplayer never seems to get past the

ICY Info: StreamTitle='Welcome to SlimServer';

The mplayer in windows actually starts to display the Song Title - that's about the only difference I can see in the players on the two different platforms. I've streamed mp3 files over http with mplayer and they work fine. This stinks.

bpa
2007-12-21, 10:10
Can you provide more details on your setup (e.g. OS, SS version), what you are trying to do and how you are starting the stream to play files/streams.

Have you selected the stream.mp3 "device" from the web interface and started any thing to play ?

If you have set up "bit rate limiting" on the player then MP3=>MP3 will occur as Slimserver transcodes the Mp3 file down to the requested bit rate (e.g. 64kbits/sec)

If so then get a log with d_source enbaled.

graymon
2007-12-21, 11:02
Setup,

Server - Fedora Core 4
Slim Server - slimserver-6.5.4-1

Client 1
Fedora 8
mplayer-1.0-0.88.rc2.lvn
xmms-1.2.10-36.fc7
xmms-mp3-1.2.10-5.lvn6

Client 2
Windows XP Pro
MPlayer 1.0rc1-3.4.2 (C) 2000-2006 MPlayer Team - works good
Windows Media Player (8?) - works good


I ran the same command for both platforms:
mplayer http://server2:9000/stream.mp3

This was "interesting"
mplayer -dumpstream http://server2:9000/stream.mp3 -dumpfile output

The dumpstream output from windows played on both windows and linux. The dumpstream output from linux did NOT play on windows or linux. It seems like slimserver is servning up different streams for different platforms?

I didn't set up any bitrate limiting. Other than setting the directory for the mp3 files, it's all default settings.

graymon
2007-12-21, 11:07
there's definitely different content in the streams. the linux clients all receive 55 55 55 55 55 55,s

I took a screen dump of the two stream in a hex editor. I'll try to attach it.

bpa
2007-12-21, 11:17
Did you use the web interface to select the stream.mp3 player and then start playing track ?

If so then where is the d_source log ?

graymon
2007-12-21, 11:36
i used the web interface to start playing one of the tracks. I checked off d_source under server setting => debugging. I clicked Change, but the link at the top of the page to the log.txt file doesn't return anything. I don't see a log file. I can't find one in /etc/ or /var either.

d_source

1

SlimServer has a number of debugging settings that can be used to record detailed information about the server's operation. Check off the items that you'd like logged for display and click Change to start logging that information. You can view the most recent log entries here. <== this link does nothing

bpa
2007-12-21, 11:44
The "here" link opens a new window viewing the log.txt file.

If that is not working then I think you should check your installation.

graymon
2007-12-21, 11:50
I reinstalled the server, then the log came up

2007-12-21 12:41:31.5851 Your data source needs to be configured. Please open your web browser,
2007-12-21 12:41:31.5855 go to the following URL, and click on the "Server Settings" link.

2007-12-21 12:41:31.5857 The URL to access SlimServer is now:

http://server2:9000/

The windows are players are working fine. Linux players - all 55 55 55 s

bpa
2007-12-21, 12:02
The "Your data source needs to be configured." means you have no source of audio tracks defined - how can you be playing tracks with none defined ?

If you have defined a source directory - the log does not show you selecting any file to play.

Double check d_source is enabled and once enabled, then play a file and make sure log window is refreshed to ensure all log messages are shown.

graymon
2007-12-21, 12:07
I enabled the d_http_verbose. It looks like the server is intentionally streaming this "silence.mp3" file to the linux client 192.168.1.7, and the correct file in the playlist to the other clients. I don't see anything about the request type in the log file - like "request unknown - sending silence to client"




<snip>
007-12-21 13:00:12.2627 reading http file for (/usr/local/slimserver/HTML/EN/html/silence.mp3)
2007-12-21 13:00:12.2633 metadata bytes: 10951
2007-12-21 13:00:12.2640 Streamed 10449 to 192.168.1.7
2007-12-21 13:00:12.2654 sendstreaming response begun...
2007-12-21 13:00:12.2661 (silence)2007-12-21 13:00:12.2667 generating from html/silence.mp3 type: get
2007-12-21 13:00:12.2676 found path: /usr/local/slimserver/HTML/EN/html/silence.mp3
2007-12-21 13:00:12.2680 reading http file for (/usr/local/slimserver/HTML/EN/html/silence.mp3)
2007-12-21 13:00:12.2688 metadata bytes: 21400
2007-12-21 13:00:12.2696 Streamed 10449 to 192.168.1.7
2007-12-21 13:00:12.2709 sendstreaming response begun...
2007-12-21 13:00:12.2716 (silence)2007-12-21 13:00:12.2722 generating from html/silence.mp3 type: get
2007-12-21 13:00:12.2731 found path: /usr/local/slimserver/HTML/EN/html/silence.mp3
2007-12-21 13:00:12.2735 reading http file for (/usr/local/slimserver/HTML/EN/html/silence.mp3)
2007-12-21 13:00:12.2742 metadata bytes: 31849
2007-12-21 13:00:12.2748 splitting message for metadata at 919
2007-12-21 13:00:12.2752 Streamed 919 to 192.168.1.7
2007-12-21 13:00:12.2763 sendstreaming response begun...
2007-12-21 13:00:12.2771 metadata bytes: 32768
2007-12-21 13:00:12.2776 sending metadata of length 3: 'StreamTitle='Welcome to SlimServer';������������' (49 bytes)
2007-12-21 13:00:12.2782 Streamed 49 to 192.168.1.7
2007-12-21 13:00:12.2792 sendstreaming response begun...
2007-12-21 13:00:12.2800 metadata bytes: 0
2007-12-21 13:00:12.2806 Streamed 9530 to 192.168.1.7
2007-12-21 13:00:12.2818 sendstreaming response begun...
2007-12-21 13:00:12.2826 (silence)2007-12-21 13:00:12.2832 generating from html/silence.mp3 type: get
2007-12-21 13:00:12.2841 found path: /usr/local/slimserver/HTML/EN/html/silence.mp3
2007-12-21 13:00:12.2845 reading http file for (/usr/local/slimserver/HTML/EN/html/silence.mp3)

graymon
2007-12-21, 12:23
I may be stupid and this could be in the documenation, but the linux clients work fine if you run them first. I stopped the server, restarted it, then started the linux clients, they worked fine, and the windows version receive silence.mp3 per the log.txt file on the server. Is that normal behavior for some max connections setting?

graymon
2007-12-21, 12:40
This one is solved - pilot error.

I only had playlists set up for one client. There is a drop down in the top right for each IP address. As soon as I added another playlist for the second client's IP address, everything was up and running. The first client was of course the only one that would show up in the drop down, so that one would work fine. When the next one connected, it would remain idle until to select in and assign it a playlist.