View Full Version : Scanning MusicIP

Aux Memes
2007-12-17, 03:25
Can anyone help please. I know this problem comes up time after time, but I'm really stuck.

I have MusicIP working perfectly, GUI and "headless" (port 10002), with a single database. All on XP by the way.

I've been running this with Slimserver for well over a year with no problems, taking the latest updates.

Recently I installed Music IP 1.8 and it all fell apart because 1.8 has it's database in a different directory. When I added new music it was showing in Slimserver but not as mixable (mm icom). I finally figured out what had happened so I changed the mmm.ini file to point at the same database. This was fine as the MusicIP Server was including all the tracks again.

Slimserver still didn't show the new tracks as mixable. I did a rescan for new music and it still didn't show them as mixable. I did a rescan clear and the number of mixable tracks reduced to about 50%. After a lot of searching I found the thread on this site that says slimserver can't process a music folder and MusicIP at the same time (although at some point in the past it worked for me).

I removed the music directory and did a rescan. This removed the non mixable tracks from Slimserver. Now all the tracks are mixable but only 50% of my tracks are in Slimserver.

I uninstalled Slimserver and reinstalled but still the same, although the number of tracks found was different. I've tried debug but there are no scan errors.

I've tried rebuilding the MusicIP database and I've tried uninstalling and re-installing MusicIP. All the time MusicIP seems fine and has all my music, Slimserver just doesn't seem to scan it all.

Any ideas anyone?


2007-12-17, 08:36
I haven't had that specific problem but have certainly had occasional quirks with MusicIP and Slimserver. Try doing these things, in this order:

- Make sure that Slimserver is set to use MusicIP in the Server Settings->Plugins, and that the port is right
- Clear out the Music Folder and Playlists folder in Slimserver's Settings->Basic Settings
- Close Slimserver
- Make sure that MusicMagic is listing the stuff you expect. Make sure the API service is turned on.
- Open Slimserver
- Make sure that MusicMagic is listed in your Server Settings (meaning that SlimServer sees it and is connected to it)
- clear library and rescan. Unfortunately this will take a really really long time, but you probably already know that.

I hope that helps: ideally that should both help you troubleshoot and get your library all reset.

Aux Memes
2007-12-17, 09:27
Thanks for the suggestions. I've done all those things and in the right order.

I did just try this though: Reinstalled SS and let it scan with my music folder. Got all my music (7k tracks). Started MM Server. Restarted SS to pick up the MM server. Removed the music folder from the settings and clicked MM. No autoscan started which is odd so started a clear and scan and it started scanning. After the scan I have 5.5k of my 7k tracks, 20% more than before.

If I did this again would I get a different number? Ie. does it scan an arbitary number of tracks or is it sequence dependent?

Anyway, still not working properly. If only I could see the tracks it's missed I might see a pattern.........

2007-12-17, 09:48
There is a way to see where the scan integration is falling over, but before you go there - do any of your file names (not tags) have non-unicode symbols in? Accents, umlauts, symbols etc?

If so, that's may be the cause of your integration scan falling over (although I thought it was only a problem with MIP on Linux). Recent thread about it here (http://forums.slimdevices.com/showthread.php?t=40845&highlight=musicip).

Assuming that's not the case, here's how to see the results of the scan (assuming you are on a 6.5 build of Slimserver):

Open up a command prompt in Windows (Run/cmd) and then enter (assuming a standard Windows install of Slimserver):

"c:\program files\slimserver\server\scanner.exe" --d_wipe --d_sql --d_scan --d_parse --d_musicmagic --d_info <musicfolder>

You need to replace <musicfolder> with the reference to your own music folder as you put it in Slimserver.

The output should show files as they are scanned and may give you an idea where and why the integration scan is getting locked up.

2007-12-17, 09:51
The other thing is to open up the MIP application and let it scan your library, just to check that it thinks the songs are all validated and mixable. Even though you are running headless, you should still be able to use the GUI to do this. If not, shut down the MIP service, let the application GUI validate all the songs, save cache, shut down and restart the service.

Then navigate to the MIP server page on "http://[IP]:10002" and "reload cache".

Aux Memes
2007-12-17, 14:13
Thanks for all the advice!!! It's helped me find the solution which is that Mcafee Virus Protection was stopping the creation of a work file the scanner.exe was trying to create for a particular type of track.

Having run the scanner as suggested I found the error (Errcode: 13) line 771 in scanner.exe . I'm filling the details in here in the hope it may help some other unfortunate person when this hits google.

Can I also add that the command supplied by Siduhe is for scanning a folder. If you want to scan from MusicIP you need to add the --musicmagic option and remove the folder option. It's also best to add the --wipe option to clear the cache before the scan so you get a complete picture. Also a good idea to redirect the output so you can review the whole log after the scan and not just the last few pages.

Here's the command I used:
"g:\slimserver\server\scanner.exe" --wipe --musicmagic --d_sql --d_scan --d_parse --d_musicmagic --d_info >[output file name] 2>&1

Don't know why Mcafee Virus Protection is doing this and whether this is a change to Mcafee or SS that's created the problem. I stopped Mcafee before the scan and restarted it after. Obviously you can't do this all the time so the solution is to change Mcafee to only scan Program Files and documents in Realtime. Here's the link that made me try Mcafee:

Thanks All