PDA

View Full Version : Cant open file error



goldmanns
2007-12-13, 06:07
SlimServer Version: 6.5.4 - 12568 - Debian - EN - utf8
Perl Version: 5.8.8 i486-linux-gnu-thread-multi
MySQL Version: 5.0.38-Ubuntu_0ubuntu1

I have a large external VFAT disk attached to the server (Ubuntu 7.10). Slimserver scans my library just fine, but refuses to play (Cant Open FIle error). MP3 located on local XFS filesystem are opened and played just fine. I tried mounting the external drive with UTF8 setting but that didnt change anything. Here is excerpt from the log:

2007-12-13 14:49:28.7479 Got /media/slimserver/bigdisk/Ahmad%20Jamal/After%20Fajr/02%20After%20Fajr.m4a from file url file:///media/slimserver/bigdisk/Ahmad%20Jamal/After%20Fajr/02%20After%20Fajr.m4a
2007-12-13 14:49:28.7484 extracted: /media/slimserver/bigdisk/Ahmad Jamal/After Fajr/02 After Fajr.m4a from file:///media/slimserver/bigdisk/Ahmad%20Jamal/After%20Fajr/02%20After%20Fajr.m4a
2007-12-13 14:49:28.7506 Backtrace:

frame 0: Slim::Player::Source::errorOpening (/usr/share/perl5/Slim/Player/Source.pm line 1666)
frame 1: Slim::Player::Source::openSong (/usr/share/perl5/Slim/Player/Source.pm line 1146)
frame 2: Slim::Player::Source::gotoNext (/usr/share/perl5/Slim/Player/Source.pm line 403)
frame 3: Slim::Player::Source::playmode (/usr/share/perl5/Slim/Player/Source.pm line 1036)
frame 4: Slim::Player::Source::jumpto (/usr/share/perl5/Slim/Control/Commands.pm line 1103)
frame 5: Slim::Control::Commands::playlistXtracksCommand (/usr/share/perl5/Slim/Control/Request.pm line 1483)
frame 6: (eval) (/usr/share/perl5/Slim/Control/Request.pm line 1483)
frame 7: Slim::Control::Request::execute (/usr/share/perl5/Slim/Control/Request.pm line 772)
frame 8: Slim::Control::Request::executeRequest (/usr/share/perl5/Slim/Web/HTTP.pm line 705)
frame 9: Slim::Web::HTTP::processURL (/usr/share/perl5/Slim/Web/HTTP.pm line 555)
frame 10: Slim::Web::HTTP::processHTTP (/usr/share/perl5/Slim/Networking/Select.pm line 238)
frame 11: (eval) (/usr/share/perl5/Slim/Networking/Select.pm line 238)
frame 12: Slim::Networking::Select::select (/usr/sbin/slimserver line 499)
frame 13: main::idle (/usr/sbin/slimserver line 452)
frame 14: main::main (/usr/sbin/slimserver line 1076)

Mark Lanctot
2007-12-13, 09:10
Permissions on the vfat drive?

Is there a reason you're using vfat? Its capabilities are pretty limited.

goldmanns
2007-12-13, 10:34
Permissions on the vfat drive?

Is there a reason you're using vfat? Its capabilities are pretty limited.

VFAT is used because the drive has to be useable with Winblows. At any rate it is almost impossible to reformat it... I don't have 1TB of free space anywhere else.

I think I solved it... alac-decoder was missing on my box and it couldnt transcode AAC into MP3 or something. At any rate seems to work now...