PDA

View Full Version : /etc/mysql/conf.d/old_passwords.cnf: No such file or directory



dac413
2007-12-04, 23:20
I was having a problem with slimserver updating my library correctly (it kept reverting to an earlier status), so I deleted mysql-server-5.0 using:
dac@home:/etc$ sudo dpkg --purge mysql-server-5.0

Poor. Life. Decision.

I now get the titular error whenever I try to reinstall.

I've tried to touch /etc/mysql/conf.d/old_passwords.cnf thinking that, "Perhaps a blank file will work!", but I get:
touch: cannot touch `/etc/mysql/conf.d/old_passwords.cnf': No such file or directory

=(


It's a mysql error which I hope someone here has encountered.
I searched the mysql forums with no luck.
The ubuntu forms have some identical instances with no resolution.
-- http://ubuntuforums.org/archive/index.php/t-534530.html
-- http://ubuntuforums.org/showthread.php?t=424705

I have an independent /home partition, so worst case, I have to reinstall, but I use mysql a good bit, and would hate to see this issue go unsolved.

Thanks for taking a look~
dac


Below is what happens if I try to install slimserver. (pkgs are already downloaded; have purged first and tried with same result.)


dac@home:/etc$ sudo apt-get install slimserver
Reading package lists... Done
Building dependency tree
Reading state information... Done
slimserver is already the newest version.
The following packages were automatically installed and are no longer required:
liburi-find-perl libtie-regexphash-perl libpath-class-perl libio-string-perl
libmpeg-audio-frame-perl libdata-page-perl libdbix-contextualfetch-perl
libxml-libxml-common-perl libyaml-syck-perl libtext-unidecode-perl
libipc-sharelite-perl libnet-ssleay-perl libtest-exception-perl
libxml-namespacesupport-perl libclass-whitehole-perl libfilter-perl
libclass-accessor-perl libtie-llhash-perl libcgi-perl libtext-glob-perl
libclass-trigger-perl libclass-accessor-chained-perl libdata-dump-perl
libcache-cache-perl libclass-inspector-perl libclass-data-accessor-perl
libclass-c3-perl libexporter-lite-perl libboost-thread1.34.1
libcarp-assert-perl liberror-perl libcarp-clan-perl libtemplate-perl
libdbix-class-perl libboost-date-time1.34.1 libyaml-perl libossp-uuid-perl
libgd2-noxpm libxml-xspf-perl libdbix-migration-perl libossp-uuid15
libuniversal-require-perl libdata-vstring-perl libtie-cache-lru-perl
libpoe-perl libima-dbi-perl libtime-modules-perl libreadonly-perl
libsql-abstract-perl libmodule-find-perl libfile-which-perl
libio-stringy-perl libxml-libxml-perl libappconfig-perl libtie-cache-perl
libxml-sax-perl libnet-ip-perl libfile-bom-perl libnet-dns-perl
libtimedate-perl libfile-find-rule-perl libfile-slurp-perl libenum-perl
libuniversal-exports-perl libxml-simple-perl libxml-writer-perl
libsql-abstract-limit-perl libgd-gd2-noxpm-perl libclass-virtual-perl
libclass-data-inheritable-perl libproc-background-perl libio-socket-ssl-perl
libtie-cache-lru-expires-perl libdigest-hmac-perl libsub-uplevel-perl
gnash-common libnet-upnp-perl libclass-singleton-perl libnumber-compare-perl
libmp4-info-perl libalgorithm-c3-perl libuniversal-moniker-perl
libdigest-sha1-perl
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 0B of archives.
After unpacking 0B of additional disk space will be used.
Setting up mysql-server-5.0 (5.0.45-1ubuntu3) ...
* Stopping MySQL database server mysqld [ OK ]
/var/lib/dpkg/info/mysql-server-5.0.postinst: line 143: /etc/mysql/conf.d/old_passwords.cnf: No such file or directory
dpkg: error processing mysql-server-5.0 (--configure):
subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of slimserver:
slimserver depends on mysql-server-4.1 | mysql-server-5.0; however:
Package mysql-server-4.1 is not installed.
Package mysql-server-5.0 is not configured yet.
dpkg: error processing slimserver (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
mysql-server-5.0
slimserver
E: Sub-process /usr/bin/dpkg returned an error code (1)

Mark Miksis
2007-12-05, 11:51
I have no idea what caused the original problem, but...


I've tried to touch /etc/mysql/conf.d/old_passwords.cnf thinking that, "Perhaps a blank file will work!", but I get:
touch: cannot touch `/etc/mysql/conf.d/old_passwords.cnf': No such file or directory

I can tell you that this error means that the path to the file you're trying to touch does not exist. Maybe try:

mkdir -p /etc/mysql/conf.d
touch /etc/mysql/conf.d/old_passwords.cnf

You may have to work out the correct permissions for those dirs...

dac413
2007-12-05, 13:52
Thanks for the post.

I'll try that when I get home.

Also, a friend of mine suggested purging the dummy package instead.

apt-get remove --purge mysql-server

I'm going to try that as well and post back.

Here's a link to the ubuntu post on the same issue:

http://ohioloco.ubuntuforums.org/showthread.php?t=626443