PDA

View Full Version : Slimserver unable to connect to DB



NBR
2007-12-04, 07:10
I am running Slimserver 6.5.1 on a Linksys NSLU2 with the Unslung OS. I use a Squeezebox v2. So far, the Slimserver and the SB have worked fine, but after restarting the NSLU2 I ran into problems.

The slimserver starts, but terminates after a few seconds. The slimserver log contains the following:

<start log>

2007-12-02 22:28:22.0556 ERROR: DBI Connection failed: DBI connect('hostname=127.0.0.1;port=9092;database=sli mserver:mysql_socket=/home/slimserver/cache/slimserver-mysql.sock','slimserver',...) failed: Can't connect to MySQL server on '127.0.0.1' (111) at /opt/share/ss65/CPAN/DBIx/Class/Storage/DBI.pm line 652
2007-12-02 22:28:22.2252 ERROR: Backtrace follows:
2007-12-02 22:28:22.2418 Backtrace:
frame 0: Slim::Schema::Storage::throw_exception (/opt/share/ss65/CPAN/DBIx/Class/Storage/DBI.pm line 658)
frame 1: DBIx::Class::Storage::DBI::_connect (/opt/share/ss65/CPAN/DBIx/Class/Storage/DBI.pm line 616)
frame 2: DBIx::Class::Storage::DBI::_populate_dbh (/opt/share/ss65/CPAN/DBIx/Class/Storage/DBI.pm line 543)
frame 3: DBIx::Class::Storage::DBI::ensure_connected (/opt/share/ss65/Slim/Schema/Storage.pm line 28)
frame 4: (eval) (/opt/share/ss65/Slim/Schema/Storage.pm line 28)
frame 5: Slim::Schema::Storage::dbh (/opt/share/ss65/Slim/Schema.pm line 118)
frame 6: Slim::Schema::init (/opt/share/ss65/Slim/Music/Info.pm line 71)
frame 7: Slim::Music::Info::init (/opt/share/ss65/slimserver.pl line 366)
frame 8: main::init (/opt/share/ss65/slimserver.pl line 443)
frame 9: main::main (/opt/share/ss65/slimserver.pl line 1071)

2007-12-02 22:28:22.2462 ERROR: Couldn't connect to database! Fatal error: [Transport endpoint is not connected] Exiting!
2007-12-02 22:28:22.2424 Backtrace:
frame 0: Slim::Schema::init (/opt/share/ss65/Slim/Music/Info.pm line 71)
frame 1: Slim::Music::Info::init (/opt/share/ss65/slimserver.pl line 366)
frame 2: main::init (/opt/share/ss65/slimserver.pl line 443)
frame 3: main::main (/opt/share/ss65/slimserver.pl line 1071)
warning: World-writable config file /home/slimserver/cache/my.cnf is ignored

<end log>

It seems that there is a problem connecting to the database.

The database seems to use port number 9092. I guess that it could be a problem with the port configuration or the mysql service.

Being new to MySQL, I am not quite sure how to track the error.

Ideas are most welcome.

Eiber
2007-12-05, 12:51
Hello,
I`m used the SC7, after the same problems on my Synology CS 407.
This version runs since 2 weeks without problems. I donīt now thats the mysql problem in the 6.5.... :-(
Then the SC7 runs on your system, install this version.
Regard`s, Eiber. :-)