PDA

View Full Version : Playlist problems with tracks on remote server



Michael Robinson
2004-01-26, 12:55
Dean,

I just tried the 5.1 candidate load and everything now seems fine playing
AAC tracks.

Thanks very much for this - the Squeezebox not does everything I need it to
do,


> Hi Michael,
>
> Sorry for taking so to get back to you.
>
> I've found and fixed the problem you were having with streaming MP3
> files from a web server. Look for it in the next nightly build.
>
> The problems you are having with AAC files I can't reproduce here.
> What make and model of wireless router do you have? Also, can you see
> if your serving computer has an abnormally high CPU load? That could
> explain the issue as well.
>
> -dean
>
> On Jan 12, 2004, at 11:52 AM, Michael Robinson wrote:
>
>> Thanks for the reply Dean. I tried SlimServer_v2004-01-12.dmg
>>
>> 1. The problem with mp3 tracks on a remote server as described below
>> still
>> exists.
>>
>> 2. The Time Elapsed on this release also appeared to be broken. The
>> track
>> duration was different every time I played a track and didn't
>> increment or
>> decrement.
>>
>> 3. The problem I reported previously with AAC tracks cutting out every
>> 5
>> seconds still exists. You suggested that "Ah, that's probably due to
>> the
>> fact that the new version sends the decoded AAC files in raw format,
>> which
>> uses substantially more network bandwidth. Your network strength is
>> probably just a little weak. Can you try adjusting the position of
>> your
>> antenna or even temporarily move the Squeezebox closer to the access
>> point
>> to test?"
>>
>> Signal strength in normal location was 76% I moved Squeezebox to
>> location
>> right beside wireless router (signal strength 92%) and AAC cutout still
>> occurs every 5 seconds or so.
>>
>> I connected Squeezebox directly to wireless router via ethernet I got
>> a
>> cutout about 2 seconds into each track however didn't get cutouts
>> during the
>> track.
>>
>> I've gone back to 5.0.1 as most of the my collection is AAC and the
>> latest
>> Slimserver version isn't usable with this.
>>
>>> Michael,
>>>
>>> Please try the latest pre-release version, here:
>>>
>>> http://www.slimdevices.com/downloads/nightly/latest
>>>
>>> -dean
>>>
>>> On Jan 11, 2004, at 11:44 AM, Michael Robinson wrote:
>>>
>>>> Iım having a problem with playlists (m3u files) where the tracks are
>>>> on a remote server.
>>>>
>>>> If I select the playlist on my Squeezebox menu, the first track plays
>>>> without any problem. However, when the track is finished, the
>>>> Squeezebox doesnıt move on to the next track in the playlist. There
>>>> is silence and the display shows the elapsed time for the track
>>>> incrementing for at least 10 minutes after the end of the track (I
>>>> havenıt had the patience to wait longer than this)
>>>>
>>>> If I press the forward key on the remote control, the Squeezebox
>>>> moves
>>>> on to the next track in the playlist without any problem. Again, the
>>>> second track does not move on to the next track after it finishes.
>>>>
>>>> For some reason, if I change the options for the display to show the
>>>> remaining time of the track, it doesnıt do this * it still shows the
>>>> elapsed time.
>>>>
>>>> iTunes can play the tracks at the remote URL without any problem and
>>>> moves on to the next track after the song has finished.
>>>>
>>>> I donıt have any problems with playlists where the tracks are on my
>>>> local machine.
>>>>
>>>> Any ideas? Iım using Squeezebox + Slimserver 5.0.1 + Mac with OS
>>>> 10.3.2
>>>>
>>>> I looked at some debug traces and saw the message ³Underrun while
>>>> this
>>>> mode: play² occur for all tracks about 5 or so seconds after the
>>>> track
>>>> SHOULD have finished.
>>>>
>>>> 2004-01-11 18:37:13.6825 00:04:20:05:04:d6: Current playmode: stop
>>>> 2004-01-11 18:37:13 22004-01-11 18:37:13.6841 00:04:20:05:04:d6:
>>>> Switching to mode play
>>>> 2004-01-11 18:37:13.6858 openSong
>>>> on:http://remote-server-url/Billy%20Bragg/Back%20To%20Basics/
>>>> To%20Have%20and%20to%20Have%20Not.mp3
>>>> 2004-01-11 18:37:13.9801 00:04:20:05:04:d6 New play mode: play
>>>> 2004-01-11 18:37:13.9909 00:04:20:05:04:d6: Current playmode: play
>>>> 2004-01-11 18:37:14.0038 00:04:20:05:04:d6: Switching to mode play
>>>> 2004-01-11 18:37:14.0049 Already in playmode play : ignoring mode
>>>> change
>>>> 2004-01-11 18:37:14.0053 00:04:20:05:04:d6: Current playmode: play
>>>> 2004-01-11 18:37:14.0691 would have blocked, will try again later
>>>> 2004-01-11 18:37:14.1230 would have blocked, will try again later
>>>> 2004-01-11 18:37:14.1772 would have blocked, will try again later
>>>> *** Debug logs deleted ***
>>>> 2004-01-11 18:37:23.8883 would have blocked, will try again later
>>>> 2004-01-11 18:37:23.9437 would have blocked, will try again later
>>>> 2004-01-11 18:37:23.9978 would have blocked, will try again later
>>>> *** track is 2:49 mins. Log occurs after 2:54 mins ***
>>>> 2004-01-11 18:39:51.6050 00:04:20:05:04:d6: Underrun while this mode:
>>>> play
>>>> *** Forward pressed on remote ***
>>>> 2004-01-11 18:40:20.1765 00:04:20:05:04:d6: Switching to mode stop
>>>> 2004-01-11 18:40:20.1772 00:04:20:05:04:d6 New play mode: stop
>>>> 2004-01-11 18:40:20.1779 Stopping and clearing out old chunks for
>>>> client 00:04:20:05:04:d6
>>>> 2004-01-11 18:40:20.1846 00:04:20:05:04:d6: Current playmode: stop
>>>> 2004-01-11 18:40:20 22004-01-11 18:40:20.1865 00:04:20:05:04:d6:
>>>> Switching to mode play
>>>> 2004-01-11 18:40:20.1879 openSong
>>>> on:http://remote-server-url/Billy%20Bragg/Back%20To%20Basics/
>>>> Richard.mp3
>>>> 2004-01-11 18:40:20.4657 00:04:20:05:04:d6 New play mode: play
>>>> 2004-01-11 18:40:20.4761 00:04:20:05:04:d6: Current playmode: play
>>>> 2004-01-11 18:40:20.4901 00:04:20:05:04:d6: Switching to mode play
>>>> 2004-01-11 18:40:20.4906 Already in playmode play : ignoring mode
>>>> change
>>>> 2004-01-11 18:40:20.4911 00:04:20:05:04:d6: Current playmode: play
>>>> 2004-01-11 18:40:20.5526 would have blocked, will try again later
>>>> 2004-01-11 18:40:20.6076 would have blocked, will try again later
>>>> 2004-01-11 18:40:20.6619 would have blocked, will try again later
>>>> *** Debug logs deleted ***
>>>> 2004-01-11 18:40:28.9175 would have blocked, will try again later
>>>> 2004-01-11 18:40:28.9721 would have blocked, will try again later
>>>> *** track is 2:33 mins. Log occurs after 2:37 mins ***
>>>> 2004-01-11 18:43:14.6751 00:04:20:05:04:d6: Underrun while this mode:
>>>> play
>>>>
>>>>
>>>>
>>>>
>>>>