PDA

View Full Version : Dependency question...



jfalk
2007-11-27, 14:01
Complete linux noob. I'm using the creation of a headless slimserver box as my first foray into Linux. Having read the excellent instructions on the CC 4.2 distro, I went that way. On doing so, I realized what it is that drives me nuts.... when someone says "type this command..." and I don't know what the command does, I get frustrated. When you don't know what you're doing, it's hard to work around a roadblock. Worse, you may think you've gotten around a roadblock only to drive off a cliff.

In any case, everything seems to have worked fine, with one exception: the command "apt-get install perl-Digest-SHA1" came back with a "no can do" reply. Then the rpm command came back with a "you need perl-Digest-SHA1" A little hunting on this forum got me to find the --nodeps option and everything seems to work. I'm amazed! But what I want to know is, what have I done? Have I planted a time bomb in which slimserver is going to ask for perl-Digest-SHA1, not find it, and erase my hard disk or something?

pfarrell
2007-11-27, 14:22
jfalk wrote:
> Complete linux noob. I'm using the creation of a headless slimserver
> box as my first foray into Linux.

headless does not mean never allow you to see what you are typing, it
means not having a keyboard and monitor on the box.

You manage it by using SSH from some other computer that has keyboards,
mouse, video, etc.

Normally, one connects a monitor, mouse and keyboard to get a headless
server up and working. Then you move them back to someplace else.
Or use a KVM to switch. I've got eight servers on a KVM in my basement.

jfalk
2007-11-27, 14:36
Thanks, but that part is working fine. the instructions worked perfectly there... (Well not completely so... I trashed a copy of Windows XP which was probably half the cost of my refurbished box, but that's no big deal... I didn't intend to use it anyway) I'm just worried about whether using the --nodeps switch will cause me problems later, or, alternatively, what I can do to get perl-digest-SHA1

Mark Miksis
2007-11-27, 16:48
Normally, it's a bad idea to use --nodeps unless you know what you're doing. In this case, you'll be fine. Slimserver doesn't really need perl-Digest-SHA1 because it includes its own version of that module. This dependency has been removed from the RPM for version 7.

signor_rossi
2007-11-28, 10:45
I am a bit curious, can anyone tell me what distribution CC4.2 is?
And to the OP, why do you mix rpm and deb on your box?

Bye, signor_rossi.

Mark Miksis
2007-11-28, 11:02
CC=ClarkConnect which is based on CentOS

I don't think he's using deb. CC is RPM based but uses apt-rpm instead of yum.

signor_rossi
2007-11-28, 13:33
Thanks for the info, haven't heard about apt-rpm before. Mixing apt nd rpm commands in the same distro seemed suspect to me. ;)