PDA

View Full Version : Mac Mini - going to sleep



unclepuncle
2007-11-13, 14:41
I've just sorted out a Mac Mini to use as my slimserver music server which I want switched on 24/7 (rather than use my main PC which is noisy and power hungry).

Everything has gone ok and it is now serving my two SB3's perfectly as I type this.

However, it seems to go into some sort of sleep mode if left inactive for any length of time (I don't have any mouse, keyboard or monitor plugged in) and I have to use the power button on the back of it to wake it up. Once I press this it comes back to life and my SB3's can then find slimserver almost straight away.

Is it possible to stop this 'sleep mode' so that it stays on permanently. I've never used a Mac before this arrived yesterday so excuse my ignorance.

qirex
2007-11-13, 15:07
I'm doing this from memory but there is a prefs pane in System Preferences > Energy Saver where you can set the sleep settings.

googdot
2007-11-14, 12:36
That's correct - sleep settings are in System Preferences - Energy Saver.

I have the same setup and my mini has been running as a dedicated server box 24/7 for well over a year and half now. The machine is headless and I control the settings updates, etc. via VNC from my other mac.

An alternative would be to setup Wake on LAN as that works fine as well if you do in fact want your mini to sleep when idle.

PM me if you need any specific details - happy to help get it setup :)

KeithL
2007-11-14, 14:12
Are you running your mini-mac wirelessly? If so you will not be able to WOL, wake on lan. You need to go into system preferences as mentioned above to disable sleep.
Keith

googdot
2007-11-14, 14:21
Hi Keith,

thanks - forgot to mention that WOL only works on a wired connection :)

cheers
frank

sugarmonster
2007-11-15, 12:43
As the other posters have said, there's a setting in system preferences that lets you choose the length of time before the mac sleeps.

I have the opposite problem - my mac will sleep on that interval even if I'm playing music! 1/2 way through a song the mac will decide that it's time to go to bed and that's it.

Any ideas? I could just set it to never sleep of course but I like the idea of it being essentially off when I'm not using it. At the moment I've compromised with a sleep setting of 3 hours as I'm rarely using it for that amount of time in one hit.

MelonMonkey
2007-11-15, 12:57
I just keep my Mac mini set to turn itself off sometime after midnight and back on at 9am. It's set not to sleep while it's on.

To prevent the mini from sleeping while music is playing there needs to be special support for this in SlimServer. There are programmatic calls that can be made to the OS to prevent sleep and then calls to allow sleep. I have no idea if S has any such support for this right now.

I'm not sure I'd use sleep even if such support was included though. When the server is sleeping it means SS is suspended and you'll lose the display on your SB. I keep Super Date & Time running to see weather and time instead of looking at a blank SB.

morris_minor
2007-11-16, 12:17
Hi Keith,

thanks - forgot to mention that WOL only works on a wired connection :)

cheers
frank

I might be missing something here, but pressing the power button twice on the SB remote definitely rouses my Mac Mini from sleep.

Press once - the computer wakes up, press a second time and SB starts up . . .

And yes, I do use wireless.

>> What I neglected to say was - SB is connected wirelessly, MAC is wired . . .

unclepuncle
2007-11-17, 06:38
Thanks for the info.

I have gone into the settings and told the Mac Mini never to go into sleep mode. However I still can't seem to keep it 'awake' 24/7.

As a test I had the SB3 playing a random mix on reapeat before I went to work, but when I came back from work about 9 hours later, the SB3 was off and the Mac and slimserver appeared to have stopped running. Likewise if i leave the SB3 in standby with the RSS News Ticker going (which presumably uses the wireless network to get the headlines so should keep things awake), I would expect this to stay on permanently but again it switches off after an hour or so.


Any ideas?

USAudio
2007-11-17, 12:01
Thanks for the info.

I have gone into the settings and told the Mac Mini never to go into sleep mode. However I still can't seem to keep it 'awake' 24/7.
I also use an Mac mini as my dedicated music server and the Preferences > Energy Saver > Never sleep option works OK for me.
You've probably already checked this but just in case; did you verify you don't have the "Schedule..." times on?

Eric Seaberg
2007-11-17, 16:21
I just keep my Mac mini set to turn itself off sometime after midnight and back on at 9am. It's set not to sleep while it's on.


I'd venture to say that it's better for the power supply and hard-drive just to leave them on, as opposed to shutting down and restarting day after day. My Mac MINI has been on continuously for over a year without any hiccups.

Did unclepuncle ever say if he was running wired or wireless?

unclepuncle
2007-11-19, 08:17
Hi again

I'm running wirelessly for those that asked.

Tried various different things but still can't get it to just stay on 24/7. It's fine when I'm actually playing music and swithcing between albums etc, but if I leave it alone, whether in standby or playing on repeat it eventually shuts down (the SB3 screen just goes blank) and then I have to switch the Mac Mini off and on again before I can reconnect to slimserver.

I'll check the preferences and scheduling again.

It's really beginning to annoy the hell out of as I want to put the Mini away out of sight, but I'm constantly having to mess with it whenever I go out or come back from work.

Eric Seaberg
2007-11-19, 09:34
My MINI is stuck in a closet with power, CAT5 and an external drive attached to it. No see, no hear, no mess. I access it using Timbuktu Pro, but that's not really critical to use. Even adding music to the external drive is a piece of cake as I mount it via the network to my G5 and rip from there.

Did you try checking the box that says WAKE FOR ETHERNET ADMINISTRATOR ACCESS? How about deleting the prefs file for Energy Saver?

googdot
2007-11-19, 12:39
Strange behaviour indeed - It seems like you may have a power management issue?

You could try to reset the PRAM, NVRAM, PMU, etc. Details are here: http://docs.info.apple.com/article.html?artnum=300574

Note these instructions are for a G4 mini - see bottom of that page for Intel versions.

unclepuncle
2007-11-21, 11:34
Well I've tried everything but still can't get it to stay on and serving slimserver to the SB3's so I'm going to try a complete reinstall of OS/X and if that doesn't do it I'll get shot of it.

Is it possible that it is slimserver itserlf that is going to sleep (or something to that effect) rather than the actual Mac Mini - maybe if I tried an earlier version of slimserver?

Eric Seaberg
2007-11-22, 10:57
SlimServer doesn't have a 'sleep' setting, although there is a plugin that puts the player displays to sleep. I use this since one of my SB3s is in the master bedroom and the display tends to be a bit 'bright' at night.

Other than that, like I've said above, my MINI is on all the time. Re-installing the OS may fix it, but it is odd.

Let us know what happens after the install.

BTW, I'm using one of the recent nightly's of SlimServer, so it probably wouldn't make any difference going backwards as it is working here.

G'Luck

unclepuncle
2007-11-23, 11:00
Well after all that (reinstalling OS-X and all my music files etc) it still dosen't work how I want it to.

Left it on this morning when I went to work, playing a random mix on repeat, but when I got back home the SB3 screen was blank, and I had to reconnect the SB3 to the mini in order to get it connected to slimserver (when I pressed the red button or play on the remote it tried to wake slimserver and then connect to it but then after a few seconds the screen just goes blank again. I had to go back to the previous part of the connecting setup on the SB3 and point to the actual mac mini before it would then connect to slimserver - I didn't actually have to do anything with the mini (reset it etc) so does that suggests the mini and slimserver were running ok and that it's the SB3 that is having the problem?).

I have no idea what it is - whether it's the mac mini, the SB3, the wireless network (though I don't have this problem with my Vista PC) or slimserver itself it just won't stay on 24/7 even if left on repeat play.

I'm giving up with the whole idea - I'll just have to have my PC on when I want to listen, even though it's noisy and power hungry. First frustrating thing with the SB3, almost enough to drive me back to CD!

danco
2007-11-23, 19:47
As I posted in another thread, there is a program called Jiggle that stop the Mac sleeping while it is running.

And it is possible to set up the SB (using a plugin) to run JUggle while music is playing and turn it off when the music stops.

Details later if needede, as I am travelling and nowhere near my own machine

unclepuncle
2007-11-24, 05:17
As I posted in another thread, there is a program called Jiggle that stop the Mac sleeping while it is running.

And it is possible to set up the SB (using a plugin) to run JUggle while music is playing and turn it off when the music stops.

Details later if needede, as I am travelling and nowhere near my own machine

Ok thanks - but from the sound of it many other people use mac mini's to run slimserver 24/7 and don't have this issue.

Eric Seaberg
2007-11-24, 22:00
OK, silly question... what are you using as a router? Can you confirm that once the SB3 has dis-connected that the Mini is still on? You're running wireless to the SB3, right? Just for fun can you run some CAT-5 and see if it makes a difference?

unclepuncle
2007-11-25, 05:47
My router is a Zoom ADSL X6 - I had wondered if maybe it was something to do with a setting on the router - though my PC which is connected to the same router does not have the switch off problem if I use it to run slimserver to feed the SB3.

One thing I noticed yesterday was that if I have my PC on as well as the Mac Mini running slimserver then the SB3 doesn't seem to have the switch off problem. Maybe the PC is keeping the router awake?

unclepuncle
2007-12-15, 03:23
Well I changed my modem/router to a Netgear model, and it all now works perfectly - no more shutting down.

Only thing I couldn't do was get the SB3 to connect to the network when using WAP security - I had to go back to 128bit WEP - from searching the web this seems to be a problem with Netgear routers and the SB3.

jhonsberger@msn.com
2011-04-16, 15:34
I have a imac with a Transporter and Squeezebox Touch hardwired to a Apple extreme Router. When playing music on the Imac harddrive both will stop playing when my sleep setting(10 minutes)kicks in .My imac isn't supposed to
sleep when there is hard drive activity,like playing music.

Funny thing is I don't remember having this problem several months ago and I haven't changed my sleep settings.I have done Snow Leopard and Squeezebox server updates over the last several months so who knows what the problem is.

last time I had this problem with the sleep function on my imac was about 4 years ago.Since then I haven't had the problem until recently again.

Four years ago I just turned the Imac sleep setting to never when playing music.I guess i may have to do that again .I can do it remotely so its no big deal but I have seen this behavior before with Mac products and Squeezebox software.

If I play Itunes directly on the computer,the Imac never goes to sleep which is the way it should be,only through the Squeezebox products have i had sleep issues off and on over the years.

danco
2011-04-17, 00:58
Try the Really Prevent Standby plugin. I think it's still in beta, so you may have to add the repository before you can get it. Look in the Third Party Plugins forum, perhaps in the Server Power Control thread, for more details.