PDA

View Full Version : Socketwrapper Problem no mplayer --> m4a audio



Yayita
2007-11-11, 02:55
I have WIN XP 32bit SP2
To debug, firewall off (Windows and Zonealarm)
Symantec Corp A/V always on.

*****SS-->
SlimServer Version: 6.5.4 - 12568 - Windows XP - EN - cp1252
Server IP address: 192.168.2.110
Perl Version: 5.8.8 MSWin32-x86-multi-thread
MySQL Version: 5.0.22-community-nt


This is the log:
Setting maxBitRate for Living Slimdevice to: 256
Setting maxBitRate for Living Slimdevice to: 256
Setting maxBitRate for Living Slimdevice to: 256
Setting maxBitRate for Living Slimdevice to: 256
00:04:20:07:22:27: Switching to mode stop from stop
Already in playmode stop : ignoring mode change
Adding song index 0 to song queue
Clearing out song queue first
streamingSongIndex: Song queue is now 0
00:04:20:07:22:27: Switching to mode play from stop
openSong on: file:///M:/Folklore/Los%20Morochucos/()%20Los%20Morochucos/01%20-%20El%20Plebeyo.m4a
openSong: duration: [187] size: [7289697] endian [] offset: [0] for file:///M:/Folklore/Los%20Morochucos/()%20Los%20Morochucos/01%20-%20El%20Plebeyo.m4a
Setting maxBitRate for Living Slimdevice to: 256
Setting maxBitRate for Living Slimdevice to: 256
Setting maxBitRate for Living Slimdevice to: 256
Setting maxBitRate for Living Slimdevice to: 256
undermax = 0, type = mov, squeezebox2 = 00:04:20:07:22:27
checking formats for: mov-wma-squeezebox2-00:04:20:07:22:27
checking formats for: mov-wma-*-00:04:20:07:22:27
checking formats for: mov-wma-squeezebox2-*
checking formats for: mov-wma-*-*
checking formats for: mov-ogg-squeezebox2-00:04:20:07:22:27
checking formats for: mov-ogg-*-00:04:20:07:22:27
checking formats for: mov-ogg-squeezebox2-*
checking formats for: mov-ogg-*-*
checking formats for: mov-flc-squeezebox2-00:04:20:07:22:27
checking formats for: mov-flc-*-00:04:20:07:22:27
checking formats for: mov-flc-squeezebox2-*
checking formats for: mov-flc-*-*
Checking to see if mov-flc-*-* is enabled
enabled
Found command: [mplayer] -really-quiet -vc null -vo null -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# $FILE$ | [flac] -cs --totally-silent --endian=little --channels=2 --sign=signed --bps=16 --sample-rate=44100 --compression-level-0 -
Setting maxBitRate for Living Slimdevice to: 256
Setting maxBitRate for Living Slimdevice to: 256
checking formats for: mov-aif-squeezebox2-00:04:20:07:22:27
checking formats for: mov-aif-*-00:04:20:07:22:27
checking formats for: mov-aif-squeezebox2-*
checking formats for: mov-aif-*-*
Checking to see if mov-aif-*-* is enabled
enabled
Found command: [mov123] $FILE$
Setting maxBitRate for Living Slimdevice to: 256
Setting maxBitRate for Living Slimdevice to: 256
checking formats for: mov-wav-squeezebox2-00:04:20:07:22:27
checking formats for: mov-wav-*-00:04:20:07:22:27
checking formats for: mov-wav-squeezebox2-*
checking formats for: mov-wav-*-*
Checking to see if mov-wav-*-* is enabled
enabled
Found command: [mplayer] -really-quiet -vc null -vo null -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# $FILE$
Setting maxBitRate for Living Slimdevice to: 256
Setting maxBitRate for Living Slimdevice to: 256
checking formats for: mov-mp3-squeezebox2-00:04:20:07:22:27
checking formats for: mov-mp3-*-00:04:20:07:22:27
checking formats for: mov-mp3-squeezebox2-*
checking formats for: mov-mp3-*-*
Checking to see if mov-mp3-*-* is enabled
enabled
Found command: [mplayer] -really-quiet -vc null -vo null -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# $FILE$ | [lame] --silent -r -x -q $QUALITY$ -b $BITRATE$ - -
Setting maxBitRate for Living Slimdevice to: 256
Setting maxBitRate for Living Slimdevice to: 256
Matched Format: mp3 Type: mov Command: [mplayer] -really-quiet -vc null -vo null -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# $FILE$ | [lame] --silent -r -x -q $QUALITY$ -b $BITRATE$ - -
openSong: this is an mov file: file:///M:/Folklore/Los%20Morochucos/()%20Los%20Morochucos/01%20-%20El%20Plebeyo.m4a
file type: mov format: mp3 inrate: 305 maxRate: 256
command: [mplayer] -really-quiet -vc null -vo null -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# $FILE$ | [lame] --silent -r -x -q $QUALITY$ -b $BITRATE$ - -
Using command for conversion: "C:\Program Files\SlimServer\server\Bin\MSWin32-x86-multi-thread\mplayer.exe" -really-quiet -vc null -vo null -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# "M:\Folklore\Los Morochucos\() Los Morochucos\01 - El Plebeyo.m4a" | "C:\Program Files\SlimServer\server\Bin\MSWin32-x86-multi-thread\lame.exe" --silent -r -x -q 6 -b 256 - - |
openSong: Streaming with format: mp3
00:04:20:07:22:27 New play mode: play
00:04:20:07:22:27: Current playmode: play
Setting maxBitRate for Living Slimdevice to: 256
Setting maxBitRate for Living Slimdevice to: 256
Setting maxBitRate for Living Slimdevice to: 256
Setting maxBitRate for Living Slimdevice to: 256
We need to send 0 seconds of silence...
sending 0 bytes of silence
Read to end of file or pipe
end of file or error on socket, opening next song, (song pos: 1671(tell says: . 0 but true), totalbytes: 5984000)
opening next song...
the next song is number 0, was 0
Setting maxBitRate for Living Slimdevice to: 256
Setting maxBitRate for Living Slimdevice to: 256
undermax = 0, type = mov, squeezebox2 = 00:04:20:07:22:27
checking formats for: mov-wma-squeezebox2-00:04:20:07:22:27
checking formats for: mov-wma-*-00:04:20:07:22:27
checking formats for: mov-wma-squeezebox2-*
checking formats for: mov-wma-*-*
checking formats for: mov-ogg-squeezebox2-00:04:20:07:22:27
checking formats for: mov-ogg-*-00:04:20:07:22:27
checking formats for: mov-ogg-squeezebox2-*
checking formats for: mov-ogg-*-*
checking formats for: mov-flc-squeezebox2-00:04:20:07:22:27
checking formats for: mov-flc-*-00:04:20:07:22:27
checking formats for: mov-flc-squeezebox2-*
checking formats for: mov-flc-*-*
Checking to see if mov-flc-*-* is enabled
enabled
Found command: [mplayer] -really-quiet -vc null -vo null -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# $FILE$ | [flac] -cs --totally-silent --endian=little --channels=2 --sign=signed --bps=16 --sample-rate=44100 --compression-level-0 -
Setting maxBitRate for Living Slimdevice to: 256
Setting maxBitRate for Living Slimdevice to: 256
checking formats for: mov-aif-squeezebox2-00:04:20:07:22:27
checking formats for: mov-aif-*-00:04:20:07:22:27
checking formats for: mov-aif-squeezebox2-*
checking formats for: mov-aif-*-*
Checking to see if mov-aif-*-* is enabled
enabled
Found command: [mov123] $FILE$
Setting maxBitRate for Living Slimdevice to: 256
Setting maxBitRate for Living Slimdevice to: 256
checking formats for: mov-wav-squeezebox2-00:04:20:07:22:27
checking formats for: mov-wav-*-00:04:20:07:22:27
checking formats for: mov-wav-squeezebox2-*
checking formats for: mov-wav-*-*
Checking to see if mov-wav-*-* is enabled
enabled
Found command: [mplayer] -really-quiet -vc null -vo null -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# $FILE$
Setting maxBitRate for Living Slimdevice to: 256
Setting maxBitRate for Living Slimdevice to: 256
checking formats for: mov-mp3-squeezebox2-00:04:20:07:22:27
checking formats for: mov-mp3-*-00:04:20:07:22:27
checking formats for: mov-mp3-squeezebox2-*
checking formats for: mov-mp3-*-*
Checking to see if mov-mp3-*-* is enabled
enabled
Found command: [mplayer] -really-quiet -vc null -vo null -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# $FILE$ | [lame] --silent -r -x -q $QUALITY$ -b $BITRATE$ - -
Setting maxBitRate for Living Slimdevice to: 256
Setting maxBitRate for Living Slimdevice to: 256
Matched Format: mp3 Type: mov Command: [mplayer] -really-quiet -vc null -vo null -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# $FILE$ | [lame] --silent -r -x -q $QUALITY$ -b $BITRATE$ - -
playing out before starting next song. (old format: mp3, new: mp3)
00:04:20:07:22:27: Switching to mode playout-play from play
00:04:20:07:22:27 New play mode: playout-play
00:04:20:07:22:27: Current playmode: playout-play
No pending chunks - we're dropping the streaming connection
00:04:20:07:22:27: Can't opennext, returning no chunk.
00:04:20:07:22:27: Decoder underrun while this mode: playout-play
the next song is number 0, was 0
Track failed before playback, marking as played
00:04:20:07:22:27: Switching to mode stop from playout-play
00:04:20:07:22:27 New play mode: stop
Stopping and clearing out old chunks for client 00:04:20:07:22:27
Resetting song queue
resetSongQueue: Song queue is now 0
00:04:20:07:22:27: Current playmode: stop


Is there a new socketwrapper around?

bpa
2007-11-11, 04:14
6.5.4 has the latest version of socketwrapper and it worked with ZoneAlarm. Even disabled ZoneAlarm used to stop old versions of socketwrapper but not the version in 6.5.4. this may be a new version of ZoneAlarm - what version of ZoneAlarm ?

Did you tell ZoneAlarm that socketwrapper.exe, mplayer and slim.exe are all trusted apps ?

Did you replace the socketwrapper that came with 6.5.4 ?
What version of socketwrapper is installed - open a cmd prompt and run socketwrapper - it will show a banner with the version.

Yayita
2007-11-11, 15:40
Thanks bpa for helping...

*quote*
6.5.4 has the latest version of socketwrapper and it worked with ZoneAlarm. Even disabled ZoneAlarm used to stop old versions of socketwrapper but not the version in 6.5.4. this may be a new version of ZoneAlarm - what version of ZoneAlarm ?

7.0.408

*Quote*
Did you tell ZoneAlarm that socketwrapper.exe, mplayer and slim.exe are all trusted apps ?

After reading your answer I did. I thought Zonealarm off was enough. slim.exe had all the rights from before that's why it works with other formats. Still no luck with zonealarm on and off.

*Quote*
Did you replace the socketwrapper that came with 6.5.4 ?
What version of socketwrapper is installed - open a cmd prompt and run socketwrapper - it will show a banner with the version.

Well, after I had no luck yes. I tried one I think you yourself put in the forum. But after that didn't work either I replaced the original. The banner says version 1.10.; 69,632 bytes filesize.

Log stil says...
openSong: this is an mov file: file:///M:/Folklore/Los%20Morochucos/()%20Los%20Morochucos/03%20-%20Jacobo%20el%20le%F1ador.m4a
file type: mov format: mp3 inrate: 304 maxRate: 256
command: [mplayer] -really-quiet -vc null -vo null -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# $FILE$ | [lame] --silent -r -x -q $QUALITY$ -b $BITRATE$ - -
Using command for conversion: "C:\Program Files\SlimServer\server\Bin\MSWin32-x86-multi-thread\mplayer.exe" -really-quiet -vc null -vo null -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# "M:\Folklore\Los Morochucos\() Los Morochucos\03 - Jacobo el leņador.m4a" | "C:\Program Files\SlimServer\server\Bin\MSWin32-x86-multi-thread\lame.exe" --silent -r -x -q 6 -b 256 - - |
openSong: Streaming with format: mp3
00:04:20:07:22:27 New play mode: play
00:04:20:07:22:27: Current playmode: play
We need to send 0 seconds of silence...
sending 0 bytes of silence
Read to end of file or pipe
end of file or error on socket, opening next song, (song pos: 1671(tell says: . 0 but true), totalbytes: 5472000)
opening next song...

bpa
2007-11-11, 15:51
1.10 is the latest version - it has worked with many ZA users since 1.8 but I can't tell whether v7 is new or not.



Well, after I had no luck yes. I tried one I think you yourself put in the forum. But after that didn't work either I replaced the original. The banner says version 1.10.; 69,632 bytes filesize.


And after you replaced sopcketwrapper - did you tell ZoneAlarm that you replaced socketwrapper. Usually ZA remember the authorised file by name and other properties such as size so if you replace the file you will have to delete the old entry and re-enter.

Yayita
2007-11-13, 08:33
I tried deleting the access rules for slim.exe mplayer.exe and socketwrapper, and recreating them. I also tried again with ZA on and off and I always get the same error.

Can you help me trace the faulty source using the command prompt?

If I use mplayer with command prompt, "mplayer c:\path\file.m4a" it play no problem. What would be the command line to test the socketwrapper??

Thanks for your help bpa or any other knowledgeable soul.

bpa
2007-11-13, 10:34
1. Open a command prompt window
2. make Window wide and long (e.g.200x9000 lines) through "C>" icon menu at top LHS of window
3. at command prompt change (use cd command) to SC directory.
4. run SC with the command "slim.exe" (I think)
5. Set the logging flag "player.source" to Info through web interface Server Settings/Advanced/Logging. Don't forget to "save settings"
6. Try to play a track - debug messages should appear in the command prompt window including socketwrapper and mplayer debug messages.
7. Copy log messages to a file (again through "C>" icon menu) , save as a txt file, zip it and attach to a post.