PDA

View Full Version : No Artists with iTunes/SS



jest
2007-10-31, 21:45
I used to run SlimServer on a Mac running as a server; my music files were stored on external HD's attached to this server. I managed the files with iTunes running on a separate Mac that wrote to the server's HD's over NFS.

I recently decided to run SS on the separate computer itself, mainly so I could create playlists in iTunes on this machine and have them available in SS. I continue to store the files on the NFS-mounted HD's.

I installed SS 6.5.4 on this Mac (running Leopard), checked the "use iTunes box", and scanned the files. While they were scanning, everything looked normal--I had a bunch of artists, they each had albums, etc. However, after the scan was finished, the artists themselves vanished--I had a message like "1000 albums with 10,000 songs by 0 artists", and if I navigated by album to a song, and it said something like "Here Comes the Sun by The Beatles from Abbey Road," and then clicked on the hyperlink at The Beatles, I'd get to "The Beatles/0 albums with 0 songs by 0 artists".

I've tried rescanning twice, with identical results--during the scan everything looks normal, afterwards the artists disappear. Any suggestions? I didn't see anything about this in the FAQ or Wiki, or in a cursory search.

jhurley
2007-11-03, 10:53
I've just reinstalled following a Vista upgrade and I have the exact same issue!

I have a fresh 6.5.4 install on a newly scanned iTunes library where Artist and Album Artist are properly populated but Slim is telling me 20,000 songs 2,500 Albums from 0 Artists.

jest
2007-11-03, 18:41
For the record: I just installed the nightly build of 6.5.5, and rescanned the library, and that fixed the problem.