View Full Version : SB3 showing the wrong time

2007-10-29, 03:30
I have a SB3 connected to a Qnap TS209, everything works well, both are good pieces of kit. However since BST ended and we're back on GMT my SB3 is still showing the wrong (old) time.

I don't know where the SB3 gets it's time from and how I configure it. So far I have logged on to the GUI for the TS209 and ensured that it's pointing to a reachable NTP server. The TS209 is able to get the correct time and logging on to the TS209 via putty and running the date command shows that it's got the correct time.

I've had a look at the SB3 and gone into as many menus as I can find. From memory I went into Squeezenetwork and I think I saw an entry for Time Format and Time-Zone. The Time-zone is correct and the time in this menu option is correct. However when the date/time screensaver kicks in I still get the wrong time displayed.

Has anyone seen this before? I'm sure the problem is probably between the keyboard and the chair.

Any help appreciated.

2007-10-29, 03:46

2007-10-29, 16:15
So to sum up what all the posts on this forum hint at, there appears to be a problem in the way that slimserver (running on a Qnap TS209) stores the timezone.

There are workarounds available, however the good that these do is rubbed out when upgrading.

From what I've read so far, this appears to have been a problem since 2006 and still isn't fixed.

I suppose I have 3 questions:

1) Is the problem with slimserver or with the Qnap firmware?

2) Why is this still a problem for so many people?

3) Who is responsible for fixing this?

2007-10-29, 16:27
Time and timezone comes from the OS, not SlimServer.

2007-10-29, 16:40
1) Is the problem with slimserver or with the Qnap firmware?

From reading the threads linked above, it looks like a problem withe the start script used by Qnap to launch slimserver.

2) Why is this still a problem for so many people?

Because no-ones fixed it yet :)

3) Who is responsible for fixing this?

As that script is supplied by Qnap (as far as I can tell) they'd have to be the ones to fix it.

2007-10-29, 16:41
So the problem lies with the Qnap OS, does anyone know if they are addressing this issue?

Thanks for the quick reply Andy

2007-10-30, 12:10
I use slimserver on a SuSE 10.3 server and with SB3. Me to, I have the wrong time, UTC instead of the timezone I have set on the Server (Yast). Could it be that the user slimserver needs its one timezone setting or that perl has an own timezone to set someware?

Fabio Vassalli