PDA

View Full Version : Non-english charcters garbled on vfat mountpoints.



eviladmin
2007-10-28, 02:37
Hi,

I've got the following setup.

SlimServer Version: 6.5.4 - 12568 - Debian - EN - utf8
Perl Version: 5.8.8 i486-linux-gnu-thread-multi
MySQL Version: 5.0.45-Debian_1ubuntu3-log

My music resides on vfat formated and mounted usb-disks.
/dev/lacie500gb on /mnt/bigdisk3 \
type vfat(rw,gid=1002,uid=1000,umask=000)[LACIE]

All folders/files with non-english chars are truncated in the webinterface.

For example
Various - 2007 - Rök Utan Eld

Shows as
Various - 2007 - R

In both the web interface and "browse music folder" with the squeezebox.

Any simple way to fix this (and keeping the vfat formating of my disk)? I haven't played around to much with diffrent settings since my wife would kill me if I destroyed her music experience or interupted it more than I already have ;-)

Is changing the LANG env-variable a good bet? I didn't find any existing threads regarding my problem.


//Eviladmin

PeterDB
2007-10-28, 05:38
Hi,

To get the disk mounted at boot-up with read/write with UTF8 support, add the following line to your /etc/fstab

/dev/lacie500gb /mnt/bigdisk vfat iocharset=utf8,umask=000 0 0


/Peter