PDA

View Full Version : Slimserver doesn't read from NTFS-partition



kei009
2007-10-20, 14:32
Hi!
I have just installed Ubuntu 7.10 and I want to setup Slimserver on the system.
The problem is that all my music is on my old NTFS-partitions and slimserver can't read from them. How shall I do to give slimserver the access to those partitions?

They have mounted up as /media/sda5 and so on. I have read and write permissions with my own user.

Mark Lanctot
2007-10-22, 07:09
But you need to give user slimserver permissions to read, not yourself.

There are ways to do this but I forget and just set permissions 777 in fstab.

aubuti
2007-10-22, 12:01
But you need to give user slimserver permissions to read, not yourself.

There are ways to do this but I forget and just set permissions 777 in fstab.
Giving everyone read/write/execute permissions is unnecessarily risky. Just imagine some bug in slimserver code that goes on to overwrite your music library. Not likely to occur, but still a possibility, and so easy to avoid....

My music files are owned by me and writable by me, and read-only for everyone else. The easiest way to do this in unix/linux is by going to the top level music directory and typing the following 2 commands. The first allows anyone to traverse the music directory tree, and only the owner can create/delete/modify that tree. The second gives r/w permission to the owner and read-only to group and world.

find . -type d -exec chmod 755 {} \;
find . -type f -exec chmod 644 {} \;

mudlark
2007-10-22, 12:35
As far as I can see gutsy is now ntfs enabled through the ntfs-3g package?

Mike.

Mark Lanctot
2007-10-22, 20:02
As far as I can see gutsy is now ntfs enabled through the ntfs-3g package?

Yes but you still need to mount the drive with proper permissions.

Mark Lanctot
2007-10-23, 09:35
Giving everyone read/write/execute permissions is unnecessarily risky. Just imagine some bug in slimserver code that goes on to overwrite your music library. Not likely to occur, but still a possibility, and so easy to avoid....

My music files are owned by me and writable by me, and read-only for everyone else. The easiest way to do this in unix/linux is by going to the top level music directory and typing the following 2 commands. The first allows anyone to traverse the music directory tree, and only the owner can create/delete/modify that tree. The second gives r/w permission to the owner and read-only to group and world.

find . -type d -exec chmod 755 {} \;
find . -type f -exec chmod 644 {} \;

Hmm, I believe I remember why I didn't do this. I tried this out, and it didn't work ("operation not permitted") until I ran it as root using sudo, and then all permissions were changed to root, so that's no good.

Oddly there were several artists whose folders weren't altered! They seem to be recent ones.

Should this have worked in Ubuntu 7.04, which normally runs as a limited-permissions user and requires super-user operations to run as root?

aubuti
2007-10-23, 11:39
Yes, it should have worked, but I suspect my post wasn't as complete as it might have been. My preferred setup is to set the user and group for my music files to my own account, e.g., user=mark and group=mark. I still do all my ripping and tagging in Windows, and then copy over to the Linux box via samba. With this setup I have full r/w access to my library using my ordinary username, which is the same on the Windows box and the Linux box. On the Linux side, slimserver (or for that matter, anyone) can read everything in the music tree, but not write to it.

Which is all a long way of saying that if you don't want to run the chmod commands as root, you need to change the ownership first. And you're likely to need sudo to change the ownership (e.g., `sudo chown -R mark:mark musiclib/'). And don't forget to make sure that the top-level directory also has the correct permissions. Sometimes I forget that.

HTH.

Mark Lanctot
2007-10-24, 05:59
Thanks aubuti, I believe this worked!