PDA

View Full Version : Problem upgrading from 6.5.0 to 6.5.1 on FC 5



Super Josh
2007-10-17, 01:57
Hi guys,
Been running 6.5.0 for an age and decided to upgrade through the various releases to get to 6.5.4. Tried to install the from the RPM and received the following error message for all of the install files

[root@SlimServer ~]# rpm -i SlimServer_v6.5.1.noarch.rpm
file /etc/slimserver.conf from install of slimserver-6.5.1-1 conflicts with file from package slimserver-6.5.0-1

Current versions are
SlimServer 6.5.0-9916-linux-EN-utf8
Perl 5.8.8 i386-linux-thread-multi
MySQL 5.0.21-standard

Does anyone have any ideas?


Thanks,

Josh

mherger
2007-10-17, 02:25
> [root@SlimServer ~]# rpm -i SlimServer_v6.5.1.noarch.rpm
> file /etc/slimserver.conf from install of slimserver-6.5.1-1
> conflicts with file from package slimserver-6.5.0-1

First of all: make sure you have 6.5.4, not 6.5.1.

Then backup /etc/slimserver.conf, move it elsewhere. Install the RPM again. If it's fine, shut down SlimServer, copy that file at its old place, restart.

Michael

Super Josh
2007-10-17, 03:12
Hi Michael,
Thank you very much for the quick response. I tried your suggestion, moved the slimserver.conf file stopped slimserver and used the 6.5.4 RPM file. But I get the same problem as before, for ALL of the installation files. So I get a whole bunch of these error messsages.

file * from install of slimserver-6.5.4-1 conflicts with file from package slimserver-6.5.0-1

Any other suggestions?


Thanks again,

Josh

mherger
2007-10-17, 03:22
> RPM file. But I get the same problem as before, for ALL of the
> installation files. So I get a whole bunch of these error messsages.

Then there's a permissions issue? Are you installing as root?

You could also try to force the installation (something like "rpm --force" - see man rpm) or uninstalling the previous version first. As long as you have slimserver.conf all your settings are save.

Michael

slimpy
2007-10-17, 03:39
I think the problem is that your package manager doesn't recognise the new rpm as a new version of the same package and thus thinks that it would overwrite files from another, unrelated package.
The easiest fix is to uninstall the 6.5.0 rmp (backup slimserver.conf first) and then install the 6.5.4 rmp.
I wouldn't use the --force option because this installs the new rpm but doesn't remove/update the 6.5.0 rpm.
You would end up with both the 6.5.0 and 6.5.4 rpms being listed as installed in your package manager.
If you later removed the 6.5.0 rpm it could cause havoc by deleting files beloging to the 6.5.4 install.

-s.

Super Josh
2007-10-17, 04:17
Thanks Guys :D that worked a treat. Uninstalled the old version and then installed the new one, copied over the conf file and all is well.

Just for anyone else trying to do the same,

I ran

rpm -qa | grep -i slimserver

to find out which version was installed

slimserver-6.5.0-1 was the reponse

then copied the /etc/slimserver.conf to a safe place

then ran

rpm -e slimserver-6.5.0-1

to unistall the old version, then ran

rpm -i SlimServer-v6.5.4.noarch.rpm

to upgrade to the latest version :)

Thanks very much,

Josh