PDA

View Full Version : SC7 on ubuntu, sox dependency problem



Ross L
2007-10-15, 17:35
Anyone have SC7 running on Debian care to help me out? I've just created a new image of Ubuntu 6.10 and trying to install Squeeze Center 7, but when I apt-get slimserver I get:

The following packages have unmet dependencies:
slimserver: Depends: sox but it is not installable

Thanks in advance if anyone can help. :)

bhaagensen
2007-10-16, 05:04
Hi,


Anyone have SC7 running on Debian care to help me out? I've just created a new image of Ubuntu 6.10 and trying to install Squeeze Center 7


Are you installing on Debian OR Ubuntu ? It's not the same thing.



, but when I apt-get slimserver I get:

The following packages have unmet dependencies:
slimserver: Depends: sox but it is not installable

Thanks in advance if anyone can help. :)


Did you enable the universe-repository? Can you try installing just sox by doing apt-get install sox. If this does not work, what is the exact output? If it does work, try installing slimserver.

Bjørn

Ross L
2007-10-25, 16:29
Thank you for the response.

I'm using Ubuntu 7.04. When I apt-get install sox I get:

Package sox is not available, but is reffered to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source
E: Package sox has no installation candidate

Mark Miksis
2007-10-25, 16:43
Do you have the universe repository enabled?

Ross L
2007-10-25, 16:45
Sorry yes, in /etc/apt/sources.list I've uncommented:

deb http://us.archive.ubuntu.com/ubuntu/ edgy universe
deb-src http://us.archive.ubuntu.com/ubuntu/ edgy universe

Mark Miksis
2007-10-25, 16:51
It should be in universe. Why are you using the edgy repositories with feisty?

Ross L
2007-10-25, 17:03
Wow I must have got my signals crossed, I'm using an older image in VMware, this is actually Ubuntu 6.10.

I'll try with the 7.10

Mark Miksis
2007-10-25, 17:04
I know sox is in universe for feisty and gutsy. I'm not sure about older releases.

Ross L
2007-10-26, 13:28
Must have just been that release, with 7.10 SC7 installed without a hitch, thanks guys. :)