PDA

View Full Version : Slimserver cannot start after latest Windows Updates



sparks451
2007-10-10, 17:04
Hello,

I just performed the following windows updates. After a reboot, Slimserver (6.5.4 and 6.5.5 nightly) no longer starts. Looking at services, Starting SlimServerSQL works but starting the Slimserver service fails to start.

FYI... I have been running flawlessly for over a month since I replaced my PC dlink wireless card. I have a hardwired Transporter and a WiFi connected SqueezeBox.

The windows updates are...
- Office 2002/XP Security Update for Word 2002 (KB942670)
- Windows XP Security Update for Windows XP (KB933729)
- Windows XP Windows Malicious Software Removal Tool - October 2007 (KB890830)
- Windows XP Cumulative Security Update for Internet Explorer 7 for Windows XP (KB939653)
- Windows XP Security Update for Outlook Express for Windows XP (KB941202)
- Office 2003 Update for Outlook Junk Email Filter 2003 (KB942571)
- Windows Defender Definition Update for Windows Defender - KB915597 (Definition 1.22.3085.0)
- Windows Defender Definition Update for Windows Defender - KB915597 (Definition 1.22.3056.0)

Any help would be greatly appreciated.

Thanks,

Sparks451

sparks451
2007-10-10, 18:56
One more thing. I unchecked "automatically start at startup and login". Restarted again. Attempted to manually start Slimserver. Internet Explorer appeared and showed the following on "http://127.0.0.1:9000/"...

-----------------------------
.NETSystem.Runtime.Remoting.RemotingExce ption: Tcp channel protocol violation: expecting preamble. at System.Runtime.Remoting.Channels.Tcp.TcpSocketHand ler.ReadVersionAndOperation(UInt16& operation) at System.Runtime.Remoting.Channels.Tcp.TcpServerSock etHandler.ReadHeaders() at System.Runtime.Remoting.Channels.Tcp.TcpServerTran sportSink.ServiceRequest(Object state) at System.Runtime.Remoting.Channels.SocketHandler.Pro cessRequestNow()
-----------------------------

mherger
2007-10-11, 00:44
Could you run "netsta -a -b" in a DOS window and see whether there's another service listening on port 9000?

Michael

sparks451
2007-10-11, 16:05
Hello Michael,

It looks like the new McAfee Data Backup utility (Ver 1.2) that I think was installed in my last Comcast McAfee SecurityCenter update (Ver 7.2). It seems to want to listen on port 9000 as well (not sure why yet). I guess it won out over SlimServer the last time I rebooted.

If I cannot disable or change McAfee's listening port, I will try to change SlimServers port.

Thanks for the suggestion.

Mark