PDA

View Full Version : andyg: Update the debian build to use our CPAN directory instead of depending on...



Mark Miksis
2007-10-08, 21:42
Just curious, what led to this change? Is it just a matter of keeping track of different version conflicts in different repos, or are there other issues?

Robin Bowes
2007-10-09, 04:07
Fletch wrote:
> Just curious, what led to this change? Is it just a matter of keeping
> track of different version conflicts in different repos, or are there
> other issues?

Fletch,

I think it was because some of the perl module versions were very
outdated on debian, and slimserver required newer versions. Andy decided
it would be easier to default to using the shipped CPAN directory.

R.

andyg
2007-10-09, 06:55
On Oct 9, 2007, at 7:07 AM, Robin Bowes wrote:

> Fletch wrote:
>> Just curious, what led to this change? Is it just a matter of
>> keeping
>> track of different version conflicts in different repos, or are there
>> other issues?
>
> Fletch,
>
> I think it was because some of the perl module versions were very
> outdated on debian, and slimserver required newer versions. Andy
> decided
> it would be easier to default to using the shipped CPAN directory.

Yeah, from a support perspective it's better if we don't allow
slightly old versions of modules that may cause subtle bugs.