PDA

View Full Version : SS not coming up in IE7, bug?



MrSinatra
2007-10-03, 10:19
hi,

i am running the last available SS for windows, and i am having a somewhat annoying issue.

many times, (almost every time) when SS starts or when it is already started and i doubleclick the systray icon, IE7 tries to load it, but goes nowhere, does nothing.

i think it may be due to the following factors:

1. the SB is connected to SN at the time.
2. localhost isn't a reliable url
3. 127.0.0.1 isn't a reliable url

i find that if i manually type in:

http://192.168.0.100:9000/

it works immediately every time.

what is going on here? i can't explain it. any ideas? fixes? is this a bug?

ceejay
2007-10-03, 11:58
Have you tried waiting a couple of minutes and then trying again? I know that with my setup (slightly older than yours) IE always starts up (and tries to connect to slimserver) long before slimserver is actually ready to talk, which would give a result like the one you're getting.

Ceejay

MrSinatra
2007-10-03, 13:22
what you just described sounds like when you're starting SS. what i am saying is it happens whether or not SS is already started.

and yeah, i've tried waiting a few minutes, and doing the systray again. it just sits. but everytime i've tried using the 192.x url, it goes there immediately without hesitation.

for instance, i just tried now. SS has been loaded for hours. double click the icon, no dice. go to 192, i'm in.

i know the old systray app had problems trying to get IE to SS before it was ready, (i reported a bug on it in fact) but afaik, bpa fixed that issue, and thats not whats happening here.

MrSinatra
2007-10-13, 22:11
can someone at least say if i should file this as a bug or not?

bpa
2007-10-14, 00:55
The doubleclick is handled by SlimTray.exe so the problem may be Slimtray or the file it reads. SlimTray will only launch SC when SlimTray believes it is running (i.e. blue writing on the SlimTray icon) and if the TCP port as specified by httpport in the prefs file is open.

Check the file "SlimServer Web Interface.url" and see if it has a valid URL and a port number that matches httpport in the prefs file. Also check access to this file.

I think you should open a bug if it is reproducible and recurs after a complete re-installation (i.e. no prefs retained). It may be systems setup issues but to a user it is a problem. There have a been sporadic postings of similar problems which may be related.

radish
2007-10-15, 06:04
If manually typing "http://localhost:9000" or "http://127.0.0.1:9000" don't work reliably then there's something up with your network config (possibly the hosts file - see http://en.wikipedia.org/wiki/Hosts_file for more).

MrSinatra
2007-10-16, 00:57
thx for the replies...

some followups...

i have never altered my hosts file. a long long time ago, when i first got SB, i had a problem very similar to this, and after an OS reinstall, it was fixed, but in that case, i HAD messed with my hosts file.

in this instance, (many parts and installs later) i have not, and i doubt any pgm has either. is it easy to check if its generic or not?

in any case...

not long after i posted this, i have had localhost and 127.0.0.1 work.

what was different, seemed to be the following:

my music is on an ext usb HD. and i use SN a lot. i think either the drive was off or asleep, or SB was set to SN, or both...

now whats odd is that as i said, the 192 addy always worked right away immediately.

so i'll try to keep better track of it.

as an aside...

SS was not loaded just now, but ST was. i clicked on it, then clicked start SS, and it did, but it never opened an IE window or tab even though (or b/c) IE was already open.

i waited a while, just to be sure, and then i double clicked ST again. this time it did open a tab, to 127 and SS, and did so even though my SB is connected to SN.

so not sure what that issue is, but it leads me to believe that my original issue is somehow tied to a problem with waking up or dealing with inaccessible USB ext drives.

thoughts?

mherger
2007-10-16, 01:28
> in this instance, (many parts and installs later) i have not, and i
> doubt any pgm has either. is it easy to check if its generic or not?

Oh, don't worry: there's enough malware out there doing it for you. Some manipulate entries for well known hosts to redirect you to their site etc.

Just post it here. It should be almost empty, with most of the entries commented out. Nothing personal - except if there's a program which altered it.

Michael

MrSinatra
2007-10-16, 01:39
in this dir:

%SystemRoot%\system32\drivers\etc\

had a few files.

'hosts' had one line:

localhost 127.0.0.1

all the other files seemed inconsequential. need them?

mherger
2007-10-16, 01:48
> 'hosts' had one line:
> localhost 127.0.0.1

That's about what I had expected. But if you can't access 127.0.0.1 then this doesn't do anything. Did you open 127.0.0.1 on your firewall, too?

Michael

MrSinatra
2007-10-16, 01:57
my firewall?

as in the XP firewall?

i am trying to access the 127 addy via the same computer running SS, do i need to make an exception in XP for it? why?

and, like i said i am now able to get IE to take me to SS via 127 or localhost.

but before, i def could not, even though 192 absolutely could.

i think its a ext usb drive sleep issue, but i need to encounter it more and pay closer attention as it occurs again.

also, regardless of this issue, ST does still seem to have issues with IE as i wrote above.