PDA

View Full Version : debian etch



dragon2611
2007-09-30, 08:00
If I install slimserver via apt-get install slimserver it works fine

However its the older 6.3 version

if I follow the instructions here http://wiki.slimdevices.com/index.cgi?DebianPackage and add the repo as suggested and install the new version

By either apt-get update
apt-get upgrade

Or apt-get remove slimserver (to remove the old one)
apt-get install slimserver

It installs the latest stable build however i'm unable to get it working due to getting the following errors...

2007-09-30 15:37:23.0540 Use of uninitialized value in negation (-) at /usr/share/perl5/Slim/Utils/Misc.pm line 1157.
2007-09-30 15:37:23.0579 Use of uninitialized value in join or string at /usr/share/perl/5.8/File/Spec/Unix.pm line 37.
2007-09-30 15:37:23.0586 Use of uninitialized value in join or string at /usr/share/perl/5.8/File/Spec/Unix.pm line 37.
2007-09-30 15:37:24.0733 Use of uninitialized value in join or string at /usr/share/perl/5.8/File/Spec/Unix.pm line 37.
2007-09-30 15:37:24.0743 Use of uninitialized value in join or string at /usr/share/perl/5.8/File/Spec/Unix.pm line 37.
2007-09-30 15:37:24.0751 Use of uninitialized value in join or string at /usr/share/perl/5.8/File/Spec/Unix.pm line 37.
2007-09-30 15:37:24.0759 Use of uninitialized value in join or string at /usr/share/perl/5.8/File/Spec/Unix.pm line 37.
2007-09-30 15:37:24.0765 Use of uninitialized value in join or string at /usr/share/perl/5.8/File/Spec/Unix.pm line 37.

I also get an error about not being able to write to /MySQL which doesn't actually exist anyway

tingtong5
2007-09-30, 12:48
Add this:
deb http://debian.slimdevices.com testing main
to /etc/apt/sources.list

run:
apt-get update

and then:
apt-get upgrade

or:
apt-get install slimserver --reinstall

Ronald.

eschurig
2007-10-02, 22:19
According to the debian download information on the slimdevices website, the new version 6.5.4 should be avalable through selecting stable. Is there just a little lag in getting everything updated for version (6.5.4) release?

What if I'm still running Sarge? Will the 6.5.4 debian package work ok or will I have dependency issues? The slimdevices wiki seems to assume sarge but etch has been out for a while now. I'm still running 6.5.0 so it's probably time for an upgrade. Everything has been working so well that I never get around to messing with it.

Thanks.

Ed

darrenyeats
2007-10-09, 12:56
Works for me...
# dpkg -l | grep slimserver
ii slimserver 6.5.4 Streaming Audio Server
#
# cat /etc/apt/sources.list
deb http://ftp.uk.debian.org/debian/ etch main contrib non-free
deb-src http://ftp.uk.debian.org/debian/ etch main contrib non-free

deb http://security.debian.org/ etch/updates main contrib non-free
deb-src http://security.debian.org/ etch/updates main contrib non-free

deb http://debian.slimdevices.com stable main


Regards, Darren