PDA

View Full Version : Some Ogg Vorbis Files Won't Play (with different results)



HalNineThousand
2007-09-28, 13:19
Here's my Slimserver info:

SlimServer Version: 6.5.3 - 12376 - Debian - EN - iso-8859-1
Server IP address: 172.16.7.2
Perl Version: 5.8.4 i386-linux-thread-multi
MySQL Version: 4.1.11-Debian_4sarge7

It's on Ubuntu Feisty Fawn.

I see that the support for Ogg Vorbis is built in to Slimserver itself, so if it does need an extra files for this, I'm missing something.

The bulk of my collection is in flac files and I have no problem with them. However, I've recently downloaded some old time radio shows from archive.org that are in Ogg Vorbis formats. I tried to play one through my Squeezebox and got an error that it could not play that file. I opened up a player on my workstation computer, which is not the same computer that runs Slimserver, and pointed it at the Slimserver mp3 stream, then tried to play the same file to that player by using the Slimserver web interface. It didn't complain about the file, but all I got was static.

These files play fine on Amarok (if you're not familiar, Amarok is a music player/jukebox program).

Is there a program I can use to analyze these files and see if there's a reason they aren't playing back? (Maybe they're flac in an Ogg wrapper or something?) What can I do to be sure that Slimserver is doing what it should with these Ogg files? Any help in tracking down this error is greatly appreciated!

bpa
2007-09-28, 13:21
Try unchecking "Ogg (built-in)" in Server Setting/Filetype and then try to play the file.

HalNineThousand
2007-09-28, 13:29
Thanks for a fast response!

It didn't make a difference, however. I made sure the only possible output stream format for Ogg was mp3, handled by sox/lame, then tried again and still got static.

Is this where I should focus on? The conversion settings? Or should I be checking any kind of formatting info?

smc2911
2007-09-28, 13:33
What version of sox have you got? This thread may be relevant: 17627.

HalNineThousand
2007-09-28, 13:34
[root@server:root]$ sox -h
sox: Version 12.17.7

smc2911
2007-09-28, 13:36
You're too fast! Read the edit of my earlier post...and it does sound like the sox version you have is too old.

HalNineThousand
2007-09-28, 13:50
1 - Out of curiosity, I saw your post and all it had was a question about which version of sox I had, then I read it again and saw the link to a thread. Did you edit it, or do you have a different way of posting so you weren't done and I thought you were?

2 - I checked, then, when I tested to see if I could upgrade, I found that the system I have Slimserver on is on Debian Sarge, which I had forgotten (with several systems, sometimes I forget which computer is setup with what!). It's scheduled for an update, the thread you linked to was a big help, so for now I'll just not listen to those Ogg files until I get that system upgraded to the new version. Considering some of the things that run that system, I'd rather not upgrade *any* software on it by hand if it has the slightest chance of breaking any dependencies.

I had searched for Ogg, but I guess I missed that thread. Thanks for pointing me to it!

smc2911
2007-09-28, 14:29
I edited my earlier post (did the search to find the post # after the initial question).

smc2911
2007-09-29, 03:19
Considering some of the things that run that system, I'd rather not upgrade *any* software on it by hand if it has the slightest chance of breaking any dependencies.
I understand your concern, but if you do want to have a try, just download the latest .deb file from http://packages.debian.org/etch/sox and install using dpkg -i <filename>. If there are any dependencies that are not met they should be flagged at this point and you may decide not to continue, otherwise I'd say it should install without doing any damage. Worked well for me a while back. Ultimately your call of course.