PDA

View Full Version : Help cant install, Ubuntu Server 6, dependants



SAS_James
2007-09-21, 04:49
Hi all can anyone help me with this below. Ive added the
deb http://debian.slimserver.com stable main to the source file

i now get this:

root@Jukebox:/dev# apt-get install slimserver
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
slimserver: Depends: libcgi-perl but it is not installable
Depends: libclass-accessor-chained-perl but it is not installable
Depends: libclass-data-inheritable-perl but it is not installable
Depends: libclass-trigger-perl but it is not installable
Depends: libclass-virtual-perl but it is not installable
Depends: libclass-whitehole-perl but it is not installable
Depends: libfile-which-perl but it is not installable
Depends: libima-dbi-perl but it is not installable
Depends: librpc-xml-perl but it is not installable
Depends: libfile-slurp-perl but it is not installable
Depends: libdata-page-perl but it is not installable
Depends: libtie-regexphash-perl but it is not installable
Depends: libpoe-perl but it is not installable
Depends: libtime-modules-perl but it is not installable
Depends: libuniversal-moniker-perl but it is not installable
Depends: libcache-cache-perl but it is not installable
Depends: libtext-unidecode-perl but it is not installable
Depends: libtie-cache-perl but it is not installable
Depends: liburi-find-perl but it is not installable
Depends: liberror-perl but it is not installable
Depends: libclass-singleton-perl but it is not installable
Depends: libfile-find-rule-perl but it is not installable
Depends: libxml-writer-perl but it is not installable
Depends: sox but it is not installable
E: Broken packages



----------------------------------

Please help.

J.

bhaagensen
2007-09-21, 06:02
Did you look at

http://forums.slimdevices.com/showthread.php?t=31536&highlight=universe+multiverse

I believe this has been asked and answered many times.

Bjørn

Mark Lanctot
2007-09-26, 11:02
Really? I'm trying to install 7.0a1 and I'm getting the exact same error messages, but universe and multiverse are enabled.

bhaagensen
2007-09-26, 14:07
I might have been jumping to conclusions, which I should know is as bad idea when it comes to computers.

What is the output of 'apt-get check' ?

If no problems are reported, does it help with 'apt-get dist-upgrade' or 'aptitude dist-upgrade' ?

Bjørn