PDA

View Full Version : Newbie: SUSE 10.1, Library Scan not working



davisford
2007-09-16, 19:31
Hi, I grabbed the RPM (SlimServer_v6.5.4.noarch.rpm) and installed it. My machine is Suse 10.1 on AMD-64.

I grabbed the SUSE scripts from here:

http://wiki.slimdevices.com/index.cgi?SuSE

I followed the directions. Had to install/tweak MySQL, but whatever..I can hit the website at http://localhost:9000

So, I have a large amount of music in /space/mp3. I set that as the dir to scan via the web-interface. I hit the re-scan button.

Nothing happens. It doesn't scan (I would hear HDD spinning), and the website reports 0 artists, 0 albums.

Can't find info on where log-file is.
Can't find much info on Linux install/help/faq.

http://wiki.slimdevices.com/index.cgi?LinuxInstallationGuide

Is pretty slim itself.

Most useful information (found via google was perhaps this):

http://wiki.slimdevices.com/index.cgi?Rescanpatch

..but tried that and still not working.

Q: where is log file, so i know what is going on?

Q: how do i tell what the progress of a dir scan is?

Thanks in advance!

Davis

Mark Lanctot
2007-09-18, 05:20
Check permissions on the MP3 directory.

Clear and rescan, but first go into Server Settings - Debugging. Set d_scan and rescan. Then read the log using the "here" link, last word at the top paragraph on the Debugging page.