View Full Version : New Airport Extreme now won't connect to slimserver

2007-09-14, 12:09
Are there any users of the new airport Extreme out there? I've been going through weeks of wireless hell and picked up the new extreme to try to get back on track. I have previously used an airport express and the older flying saucer extreme. I've been happily (for the most part) been using slim products for years now with minimal problems. I have two squeezebox 3's. a sueezebox 2 and a transporter.
My computer is a 20" IMAC Intel core duo 2 ghz which is a little over a year old. It's hooked up to a 1tb OWC external drive.
I installed the new airport with no problems. I get on the internet and continue to use internet with no problems. I then immediately start using my sueezeboxes with no problem. Then after three hours of music playing I get a complete freeze and the screen says connecting to slim server. I factory reset and I can hookup to my wireless network, I can get an IP address and then I get stuck. I'm now on the select a music source screen and instead of showing my computer it asks me to specify an address for my slimserver. I'm trying to make a long story short here but I've had multiple computer/slim problems lately and since installing the new Airport this is the first time it hasn't recoginized my computer. To make things more confusing if I keep trying it will occasionaly recognize the computer and then will connect and then freeze upon trying to play a song.
I have been in ongoing contact with Slim support and will continue. They last said to contact Apple that there is something interfering with slim communicating with the network. Apple was completely unhelpful and wouldn't speak to me about any settings/firewall or anything because the product is working fine, I'm on the net. I'm a long time Apple fan who has pretty much had it with this company.
Slim has already had me do an uninstall and re-install their software. They had me change the Airport away from N networks and on b/g networks. I'm using WPA security. I just tried running ethernet cable from the airport to my computer and then to the squeezebox nearest my computer and I'm still stuck with the same situation detailed above. I toggled my Airpoprt off and tried to hook up through ethernet.
If anybody has any suggestions or if I'm leaving out any critical info on settings,etc. please let me know.
Of course immediately after posting this I turn around and my squeezebox is finding my computer and after a few clicks of the remote is now playing in wired mode. I then wired the transporter and they have both been playing for a song so we'll see. It doesn't have my whole apartment back on track with wireless but some music is better than no music!

Ross L
2007-09-14, 15:05

Sorry to hear about the frustrations, wireless just isn't always a perfect solution. Is permanent Ethernet possible?

2007-09-14, 16:46
Permanent ethernet is only possible(and not pretty) for half of my apartment. I understand that wireless is not always possible but the biggest frustration is that I've run wireless with no problems in the same place with the same system for almost a year and a half. I ran wireless for over a year in my old house with no problem using the older Airport and Macs. So I know that it is completely possible and do-able.
I really think it's just a matter of going over the setup with someone familiar with the new Airport extreme. It has a new utility that the older extreme and Airport Express that I have succesfully used did not have. The new utility has a much wider variety of settings and I am unforunately not much of a tech expert. I searched the forum for Airport before posting and didn't come up with too much info. I thought maybe a thread detailing the settings etc. on the new Airport would be a service to others down the road and get me back working.
As I said I'm also going through Slim customer service who have never failed me yet. Although I see that you're from Slim so I hope this doesn't mean it's time to throw in the towel! They've taken the time to listen to the problem and detailed how to switch form the n to the b/g networks. Unfortunately that hasn't done it and it doesn't appear that they're familiar with all of the ins and outs of the settings and menus of the new Airport. The Apple manual and Airport help doesn't appear to explain the different settings even if I were to understand the explanations. I'll try to search around more on the Apple website but understanding detailed wireless network settings is tough going when you're not a computer expert.
My plan is to run wired for a little while just to make sure that runs smooth. Then I'm at least partly on track and I can hear some music. Once that's established hopefully there is someone out there that has some suggestions and we can get to the bottom of it.

Ross L
2007-09-14, 17:04

It's very possible that the wireless failure is out of your control. It could be due to neighboring wireless networks, or some new microwave, too many things can cause wireless networks to fail. Just because it worked yesterday doesn't mean it will work today. I use a Squeezebox via wireless in my garage and most of the time it works perfectly, but sometimes it simply will not work. The wireless works in the rest of my house but not in the garage, sometimes. I've turned appliances off and on and even asked my neighbors, yet still I have no idea what causes the failure.

In my opinion, the only practical solution to my problem is an Ethernet cable. I realize that in some situations, wireless networks simply don't work as well as I want them to.

2007-09-14, 20:16
Thanks for taking the time to reply. I understand the quirkiness of wireless networks and interference. The problem with it being unable to connect to slimserver just struck me as being an Airport not letting slimserver in or kicking it out issue. But my wireless problem is now at the bottom of a long list.
I'm about ready to go out and change every piece of equipment that I own because just minutes ago I had slimserver go black, this time through the wired connection! This is actually the issue that started all of my recent computer grief. I hit a key to wake my IMAC out of sleep and it was frozen for a minute. The screen blinked and then the computer was operational. Then it says that my firewire drive was improperly disconnected. I shut the drive off for a minute, turned it back on and music is currently playing.
A couple of weeks ago everything was fine until this very same thing happened. Sometimes the crash would be as described above and other times it would be a complete lock up and I would have to hold the power button down and shut off just to get the computr to respond at all.
I checked the Macintosh forums and there are reports of Airports doing this very thing. The Imac forums have reports of IMAC's also doing this very thing. To confuse even further there are reports on the forum that the last software update 10.4.10 is also crashing people similarly. This update is on the IMAC but not the powerbook. So is it the IMAC or the Airport?
Last week I called Apple and I'm ready to bring the IMAC in per their recommendation. Then I read the mac forums and think maybe it's the Airport so I try hooking up my external drive to my powerbook and run slimserver through that. This puts the IMAC out of the picture with the powerbook running through the airport. I then shockingly (to me) get the same exact crashes more than once. I then figure it has to be the Airport so I switch from my old Airport Extreme to an Airport Express and get the same problem. I then buy a new Airport Extreme N and I thought the crashing problem was done with. This brings us to today and this post. After one day the crashes are back. The mac forums for the new Airport Extreme believe it or not mention the same exact problem! One person says even with the airport turned off and it just being used as a router! This is how I had it set up with Airport off on my last crash.
So I'm trying to think of my next step here before I lose my mind. I picked up a Linksys 5-port workgroup switch. I'm thinking about trying this with the IMAC or maybe the powerbook first to try to get to the bottom of this. My ethernet cables are fairly new but I'm so paranoid at this point I may buy all new cables. Anybody out there have any ideas at all on this madness?

2007-09-14, 22:03
Ron --

Yikes, sorry to hear of your problems. I recently switched to a Airport Extreme from an Airport Express, too. I had some dropout problems from my microwave, but once I switched to Channel 1 from automatic, they all went away. I did get some strange crashes a while back, but completely erasing every trace of Slimserver and reinstalling seems to have done the trick. So, now everything is working much better (though I do get the odd crash on my G4, but it restarts almost instantly). I connect a Transporter and a couple of SB3s.

It is hard to say exactly what caused my crashes as I installed a new Airport Extreme, and upgraded to Mac OS X 10.4.10 and Slimserver 6.5.4 all at about the same time (so much for the scientific method!)

Here's a couple of things to try...

1) Full erase of Slimserver. Just right clicking on the Slimserver icon in the Systems Preferences pane isn't a couple uninstall -- there are a few other files here and there that need cleaning up. In particular, it seems that the cache files can really muck things up.

Here's a list of the files that you need to delete along with deleting the Slimserver icon from the System Preferences. These are all in your home Library directory and you can easily navigate to them:/

[username]/Library/Caches/SlimServer (trash the entire SlimServer folder)

But wait to reinstall Slimserver until you have done the following Airport Extreme step...

2) Another problem that you may be having is that you are not getting a static IP address for your iMac G5 (or whatever machine you are running Slimserver on). The Slim players seem to be happiest when the Slimserver always has the same IP address (this may not be strictly necessary, but is safer). Also, you should be sure that you have DHCP set up correctly, too. The AirPort Extreme allocates IP addresses in kind of a strange way (from highest to lowest) -- a big difference from the Airport Express.

Start the new AirPort Utility, find your AirPort Exreme and choose manual config. Then select the "Internet" tab at the top of the screen. On the first tab, "Internet Connection", make sure that the bottom drop-down, "Connection Sharing", is set to "Share a public IP address"

Then, you need to reserve a static IP address for your iMac G5 (and another for your Powerbook if you ever use that). Since I have three possible servers, I have three reserved address (see attached jpeg). Hit the + under DHCP Reservations, and give a Description (ie. iMac G5) and select reserve address by MAC address. On the next screen, fill in the MAC address of your iMac (you can get this by going to System Preferences-Network-Show AirPort and looking at the AirPort ID). Pick an IP address in range (see the attached JPEG as an example).

Save these changes and your Airport Extreme will reboot. To be extra safe, unplug all of your Slim players, and reboot your iMac, too (so it picks up the new IP address).

Then reinstall Slimserver (a clean install), then power up your Slim players and run through the network setup so that you can enter the correct new static IP address for the Slimserver.

Try this and let me know how it goes...


2007-09-14, 22:42
Ross --

Just as I was writing the above post, my Slimserver running on my G4 Cube crashed briefly, then restarted. Here's the log entry:

2007-09-14 21:40:10.8164 Backtrace:

frame 0: Slim::Player::Source::errorOpening (/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Player/Squeezebox2.pm line 579)
frame 1: Slim::Player::Squeezebox2::failedDirectStream (/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Slimproto.pm line 527)
frame 2: Slim::Networking::Slimproto::_disco_handler (/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Slimproto.pm line 387)
frame 3: Slim::Networking::Slimproto::client_readable (/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Select.pm line 238)
frame 4: (eval) (/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Select.pm line 238)
frame 5: Slim::Networking::Select::select (./slimserver.pl line 493)
frame 6: main::idle (./slimserver.pl line 446)
frame 7: main::main (./slimserver.pl line 1072)

There are also two identical earlier entries on my G5.

Here's something similar looking from my MacBook Pro

2007-09-12 12:45:07.2037 Backtrace:

frame 0: Slim::Player::Source::errorOpening (/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Player/Source.pm line 1666)
frame 1: Slim::Player::Source::openSong (/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Player/Source.pm line 1146)
frame 2: Slim::Player::Source::gotoNext (/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Player/Source.pm line 403)
frame 3: Slim::Player::Source::playmode (/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Player/Source.pm line 1036)
frame 4: Slim::Player::Source::jumpto (/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Control/Commands.pm line 1103)
frame 5: Slim::Control::Commands::playlistXtracksCommand (/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Control/Request.pm line 1483)
frame 6: (eval) (/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Control/Request.pm line 1483)
frame 7: Slim::Control::Request::execute (/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Control/Request.pm line 772)
frame 8: Slim::Control::Request::executeRequest (/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Web/HTTP.pm line 705)
frame 9: Slim::Web::HTTP::processURL (/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Web/HTTP.pm line 555)
frame 10: Slim::Web::HTTP::processHTTP (/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Select.pm line 238)
frame 11: (eval) (/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Select.pm line 238)
frame 12: Slim::Networking::Select::select (./slimserver.pl line 499)
frame 13: main::idle (./slimserver.pl line 452)
frame 14: main::main (./slimserver.pl line 1076)

Any ideas what might be causing this? (Do you think the fact that I have "Block UDP Traffic" turned on have anything to do with this?)


Eric Seaberg
2007-09-15, 08:06
Just to let you know it all DOES work... I've got a new Extreme (.11N) and an older AirPort (.11B/G) running on different channels and setup as different networks. My SB3 in the master bedroom sees the Extreme just great, especially since the Extreme is in the attic at the top of the house. The B/G is used for non-N Macs downstairs, yet everything is connected to a router to handle IP addresses.

It does sound to me like you're not setup properly to address from the Extreme. Since I'm using a router, the IP management of both of my AirPorts is OFF, allowing the router to handle it. If you're not too keen to setup static addresses like someone said above, it may be worth getting a cheap LinkSys router to handle addresses. You can usually find them for $50 or less.

2007-09-15, 10:11
One other idea. I noticed that the DHCP lease is set only to 4 hours (see the jpeg in my earlier post) Maybe this is causing the short dropouts? I changed it to 10 days.

2007-09-15, 13:18
Thanks for the replies and suggestions. I was just about to ditch the Airport for a little while and try a simple hardwire Linksys switch to hook up just a transporter and one squeezebox. Muski's suggestions had me feeling brave so I just gave it a shot and now I'm pretty disgusted.
I'll start from the beginning:
-I had already changed the channel setting to channel one because that is what worked best with the previous Airports.
-I then did the full de-install (I had previously done this). I waited to install the slimserver and shifted over to the Airport utility.
-I confirmed that it was set to share public IP address
-I then reserved a static IP for the IMAC using your instructions. I got the mac address by by going to System Preferences-Network-Show AirPort and looking at the AirPort ID. I didn't do the powerbook at the same time, I'll have to add it later. Hopefully this isn't a problem. I'm only trying it on the IMAC right now. I got a bit confused here and didn't realize that the powerbook would show a different address by doing the same thing in it's system preferences.
-Here's where I continue to mess up. I saved the changes and the Airport restarted. I unplugged all my slim players but I didn't reboot the IMAC. I just realized that I didn't reboot the IMAC after I had already installed slimserver, started it running and plugged all of the players back in. I started to connect to slim on my first Squeezebox and realized. So I'm now I really don't know where I'm at.
-While in Airport utility I changed the DHCP lease to 10 days. Mine was also preset to 4 hours. In poking around through the settings I went to Airport tab>clicked wireless options button and I see a WPA group key timeout set to one hour? I have absolutely no idea what this is but thought I'd mention it. Here are some settings I copied down from the Airport:
- IPV4 Address:
- DHCP Range: 10.0.1......the one was selected in a drop down menu
-DHCP beginning address

Some Current settings from the slimserver (still unbooted mac):
DNS Server:
Obtain IP: Auto
IP Address:
Thanks for trying to help me out but I'm not sure where I'm going from here.

2007-09-15, 16:52
No big deal about not rebooting the iMac -- you won't need to reinstall. Just unplug all your slim players and reboot your iMac. Then plug in each of your players and do network setup for each of them.

2007-09-15, 18:55
My IMAC crashed again after my last post so I uninstalled slimserver. Interestingly it hasn't crashed since. I think I'll see if that keeps up into tomorrow and evaluate if I'm going to go straight back into Airport hell or not. I may try the Linksys switch first to see if my IMAC runs slimserver without crashing for a while. I'm interested to see if there are no IMAC crashes with the Airport out of the picture completely.