PDA

View Full Version : RandomMix not working



ysub
2007-09-12, 04:35
Hey,

Not sure where else to get help so here I go, I'm running Slimserver 6.2.2 on a LinkStation. My RandomMix used to be working fine but now when I go to do a random song mix (album mix is fine incidently) it SAYS it's playing random mix but nothing plays and nothing appears in the playlist. I have approx 13000 tracks.

Here is the log text (also attached). Any ideas? Oh one further note DURING a rebuild of the library (fairly early on) it functions correctly.

2007-09-10 19:19:53.0373 DBD::SQLite::st execute failed: disk I/O error(1) at dbdimp.c line 419 at /mnt/slimserver/CPAN/DBIx/ContextualFetch.pm line 51.
2007-09-10 19:19:53.1127 Whoops! prepare_cached() or execute() failed on sql: [SELECT DISTINCT tracks.id AS id,tracks.multialbumsortkey AS multialbumsortkey,tracks.thumb AS thumb,tracks.age AS age,tracks.remote AS remote,tracks.ct AS ct,tracks.audio AS audio,tracks.titlesort AS titlesort,tracks.album AS album,tracks.tracknum AS tracknum,tracks.url AS url,tracks.tag AS tag,tracks.title AS title,tracks.disc AS disc,tracks.fs AS fs FROM tracks, genre_track, genres WHERE genre_track.track = tracks.id AND genres.id = genre_track.genre AND ( genres.name IN ( ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ? ) AND tracks.audio = ? ) ORDER BY RANDOM() LIMIT 10] - [DBD::SQLite::st execute failed: disk I/O error(1) at dbdimp.c line 419 at /mnt/slimserver/CPAN/DBIx/ContextualFetch.pm line 51.
]
2007-09-10 19:19:53.1321 Backtrace:

frame 0: Slim::DataStores::DBI::DataModel::find (/mnt/slimserver/Slim/DataStores/DBI/DBIStore.pm line 307)
frame 1: Slim::DataStores::DBI::DBIStore::find (/mnt/slimserver/Plugins/RandomPlay/Plugin.pm line 44)
frame 2: Plugins::RandomPlay::Plugin::findAndAdd (/mnt/slimserver/Plugins/RandomPlay/Plugin.pm line 246)
frame 3: Plugins::RandomPlay::Plugin::playRandom (/mnt/slimserver/Plugins/RandomPlay/Plugin.pm line 387)
frame 4: Plugins::RandomPlay::Plugin::handlePlayOrAdd (/mnt/slimserver/Plugins/RandomPlay/Plugin.pm line 410)
frame 5: Plugins::RandomPlay::Plugin::__ANON__ (/mnt/slimserver/Slim/Buttons/Input/Choice.pm line 187)
frame 6: Slim::Buttons::Input::Choice::callCallback (/mnt/slimserver/Slim/Buttons/Input/Choice.pm line 156)
frame 7: Slim::Buttons::Input::Choice::__ANON__ (/mnt/slimserver/Slim/Hardware/IR.pm line 662)
frame 8: Slim::Hardware::IR::executeButton (/mnt/slimserver/Slim/Control/Command.pm line 253)
frame 9: Slim::Control::Command::execute (/mnt/slimserver/Slim/Player/Client.pm line 996)
frame 10: Slim::Player::Client::execute (/mnt/slimserver/Slim/Hardware/IR.pm line 675)
frame 11: Slim::Hardware::IR::processCode (/mnt/slimserver/Slim/Hardware/IR.pm line 493)
frame 12: Slim::Hardware::IR::processIR (/mnt/slimserver/Slim/Control/Command.pm line 253)
frame 13: Slim::Control::Command::execute (/mnt/slimserver/Slim/Player/Client.pm line 996)
frame 14: Slim::Player::Client::execute (/mnt/slimserver/Slim/Hardware/IR.pm line 88)
frame 15: Slim::Hardware::IR::idle (./slimserver.pl line 606)
frame 16: main::idle (./slimserver.pl line 565)
frame 17: main::main (./slimserver.pl line 1196)

kdf
2007-09-12, 07:59
On 12-Sep-07, at 4:35 AM, ysub wrote:

>
> 2007-09-10 19:19:53.0373 DBD::SQLite::st execute failed: disk I/O
> error(1) at dbdimp.c line 419 at

fairly scary bit right there. could it be that your hard drive is
spinning down?
that might explain a read error out of nowhere, while also allowing
things to work during scanning (lots of drive activity to keep it
active)
-kdf

ysub
2007-09-12, 08:56
Yeah I agree. I/O doesnt sound good. I wondered if it was a problem with one of the files that it was scanning that was causing something wierd in the database file.

Don't know what to do to be honest. I could try doing a RandomMix while also doing some other disk activity but I have a funny feeling it's not going to make any difference.