PDA

View Full Version : Can't create tunnels in PuTTY



4mula1
2007-09-11, 03:46
I'm not sure where else to look for help on this one, so I'll post here...

My parents have SlimServer running on their XP box, mainly for my mom to stream online radio. I wanted to stop their SlimServer and open Putty and create a tunnel so I could stream from my SlimServer at home (I can successfully stream). Whatever I do I cannot get a usable tunnel in Putty. I know how to create them, and have done it successfully many times. I just can't do it with theirs. If I use IE to try to view my SlimServer over the tunnel I get a Page Cannot Be Displayed error when I try localhost:9000 and when I try 127.0.0.1:9000 it either keeps trying to connect or gives the same error as localhost, I can't quite remember now.

As an experiment, I went home and created a similar setup on my XP box (I run my SlimServer on another machine running Solaris) and created a tunnel on ports 3483 and 9000 to the SlimServer box. I then manually entered the IP address of my XP box in one of my SB3s and like magic everything worked. As expected.

My parents and I both run XP SP2 with Norton 2007. As far as I can tell both firewalls are good to go.

Any ideas what will make tunnels in Putty not work? I can login to my Solaris box fine, so Putty itself can connect.

mflint
2007-09-11, 03:54
It's worth remembering that the "Tunnel Destination" setting (either "Remote" or "Local") is from the perspective of the SSH Server, not of the PuTTY client.

(It caused me much head-scratching when I first tried tunnelling)

Matthew

OldeSchule
2007-09-11, 06:27
(looking at the PuTTY window as I'm typing this...)
- Open SSH (frame on the left side of the Putty connection window)
- Click on "Tunnels"
- Keep the top 2 checkboxes unchecked
- Enter 9000 in the "Source Port"
- Enter (ip of your XP box):9000 as Destination
- Keep defaults of "Local" and "Auto"
- THEN click the "Add" button
- Click back on Session in the left-hand frame
- Enter the IP address or DNS name
- Optionally, enter a name and save it
- Click "open"

Just did this yesterday to stream from my SlimServer box at home to WMP on my desktop at work...

4mula1
2007-09-11, 06:43
It's worth remembering that the "Tunnel Destination" setting (either "Remote" or "Local") is from the perspective of the SSH Server, not of the PuTTY client.


I'll have to check that. Both at home and work when I use Putty I leave that to "Local" and it seems to be fine. I think that's what it was on my parent's computer but I'll have to double check.

I just tried it at work and found something interesting. Firefox can connect to both localhost:9000 and 127.0.0.1:9000 while IE cannot.

I never tried to stream with my parents SB3 because I could never get the browser to work. I'll have to download Firefox and see if that works.

OldeSchule
2007-09-11, 06:54
You should also be able to point your player of choice (Windows Media, VLC, etc.) directly at the streaming URL:
http://localhost:9000/stream.mp3

Then point your browser to http://localhost:9000 and go from there.

I'm able to hit locahost:9000 from IE (6.0.2900 on XP) and Firefox both...

OldeSchule
2007-09-11, 13:40
Just thought of one other thing... Do you have port 22 enabled inbound on your firewall? You said you could open a terminal session via putty - was that from your parents'?

4mula1
2007-09-11, 18:05
I'll know more on Thursday when I can get my hands on their computer...

4mula1
2007-09-13, 16:02
This turned out to be the strangest thing...

I turned off Windows Firewall, disabled as much of Norton 2007 as I could, and it still wouldn't work. WTF?!?

I ended up getting tired of typing in the IP address of my system at home so I added an entry to the hosts file. Once I did that, everything started working. I turned the firewall and Norton back on and everything still worked, so it looks like it was all to do with not having an entry in the hosts file.

Very bizarre...