PDA

View Full Version : how to wipe database?



Phil Leigh
2007-09-10, 16:27
Could someone please advise how to completely clear the database for version 6.5.4 (Windows XP)
Spent a whole evening getting nowhere fast trying to upgrade!
Many thanks
Phil

haunyack
2007-09-10, 16:33
Could someone please advise how to completely clear the database for version 6.5.4 (Windows XP)
Spent a whole evening getting nowhere fast trying to upgrade!
Many thanks
Phil

Hi Phil,
This is how I do it.
Shut down slimserver from Task Manager...look for Slim.exe,Slimtray.exe,mysqld.exe,scanner.exe,possi bly any codec that may be in use.
Delete the contents of the following -

\\Documents and Settings\<user>\Local Settings\Temp\pdk-<user>

\\Program Files\SlimServer\server\Cache

\\WINDOWS\Temp\pdk-SYSTEM

Cheers!

.

Phil Leigh
2007-09-10, 16:41
Hi Phil,
This is how I do it.
Shut down slimserver
Delete the contents of the following -

\\Documents and Settings\<user>\Local Settings\Temp\pdk-<user>

\\Program Files\SlimServer\server\Cache

\\WINDOWS\Temp\pdk-SYSTEM

Cheers!

.

Thanks Haunyack - I'm trying that now...hopefully I can fix this strange duplicate track problem once and for all (never a problem under 6.3.x)

Phil Leigh
2007-09-11, 00:25
OK so I managed to wipe the database. Then - to be doubble sure - I rescanned pointing at an empty folder. Sure enough - O tracks by 0 artists...


Details: SS 6.5.4, XP, flac files across 3 drives (e, f,g). E is set as the music folder in SS. There are NO shortcuts or playlists anywhere. I have MusicIP.


Then I did a rescan. All seems ok at first and then I can see that all albums on drive e are fine, but those on f & g are coming up with entire sets of duplicate tracks - each track has 3 identical entries!

This is driving me bananas as I really want the speed of 6.5.x I have never had this problem with 6.3.x or earlier!

Any ideas? - why isn't drive E affected?
many thanks
Phil

haunyack
2007-09-11, 07:40
OK so I managed to wipe the database. Then - to be doubble sure - I rescanned pointing at an empty folder. Sure enough - O tracks by 0 artists...


Details: SS 6.5.4, XP, flac files across 3 drives (e, f,g). E is set as the music folder in SS. There are NO shortcuts or playlists anywhere. I have MusicIP.


Then I did a rescan. All seems ok at first and then I can see that all albums on drive e are fine, but those on f & g are coming up with entire sets of duplicate tracks - each track has 3 identical entries!

This is driving me bananas as I really want the speed of 6.5.x I have never had this problem with 6.3.x or earlier!

Any ideas? - why isn't drive E affected?
many thanks
Phil


Hmm..interesting.
Maybe isolate MusicIP (disable in SS) then do another wipe & scan.
I also use MusicIP (full version) but had so much misery running it as a service that I disabled it in SS and run it as a standalone only.

.

Phil Leigh
2007-09-11, 11:09
Hmm..interesting.
Maybe isolate MusicIP (disable in SS) then do another wipe & scan.
I also use MusicIP (full version) but had so much misery running it as a service that I disabled it in SS and run it as a standalone only.

.


Finally cracked it after 20 rescans!

This makes no sense - but it worked:

I had shortcuts in e: to F: and G:

I deleted the shortcuts and made G:\ the music Folder. Then I scanned and all was fine (but only a third of my collection showed up obviously)

Then I added a shortcut in G: to E: and one to F: - rescanned - looks good.
Finally did a complete wipe and all still OK plus the gallery thumbnails now work.

So - excellent! 6.5 is now working and is WAY fasteer than previous versions!

Thanks all for your help.

haunyack
2007-09-11, 13:53
Finally cracked it after 20 rescans!

This makes no sense - but it worked:

I had shortcuts in e: to F: and G:

I deleted the shortcuts and made G:\ the music Folder. Then I scanned and all was fine (but only a third of my collection showed up obviously)

Then I added a shortcut in G: to E: and one to F: - rescanned - looks good.
Finally did a complete wipe and all still OK plus the gallery thumbnails now work.

So - excellent! 6.5 is now working and is WAY fasteer than previous versions!

Thanks all for your help.

Cool..
Now you're cookin' with <insert genre here>

Possible that your shortcut targets went recursive?
Strange indeed.

.