PDA

View Full Version : SlimServer on SUSE Linux



jclausius
2007-09-08, 22:32
I'm trying out SUSE Linux for the slimserver. The RPM doesn't seem to be installing correctly. I used --force and the files are there, but the daemon is not starting.

I tried to manually start the slimserver daemon in /etc/rc.d/init.d/, but it gives me the following errors:

./slimserver: line 12: /etc/rc.d/init.d/functions: No such file or directory
./slimserver: line 15: .: /etc/sysconfig/network: is a directory
./slimserver: line 22: [: =: unary operator expected
Usage: ./slimserver {start|stop|restart|status}


What is the slimserver script looking for in functions and network? I think if I knew this I would be able to modify the shell script.

Thanks,
Jeff

bpa
2007-09-09, 01:19
Did you check the Wiki for advice depending the SuSe version ? Read all of the relevant entry as usually there are late additions/edits at the end of an entry

http://wiki.slimdevices.com/index.cgi?SuSE

jimflanagan
2007-09-10, 08:31
bpa wrote:
> Did you check the Wiki for advice depending the SuSe version ?
>
> http://wiki.slimdevices.com/index.cgi?SuSE
>
>
>
The script on the Wiki works great on my opensuse 10.2 box. BUT, the
Wiki fails to mention that you have to make the script executable. Do
that and it should work flawlessly. You should be able to start
slimserver manually, or with yast. Use yast to have it start
automatically in runlevel 5 (and or 3).

Cheers,

Jim F

jclausius
2007-09-10, 08:45
Did you check the Wiki for advice depending the SuSe version ? Read all of the relevant entry as usually there are late additions/edits at the end of an entry

http://wiki.slimdevices.com/index.cgi?SuSE

I didn't look throught the Wiki; just through this posts on this forum. I'll give this a try, and post back my results.

TIA,
Jeff

jclausius
2007-09-14, 08:03
The WIKI article worked like a charm. I don't know if it was necessary, but I went ahead and set the executable bit for user and group.

I'm up and running.

Thanks for everyone's help.

Jeff