PDA

View Full Version : gapless flac playback doesn't work (6.5.4 debian/ubuntu)



ephemere
2007-09-01, 16:34
I've been using slimserver for years on windows, streaming flac files gaplessly to my SB1 and SB2 with no trouble.

I just switched from windows to ubuntu, in the process upgrading from (I think) 6.5.1 to 6.5.4. There are now small gaps of a fraction of a second between all tracks. This happens on both my SB1 and SB2. This must be due to one of the following:

[A] an option I didn't set (I don't think this is the answer)
[B] the move from windows to ubuntu
[C] the move from 6.5.1 to 6.5.4

Any ideas? I hope there's a solution because this is a critical feature regression for me.

ephemere
2007-09-01, 18:25
Mystery solved. The reason turned out to be

[D] I had the two squeezeboxes synchronized

Apparently, gapless playback doesn't work with synchronization. I had never tested this before, since I rarely synchronize my squeezeboxes. I don't know if this is a known issue.

aubuti
2007-09-01, 20:02
Yes, it's a well-known issue. When synchronizing SBs, slimserver re-syncs at the beginning of each track, to correct for the SBs drifting out of sync. There is work being done on improving synchronization, but I don't know for sure if improvements there will spillover into making sync+gapless a possibility.

ephemere
2007-09-02, 13:58
Not an important feature for me. When I sync my SBs it's usually because I want background music all over the house, and a small gap isn't so critical for background music.