PDA

View Full Version : Help with Slimserver installation



cavediver
2007-09-01, 13:45
I just bought a Squeezebox yesterday and downloaded the Slimserver software today. After installing the software, I get an error message that scanner.exe has encountered a problem and needs to shut down. When I try to rescan my music files, slimserver shuts down. I'm running XP Pro on a Dell Optiplex 620. I have installed, removed and re-installed the software four times and get the same error each time.

Siduhe
2007-09-01, 15:02
What antivirus/security software are you running? McAfee/Norton? Try adding an exception for scanner.exe as well as slim.exe.

cavediver
2007-09-01, 17:41
What antivirus/security software are you running? McAfee/Norton? Try adding an exception for scanner.exe as well as slim.exe.

I am running etrust antivirus. I set the exceptions and re-installed slimserver and still got the same error message.

alZmtbr
2007-09-01, 19:00
Do you have a firewall running? The ports (9000, 3483) must be allowed in the local zone.

ie slimserver and scanner must have access from 127.0.0.1 (localhost).

HTH!
~A

cavediver
2007-09-01, 21:17
Do you have a firewall running? The ports (9000, 3483) must be allowed in the local zone.

ie slimserver and scanner must have access from 127.0.0.1 (localhost).

HTH!
~A

I just have windows firewall running on the computer and my lan is behind a Linksys router. I just tried installing slimserver on another computer on my network and encountered the same problem. Ports 9000 and 3483 are listed in the exceptions in the Windows Firewall settings on both computers.

davep
2007-09-01, 23:23
Try something simple first - turn off/disable both your antivirus and your firewall and see what happens. If you get SlimServer and your SB to work properly then you reactivate each of the disabled programs and see which one is the culprit.

On the firewall you need TCP and UDP exceptions for one of the two ports and, since I can never be bothered to remember which I have TCP and UDP set for both.

davep

cavediver
2007-09-02, 08:21
Try something simple first - turn off/disable both your antivirus and your firewall and see what happens. If you get SlimServer and your SB to work properly then you reactivate each of the disabled programs and see which one is the culprit.

On the firewall you need TCP and UDP exceptions for one of the two ports and, since I can never be bothered to remember which I have TCP and UDP set for both.

davep

I've done all this on both computers and the scanner still quits with the error. I'm at a loss as to what is the problem.

davep
2007-09-02, 15:40
I've done all this on both computers and the scanner still quits with the error. I'm at a loss as to what is the problem.

OK, maybe we are looking at the wrong thing here. If the problem is that after some period of scanning your music files the system quits could it be a problem with something in the music files directory, such as a recursive playlist?

Could you try putting a few music files into a new clean directory and pointing Slimserver at this and doing a scan? If this completes and you can navigate and play music with the SB then it might help show that the SS installation is OK but the problem lies elsewhere.

davep

cavediver
2007-09-02, 17:28
OK, maybe we are looking at the wrong thing here. If the problem is that after some period of scanning your music files the system quits could it be a problem with something in the music files directory, such as a recursive playlist?

Could you try putting a few music files into a new clean directory and pointing Slimserver at this and doing a scan? If this completes and you can navigate and play music with the SB then it might help show that the SS installation is OK but the problem lies elsewhere.

davep

I've actually done just what you suggest. I started out with a freshly formated snap server 2200 as a nas on my network and ripped one cd, (12 wave files), to it in wave file format. When I couldn't get it to work, I copied the 12 files to a freshly formated 300 gb usb drive directly attached to the main computer were I had loaded slimserver. It still didn't work (scanner.exe error). Then I copied the 12 files directly on the computer under the my music folder. Still got the scanner error. Then I loaded the slimserver on another computer on my network that I use for back-ups and I copied the 12 files under on that computer under the my music folder. Still got the exact same error. I've checked the security settings on both computers to make sure the required ports were allowed, which they were; apparently automatically when slimserver was installed. I've checked all the settings on my router and there's nothing I can see that would be blocking the scanner.

I was really pleased when I set up the squeezebox and it connected to the wireless and downloaded the firmware update. Slimserver was seeing the squeezebox, but the slimserver software just doesn't seem to work.

davep
2007-09-02, 21:42
Just for the record, what version of Slimserver are you running (details can be found at the foot of the page when you click on "Server Settings")?

davep

MikeFish
2007-09-03, 00:31
A corrupt copy of Slimserver? Try downloading a fresh copy or even a different version.

cavediver
2007-09-03, 06:00
Just for the record, what version of Slimserver are you running (details can be found at the foot of the page when you click on "Server Settings")?

davep

Version 6.5.4-12568
Pearl version 5.8.8
MySQL version 5.0.22

I just downloaded it on Saturday morning.

cavediver
2007-09-03, 06:01
A corrupt copy of Slimserver? Try downloading a fresh copy or even a different version.

I actually did this. I downloaded a new copy on a different computer, but still get the same error. How do I get a different version than the latest version on the website?

davep
2007-09-03, 06:40
If you go to http://www.slimdevices.com/downloads/nightly/SlimServer_6_5_x_v2007-09-03/ this will get you today's build of 6.5.4.

davep

cavediver
2007-09-03, 12:32
If you go to http://www.slimdevices.com/downloads/nightly/SlimServer_6_5_x_v2007-09-03/ this will get you today's build of 6.5.4.

davep

I just downloaded and installed this latest version. I got the scanner.exe error before I even opened slimserver into the browser.

adamslim
2007-09-03, 15:09
Try calling Slim support direct - they do view these forums, but not that regularly. They should be able to sort you out.

http://www.slimdevices.com/su_tech.html

cavediver
2007-09-03, 18:31
Try calling Slim support direct - they do view these forums, but not that regularly. They should be able to sort you out.

http://www.slimdevices.com/su_tech.html

I plan to do that tomorrow. I was visiting a friend tonight listening to music being played on his Squeezebox. I asked if he had any problems with the software, which he hadn't. He had just purchased the Squeezebox, downloaded and installed Slimserver on Saturday, the same day I downloaded the software. So I figure, since the problem is happening on two computers on my network, there must be something inside my network that is conflicting with the software.

cavediver
2007-09-04, 21:46
Thanks everyone for your gracious help.

I finally got Slimserver working tonight. After spending quite a bit of time on the phone with tech support this afternoon and running several manual scans, all ending with a scanner.exe error message and reviewing the log files, I began to think that maybe the music files were corrupted. I had originally ripped the test CD (Dead Can Dance; Aion) with Ashampoo into wav files. I deleated the original music files and re-copied them with Exact Audio Copy using error corection into wav files. After re-copying the CD using EAC, the scan worked and the Squeezebox woke up showing the music files. I hit the play button and voila'; Wireless audio nirvana. Thanks again for your help.