View Full Version : Strange Slimtray & web interface behaviour

2007-09-01, 11:54
So, I recently got a new computer which has vista on it (mentioning vista is never way to start a problem post is it...?).

My problems are *simliar* to the ones outlined in the sticky Vista problem thread, but not quite the same.
The services seem to run fine. Both MySQL and Slim services run on automatic and seem to start ok.

The slimtray loads, however if I right click and select 'open slimserver' to access the web interface it will close (the services will keep running fine and so does slim.exe). If I select 'stop slimserver' the service will stop (and so will the CPU usage from the scanfrom slim.exe) but slim.exe will keep running.

If I load the tray from the shortcut placed on the desktop by the installer the slimtray will load for 2 seconds then close again. If I remove the '--start' from the shortcut slimtray will load fine, but close as soon as I select 'open slimserver'.

Trying to load the webinterface via localhost:9000 web address in firefox or IE results in a permentantly 'connecting' or 'loading' blank page.

Any thoughts? I'm at a complete loss.


Have tried installing as an administrator, changing the way services load (delayed, or at login rather than startup). Tried the nightly builds (including v7). Added slim, slimtray, mysql, scanner and socketwrapper to windows firewall and defender. Also added ports 9000 and 7843 to the firewall and router.

The ports on my router are currently forwarding to the slimserver on my pc, do they need to be forwarded to the squeezebox's ip too?

Oh, also my SB3 won't connect even tho Vista says the services are running. Finds the network and gets an IP fine, just won't connect to my PC where the slimserver is.

Edit: Getting this error in cmd when I try to run slim.exe

c:\Program Files\SlimServer\server>slim.exe
2007-09-10 19:58:29.5199 Use of uninitialized value in transliteration (tr///) at /<c:\Program Files\SlimServer\server\slim.exe>File/Spec/Win32.pm line 103, <DATA> line 164.
2007-09-10 19:58:29.5206 Use of uninitialized value in pattern match (m//) at /<c:\Program Files\SlimServer\server\slim.exe>File/Spec/Win32.pm line 105, <DATA> line 164.

Then it just hangs...

2007-09-10, 12:24
Uninstalled my antivirus, Eset's NOD32, and it all works. Grrr! Of all the things >_<

Edit: Reinstalled my antivirus after slimserver and all is fine!