PDA

View Full Version : Album View Never Displays



wodehouse
2007-08-26, 17:26
First order of problem is that unless I am on the actual computer that is my SlimServer, the Browse Albums View never displays. Browser indicates it is loading then.... stops and leaves me at Home. (Even when on the SS itself, this view is very slow.

All other views snap right up.

Second question -- I've got a file named cover.jpg in virtually all my album folders. When I traverse to an album, SS displays the art. But when I look at the Browse Album windows (on those few occasions when it shows!) I only get the default Folder icon.

Any thoughts anyone? I have just upgraded to 6.5.4 - 12568 with no effect.

Other thoughts:
* My library is on a UNC drive, slimserver runs as user with access (not as system).
* debug artwork shows:
<snip>
ERROR: Error executing 'SELECT contributor.id, contributor.name, contributor.namesort, contributor.musicmagic_mixable, contributor.namesearch, contributor.musicbrainz_id FROM contributor_album me JOIN contributors contributor ON ( contributor.id = me.contributor ) WHERE ( ( ( role IN ( ? ) ) AND ( me.album = ? ) ) ) GROUP BY contributor.id ORDER BY role desc': DBD::mysql::st execute failed: Can't create/write to file 'C:\WINDOWS\TEMP\#sql_17c4_0.MYD' (Errcode: 13) at C:\Program Files\SlimServer\server\CPAN/DBIx/Class/Storage/DBI.pm line 771.

ERROR: Backtrace follows:

Backtrace:

frame 0: Slim::Schema::Storage::throw_exception (C:\Program Files\SlimServer\server\CPAN/DBIx/Class/Storage/DBI.pm line 773)
frame 1: DBIx::Class::Storage::DBI::_execute (C:\Program Files\SlimServer\server\CPAN/DBIx/Class/Storage/DBI.pm line 826)
frame 2: DBIx::Class::Storage::DBI::_select (C:\Program Files\SlimServer\server\CPAN/DBIx/Class/Storage/DBI/Cursor.pm line 118)
frame 3: DBIx::Class::Storage::DBI::Cursor::all (C:\Program Files\SlimServer\server\CPAN/DBIx/Class/ResultSet.pm line 945)
frame 4: DBIx::Class::ResultSet::all (C:\Program Files\SlimServer\server/Slim/Schema/Album.pm line 166)
frame 5: Slim::Schema::Album::artistsForRoles (C:\Program Files\SlimServer\server/Slim/Schema/Album.pm line 176)
frame 6: Slim::Schema::Album::artists (C:\Program Files\SlimServer\server/Slim/Schema/Album.pm line 124)
frame 7: Slim::Schema::Album::displayAsHTML (/<C:\Program Files\SlimServer\server\slim.exe>Slim/Web/Pages/BrowseDB.pm line 424)
frame 8: Slim::Web::Pages::BrowseDB::browsedb (/<C:\Program Files\SlimServer\server\slim.exe>Slim/Web/HTTP.pm line 843)
frame 9: Slim::Web::HTTP::generateHTTPResponse (/<C:\Program Files\SlimServer\server\slim.exe>Slim/Web/HTTP.pm line 709)
frame 10: Slim::Web::HTTP::processURL (/<C:\Program Files\SlimServer\server\slim.exe>Slim/Web/HTTP.pm line 555)
frame 11: Slim::Web::HTTP::processHTTP (/<C:\Program Files\SlimServer\server\slim.exe>Slim/Networking/Select.pm line 238)
frame 12: (eval) (/<C:\Program Files\SlimServer\server\slim.exe>Slim/Networking/Select.pm line 238)
frame 13: Slim::Networking::Select::select (slimserver.pl line 499)
frame 14: main::idle (slimserver.pl line 42)
frame 15: PerlSvc::Startup (perlsvc line 850)
frame 16: PerlSvc::_startup (slimserver.pl line 0)
frame 17: (eval) (slimserver.pl line 0)

Select task failed: Carp::Clan::__ANON__(): Error executing 'SELECT contributor.id, contributor.name, contributor.namesort, contributor.musicmagic_mixable, contributor.namesearch, contributor.musicbrainz_id FROM contributor_album me JOIN contributors contributor ON ( contributor.id = me.contributor ) WHERE ( ( ( role IN ( ? ) ) AND ( me.album = ? ) ) ) GROUP BY contributor.id ORDER BY role desc': DBD::mysql::st execute failed: Can't create/write to file 'C:\WINDOWS\TEMP\#sql_17c4_0.MYD' (Errcode: 13) at C:\Program Files\SlimServer\server\CPAN/DBIx/Class/Storage/DBI.pm line 771.

</snip>

Nattlorden
2007-08-27, 22:31
I'm struggling with a similar problem - that I don't get anything when choosing the Album view. Artist always seems to work though.

I've removed most my albums and I got it working with only a few, fixed one issue (I was trying to have one extra level below album name with CD1 & CD2) but when I keep adding one by one (starting new database from scratch every time) it suddenly fails. Don't look like there's any odd characters or so...

Do I have to dig deeper than looking at directory level - like going into the tags? Do directory name and album tag have to match for instance?

Or is there a bug allowing only around 15 albums before failing?

SlimServer is 6.5.4 running on XP (Swedish flavour if that has any relevance).

Any one who resolved their issues out there?

snarlydwarf
2007-08-27, 22:35
ERROR: Error executing 'SELECT contributor.id, contributor.name, contributor.namesort, contributor.musicmagic_mixable, contributor.namesearch, contributor.musicbrainz_id FROM contributor_album me JOIN contributors contributor ON ( contributor.id = me.contributor ) WHERE ( ( ( role IN ( ? ) ) AND ( me.album = ? ) ) ) GROUP BY contributor.id ORDER BY role desc': DBD::mysql::st execute failed: Can't create/write to file 'C:\WINDOWS\TEMP\#sql_17c4_0.MYD' (Errcode: 13) at C:\Program Files\SlimServer\server\CPAN/DBIx/Class/Storage/DBI.pm line 771.



The error is "Can't create/write to file 'C:\WINDOWS\TEMP\#sql_17c4_0.MYD"

The most common reason for failing to write to a Mysql file is ... your Antivirus software. Tell it to stop messing with .MYD files.

wodehouse
2007-08-30, 21:42
Thanks, but AV software was disabled when I captured the log file... I'd picked up that item on other threads while researching before posting.

Cold it have anything to do with the library being on a unc link instead of local drive?

Siduhe
2007-08-31, 01:32
Thanks, but AV software was disabled when I captured the log file... I'd picked up that item on other threads while researching before posting.

Depends what your AV software is. McAfee, Norton and Zone Alarm (to name but a few) still remain active in several ways even when you disable them and would still block this kind of "on access" scanning of files. Would definitely try adding the exceptions and then doing a full clear and rescan just to be sure (if you haven't already).

McAfee can be a particular issue as even when you add exceptions, it doesn't recognise them (in some cases) without a full reinstallation.