View Full Version : size mismatch installing on Debian 4.0r0

2007-08-25, 23:18
I just installed Debian 4.0r0 on a machine and I am trying to install slimserver with "aptitude install slimserver". Part way through the install, I get

E: Failed to fetch http://ftp.debian.org/debian/pool/main/libp/libpath-class-perl/libpath-class-perl_0.15-1_all.deb: Size mismatch

For Ubuntu you just point to a previous repository. What would you point to for straight debian? I've tried several other repositories, but I get the same error.

2007-09-06, 20:57

I have the same problem while trying to install with 'apt-get install slimserver'.

Tried installing the package alone:

apt-get install libpath-class-perl

and it output this:

Reading package lists... Done
Building dependency tree... Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
Need to get 32.9kB of archives.
After unpacking 81.9kB of additional disk space will be used.
Get:1 http://ftp.debian.org etch/main libpath-class-perl 0.15-1 [32.9kB]
Fetched 1B in 5s (0B/s)
Failed to fetch http://ftp.debian.org/debian/pool/main/libp/libpath-class-perl/libpath-class-perl_0.15-1_all.deb Size mismatch
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Already tried with '--fix-missing' parameter but is still fails because of 'Size mismatch'

I installed Debian 4.0r1 with the NETINST CD i386.

2007-09-06, 23:24
Hi again,

I got around the libpath-class-perl problem by adding Lenny testing repository.

On the /etc/apt/sources.list file, I added deb http://http.us.debian.org/debian/ testing main contrib non-free , and I disabled every other repository, so it looks like this:

# Repositorio de siguiente version de Debian (Lenny) (testing)
deb http://http.us.debian.org/debian/ testing main contrib non-free

# Paquete de slimserver
# deb http://debian.slimdevices.com stable main

# deb http://ftp.debian.org/debian/ etch main
# deb-src http://ftp.debian.org/debian/ etch main

# deb http://security.debian.org/ etch/updates main contrib
# deb-src http://security.debian.org/ etch/updates main contrib

After saving the file, execute the following:
apt-get update
apt-get install libpath-class-perl

After the package is installed, return your /etc/apt/sources.list to normal (without Lenny repository), and install as normal:
apt-get update
apt-get install slimserver

Hope this helps!

2007-09-12, 21:59
That does it for me. Thanks.