PDA

View Full Version : Dependency problems upgrading to SS 6.5 on Debian etch



Coen Giesberts
2007-08-24, 00:01
Hi,

I am running Debian etch and I have installed slimserver 6.3.0 which comes along with etch. When I try to upgrade slimserver to version 6.5.4, using the debian package on the slimdevices site, I get the following error:

The following packages have unmet dependencies:
slimserver: Depends: libmysqlclient14-dev but it is not installable or
libmysqlclient15-dev but it is not going to be installed
E: Broken packages

When trying to install for example libmysqlclient15-dev, it turns out that is has to do with zlib1g:

The following packages have unmet dependencies:
zlib1g-dev: Depends: zlib1g (= 1:1.2.3-13) but 1:1.2.3.3.dfsg-5 is to be installed


Any suggestions? Thanks!

Dougal
2007-08-25, 09:19
I'm not sure about your dependency probs but I would do a --purge remove slimserver then an install as there have been big changes between 6.3 and 6.5.

Doug.

Coen Giesberts
2007-09-10, 01:59
I removed the old slimserver package. Installing debian package slimserver_6.5.4_all.deb is not possible, according to the following message:

# dpkg -i slimserver_6.5.4_all.deb
Selecting previously deselected package slimserver.
(Reading database ... 125800 files and directories currently installed.)
Unpacking slimserver (from slimserver_6.5.4_all.deb) ...
dpkg: dependency problems prevent configuration of slimserver:
slimserver depends on libcgi-perl; however:
Package libcgi-perl is not installed.
slimserver depends on libmp4-info-perl; however:
Package libmp4-info-perl is not installed.
slimserver depends on libyaml-perl (>= 0.57-1); however:
Package libyaml-perl is not installed.
[...]
slimserver depends on libnet-upnp-perl; however:
Package libnet-upnp-perl is not installed.
slimserver depends on libxml-simple-perl (>= 2.15-1); however:
Version of libxml-simple-perl on system is 2.14-5.
slimserver depends on libdbix-migration-perl; however:
Package libdbix-migration-perl is not installed.
slimserver depends on libyaml-syck-perl (>= 0.41-1); however:
Package libyaml-syck-perl is not installed.
slimserver depends on libmysqlclient14-dev | libmysqlclient15-dev; however:
Package libmysqlclient14-dev is not installed.
Package libmysqlclient15-dev is not installed.
dpkg: error processing slimserver (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
slimserver

Can SS 6.5.4 be installed on etch, or is a different version of Debian required?

Ben Sandee
2007-09-10, 06:38
On 9/10/07, Coen Giesberts <
Coen.Giesberts.2wospz1189414801 (AT) no-mx (DOT) forums.slimdevices.com> wrote:
>
> Can SS 6.5.4 be installed on etch, or is a different version of Debian
> required?


Yes it absolutely can be used with etch. dpkg does not resolve dependencies
for you, it merely enforces them. If you insist on using dpkg and not
apt-get or synaptic then you will need to download each required .deb from a
repository and use dpkg to install them before installing the slimserver
..deb.

Or you can follow these instructions, which is a much simpler process

http://wiki.slimdevices.com/index.cgi?DebianPackage

Ben

Coen Giesberts
2007-09-11, 01:24
Yes it absolutely can be used with etch. dpkg does not resolve dependencies
for you, it merely enforces them. If you insist on using dpkg and not
apt-get or synaptic then you will need to download each required .deb from a
repository and use dpkg to install them before installing the slimserver
..deb.

Or you can follow these instructions, which is a much simpler process

http://wiki.slimdevices.com/index.cgi?DebianPackage

Ben

I have tried using apt-get, but that gave broken packages, so I hoped to be able to enforce installing using dpkg. Using apt-get will give a broken packages error:

The following packages have unmet dependencies:
slimserver: Depends:
libmysqlclient14-dev but it is not installable or
libmysqlclient15-dev but it is not going to be installed
E: Broken packages

Coen Giesberts
2007-09-11, 01:41
I think I see what is going on:

$ apt-get install libmysqlclient15-dev zlib1g-dev
The following packages have unmet dependencies:
zlib1g-dev: Depends: zlib1g (= 1:1.2.3-13) but 1:1.2.3.3.dfsg-5 is to be installed
E: Broken packages

$ apt-show-versions zlib1g
zlib1g 1:1.2.3.3.dfsg-5 newer than version in archive

Apparently I have zlib1g from lenny (testing). I think I must have had "testing" in my apt-sources and switched it back to "etch" after etch became stable. I will upgrade to lenny, as that seems to upgrade slimserver package as well.

Thanks for your help.

Coen Giesberts
2007-09-11, 03:58
I have finished the upgrade to lenny and slimserver 6.5.5 has now been installed successfully. Me happy again ;-)